Issues flashing bios from unreleased Dell Vostro 7590 i9 gtx 1650

For CSME firmware, the region types are “Region, Stock” (RGN) and “Region, Extracted” (EXTR). RGN are pure from Intel w/o any configuration. EXTR is anything that has been outputted by FIT in general.

You can just input an RGN into FIT and immediately output it. That’s still an EXTR even if you never actually configured anything. For CSME 12 FWUpdate tool, you actually need to do that, as explained at the (CS)ME thread. You need to input a CSE firmware & combine it with PMC w/o adjusting any settings (because FWUpdate tool does not deal with those). It will show as “File System Configured” afterwards but it doesn’t mean that the included configuration is proper for a given system. Before CSME 12, it was easier to tell because you basically knew that EXTR were probably configured for some system. But now an EXTR firware might actually be an RGN which was merged with PMC via FIT and then outputted for FWUpdate use, so it might not be configured for any system.

Remember that Engine firmware within Dell HDR are for use with FWUpdate so either RGN for pre-CSME 12 or EXTR (RGN-ish + PMC) for CSME 12+. None hold actual model settings and they cannot be used at the CleanUp Guide or similar.

A rule of thumb for CSME 12: if you see an Engine region ($FPT) attached to PMC, it’s probably an “non-actually-configured” image for FWUpdate. If you see a CSE region (does not start with $FPT, were the Engine region used to be at the SPI Flash Descriptor images) then it should contain proper model settings.



Thank you for the detailed explanation, I will try to absorb and remember. ME FW always so confusing, more so now with V12, configured and extracted means neither, they need to keep it in a straight line!
Could that kind of detection be noted/changed to say something else in MEA, so it’s less confusing for V12, or does this really only apply with Dell or other FW UPD images (or something you’re in the middle of rebuilding manually)?

A stock/RGN firmware always has an Unconfigured File System. A dirty/Extracted firmware always has either a Configured or Initialized File System. An Initialized EXTR obviously has actual model configuration. A Configured EXTR could be anything really. Maybe a properly configured firmware for a specific model, maybe a simple RGN/EXTR + PMC merger to create an image for FWUpdate tool etc. All these are valid/possible File System configurations but we can’t know if they’re setup for what we want or not. This is why relying on mnemonics and rule of thumb practices is preferred. For this case, if you see a CSME 12 $FPT firmware with PMCP firmware included, then it’s destined for FWUpdate use. The stock/RGN $FPT from Intel don’t pre-include PMCP and the actual Engine (CSE) region of the SPI image is not in $FPT form. So seeing $FPT + PMCP is a pretty easy way to tell.

Thanks again, makes it easy to tell, hopefully I can remember this

The cpu seems to be running normally on a alienware adapter. Going above 800mhz, with speedstep disabled sticking at 2.1ghz as it should. , before i was getting a power adapter error although it was a dell and the same watts as the original.

I tried throttlestop to try to control the cpu but not doing much if at all, actually it makes it worse most of the time

Is there a way to unlock the multiplier or set it base multiplier to 3.9ghz instead of 2.1ghz? I’m assuming we aren’t anywhere near that. When benching, turbo doesn’t stay at a high frequency and scores are lower than expected since its averaging 2.6ghz

One thing I did notice is the igpu nor the gpu will run 3d applications, it says no direct3d device although it shows compatible in dxdiag

Here is a picture of the bios, seems the same as the normal bios. I forgot to take more but its pretty much the same, nothing different.

the microcode did update according to AE, is that the latest revision? it didn’t register as a i9, im sure it is a ES but its a P0 so I believe its a early revision and not a QS

@bobcatchris - We may be able to mess with turbo, but lets get you onto a more final BIOS before I look into any of that.

Thanks for BIOS image, that is Dell BIOS “look” not AMI type. I’ll look this over and see what I can do as far as unlocking things or making things visible to you etc
For that, I need to see images of each individual section and all settings shown to you in each, but for this lets wait until we get stock BIOS region in there.

Yes, CPUID 906EC latest microcode is Rev AE (2/14/2019). ES/CPU often only show what you see in the BIOS as far as model name, same in CPU-z, sometimes on later ES more closer to actual retail it will show the retail model name and correct details but still be shown as ES too.
Here, lets see what retail ME FW does on this system - First dump current BIOS with programmer, then put this on with programmer, then once done remove all power from the system (remove power cables, and CMOS) then let sit for one full minute, then put cables and battery back.
If it fails to boot, program back in new backup, and we’ll test if adding stock BIOS region is required for that ME FW to work properly next if this one fails. Then if both those fail, we’ll know the PRE PCH can’t work with the retail ME FW

Never mind, see below! I suppose he probably told me that previously too and I forgot or overlooked it

BIOS region swap coming in below soon!

Brick. Pre-Production PCH works only with PRE or BYP firmware, not PRD.

Ahhh, thank you for the heads up! Is that always? IF yes, then nothing we can do further at ME FW? What is BYP, is it any better than PRE?

Since we have ME FW working now, I guess only thing left to do is test stock BIOS region swapped in, and then unlock any hidden settings if possible

* Edit @bobcatchris - After this process, please run MEInfoWin -verbose again and make sure ME FW is functioning properly, if not we’ll first need to redo the manufacturing mode edit to 04 again, then if it still fails that may mean stock BIOS can’t work with PRE PCH/PRE-ME-FW.
I did not make this edit now, because I wanted to see what stock BIOS set to 0 does (Some areas it’s already set to 4, others to zero) This is stock BIOS region swapped in + your old NVRAM x2 in there and another volume too.
This may not run properly aside from any possible ME issues I’ve mentioned, due to NVRAM stuff, but I wanted to test it first and see the outcome, before sending you file without NRAM volumes…209928906325487

Be ready to recover!

Yes, always. PRE/BYP firmware are signed with a different RSA key. The signature is validated upon Engine boot and the CPU won’t initialize if the former fails. Using the same for PRD and PRE/BYP would have been a big security problem.

BYP is ROM-Bypass which is used at Alpha PCH when the hardware is not ready yet and may require booting the Engine ROM from the flash instead of the PCH.

For this issue, as I said earlier, it is my belief that the disablement is at the FD or BIOS with the latter being much more probable. In such case, there is nothing more to do at the CSME other than cleanup.

its bricked after flashing it, won’t turn on

i tried bios recovery but the light flashes red when i attempt to turn it on, i can’t even get there

I’ll have to wait for the bios flasher

Anything I can try to get this back on?

plutomaniac We already have ME enabled now, I was only considering that as a move to try and get him onto full retail BIOS. I enable the ME via BIOS edit, manufacturing mode to 04 instead of 03
Here’s MEInfoWin - verbose and -fwsts output after that enablement (from post #35) -

@bobcatchris - very sorry to hear! Do you mean BIOS in #48 did this? If so, I did not expect, but it’s probably due to the old NVRAM and new BIOS differences.
I thought you had programmer already too? When will it arrive? No, sorry, nothing you can do to fix until you have programmer in hand, unless you can boot to DOS
Once you get recovered I’ll rebuild you another BIOS with stock stuff, but rebuild NVRAM with it’s setup entry instead of your old one, so the BIOS settings will match up properly

I received it today, never used anything like this before. Would you mind helping me out with instructions?

@bobcatchris - here is a guide with plenty of images to help you get setup and familiar with using
[GUIDE] Flash BIOS with CH341A programmer…341A-programmer << Same as one directly above, but with all images expanded/visible at once

And here is software and main driver package…257455007472602

As soon as you open any version of the software, go to the auto function button and uncheck Erase + Blank check, that way nothing gets accidentally erased.

Get verified and valid dumps before you write anything, this means verified by the program and valid by checking in BIOS tools yourself and see that file looks similar to other BIOS files you’ve been using (or have someone else check for you).
This is to make sure the software isn’t “verifying” a empty FF or 00 file, this happens sometimes when it’s not reading properly.

Once you are ready to write something, this is the process I use >>> Erase, then blank check both manually, then open BIOS file, then hit Auto (with only write + verify checked)

I get this error

file length beyond range of will be ignored

I think im trying to flash the wrong bin, which file should i be trying to flash?

nevermind its back alive! YAY!

I’m ready for the bios with the stock stuff when you get a chance

Great you sorted that out! Sounds like you were trying to flash wrong file to wrong chip
Give me a bit, if you’re still here now, and I will make you new test file

* Edit @bobcatchris - Here, as quick test, before I spend any unnecessary time rebuilding NVRAM, test this semi-stock BIOS (without populated NVRAM, only stock StdDefaults)
Be ready to recover, ie program back in last successful BIOS test with programmer if this fails (BCPManuMode04testH.bin) to 16MB chip

If it runs, great, I will rebuild NVRAM and try to get that sorted out properly. If it fails, there is some other reason causing it, maybe one of the other volumes I copied out from the original BIOS, and I’ll have to rebuild the entire BIOS again and see if we can find the cause.
Before I do that, if we get to that, I’ll have you test straight stock BIOS programmed in but wait for me to give you that because it’s not a stock file like you are thinking or have already.

yes i am still here

yes i did try to flash the wrong chip, thankfully that clip would not stay on long enough on that wrong chip for me to mess it up :slight_smile:

Thank you!

it posted, bios looks the same, did -greset after as well

fan seems to be louder, just got into windows

need me to run anything to check

gpu is still being strange, this is possible the vbios i pulled with the ch314a while trying to figure out the right bios chip

vBIOS you already sent me a GPU-z dump, but yes that is it (both GPU-z and this dump incorrectly sized though, but nothing we can do there anyway)
It’s possible fan settings are different now, and or this is due to NVRAM. Can you see ME FW version in BIOS or with HWINFO or MEInfoWin? If yes, it’s not an ME issue and then we know this ME is OK with stock BIOS.
Great it’s posting, I’ll rebuild the rest of the NVRAM and see if we can get that in there now too, that should possibly help with some things. Give me some time on this, it may take a day or so

-greset only needed if we’re changing the ME FW (FYI, so you don’t always spend time doing that)

That sounds awesome! Thank you

Just a thought

it should be possible to flash the vbios of this gpu, its a QS, there is another dell model with almost exactly the same ID 10de 1f91 1028 9222, mine is 10de 1f92 1028 9222

I know its considered risky but its not really doing much right now, i flashed some cards before and they ended up fine. I have no idea where to find the vbios for it, i been looking but it hasnt been uploaded anywhere

i read they can possibly be fixed with the programmer since its not dual bios like desktop gpus

Here is winme

no me options or status in bios