Laptop shuts off after 30 minutes

Hi guys, I’ve been pointed here from a thread on reddit. I have an acer aspire v5-131-2629 running windows 7 64bit. 30 minutes after boot it shuts off and I have pinned it down to being a MEI problem. I have no idea when the problem started or what was done to the laptop prior to this problem occurring, but I’m hoping I can help you guys help me get it solved.

As I’ve said, I believe it is a problem with the MEI because it happens no matter if I am booted into windows or just the BIOS. I downloaded the tools from the stickied post and ran a few functions that were recommended to another user with a similar problem by plutomaniac. However when I run these programs I get an error code and based on what I’ve deducted from the post I’ve been reading, that’s not a good sign.

I’ll attach the error logs and hopefully someone can help me comprehend them.

fptw64.txt (569 Bytes)

meinfo.txt (3.34 KB)

memanufwin64.txt (881 Bytes)

What CPU is currently installed at that system? Due to a forum bug, please compress to an archive and then attach the text file reports.

It is a Intel Celeron 1007U 1.5ghz. My initial thought was somebody swapped the CPU but that “U” at the end means it’s soldered to the board so that’s out of the question. I am at work right now but will re upload those files once I get home.

Worst case scenario if I can’t get it fixed I can swap the mobo but would rather try to get this one fixed first. Thanks for your reply!

Here is the compressed version of those error logs. From what I can understand from them the ME device is either physically broken or has bad firmware. And I think it is write protected but correct me if I’m wrong.

Error Reports.rar (1.74 KB)

The CPU is indeed BGA so that couldn’t be the issue. It seems that the ME firmware is corrupted and a reflash is needed after following the Engine CleanUp Guide. You have no read/write access to the Engine region of the SPI chip via software solutions. Do you have a hardware programmer which can dump and reflash the SPI chip?

Darn I was expecting that answer but was hoping to not hear it. I don’t have a programmer and it’ll probably be more cost effective to just swap the mobo. I can’t find my exact model mobo online but found one with a 1.1ghz processor. It’s the same mobo version and goes in the same laptop just a different class of that laptop. I assume windows will automatically update the CPU drivers upon login, if not they can be updated in device manager and I should be good to go right?

I wonder what caused the firmware to get corrupted like that. Maybe a failed update or something?

It could be due to bad update but it can also happen by itself sometimes. Replacing the mobo is the last resort in my opinion, especially when you’ll also be downgrading the (already weak) CPU. You can try the pinmod method. If your system has a Realtek Audio chip, you need to turn off the laptop, short pins 1 & 5 of the audio chip (starting from the dot) and power on the system. Release the shortcut once the OS starts to load. This works 100% but is not easy to perform because the audio chip pins are very small and you need to keep them shorted for a few seconds while the system starts. Then try to dump the SPI chip firmware. Remember that this method works until the next reboot so if you’re successful, you should follow the CleanUp Guide and flash before any other restarts.

How small is small? Think I could wire a momentary switch to it with some 30g wire? That will give me write access to the engine right? I’ll give that a shot maybe this weekend I’ll let you know how that goes. Thank you for your help sir, much appreciated

The pins are small but you can short them with a thin conductive wire and the method will certainly work as it’s the official method to unlock read/write access on the field. You can google “realtek audio chip” to see some image examples of what you’ll be dealing with. If you know the Realtek audio chip name we can also look online to see if a datasheet is available which will verify that the required pins are indeed 1 & 5 but based from experience, it’s always them for Realtek. Other audio chip manufacturers use their own pinout.

After Google searching, it does have a realtek chip! I’ll crack her open this weekend and give it a shot. After doing that I can follow the clean up guide and I should be good to go right? I didn’t see the clean up guide before I made this post which is why I had so many questions, my apologies!

When you have access to the machine, you can use something like Speccy tool to see the actual Realtek chip model so that we can verify pins 1 & 5 and be 100% sure. As for the Engine firmware cleanup, you have to dump the SPI image (“fptw -d spi.bin”), follow the guide and flash the result back (“fptw -f outimage.bin”) followed by a ME reset (“fptw -greset”). After the restart, everything should be proper (verifiable by MEInfo & MEManuf tools).

My realtek chip is the ALC271X I wasn’t able to find a datasheet for that model though. I’m gonna go ahead and try with the 1 and 5 pin anyways and hope that works. I will still only have 30 minutes to get done what need a to be done before the computer shuts off right?

There is a datasheet for ALC272 and once again it is pins 1 & 5. You definitely need to short these two. Yes, you’ll have 30 minutes after being successful before the system restarts due to the ME firmware corruption. You can however enable read/write access for good after performing the “pinmod” by reflashing the SPI image with the Flash Descriptor unlocked as follows:


That way, you won’t have to do the “pinmod” again after the system restarts.

Hey I’ve been working on this for a few days now but can’t seem to find a solution. I have the firmware dumped and cleaned but when I went to flash it back I got an error 28. I heard I can make a DOS USB I can run a program called prr.exe to enable write access. Although I cannot find this prr.exe anywhere on the internet. Any ideas man?

So you were successful in performing the “pinmod”. What is error 28? If it’s about BIOS Protected Range Registers, you can just reflash the Engine firmware region and not the entire SPI chip. Open the result SPI image of the CleanUp Guide (outimage.bin usually) with UEFITool and “Extract as is…” the ME region. Then use Flash Programming Tool with command “fptw -rewrite -me -f me.rgn” followed by “fptw -greset”.

Yes I was successful with the pin mod. I used some .03125" SS wire ground to a point and a VEEEERY expensive magnifier setup from work to short it out, God it was small!. But yes the error is with the protected range registers. I’ll give what you said a shot today when I get off work. Also if you ever need any machine work done let me know I’ll give you a $100 credit for your help

Thanks again man, this worked for flashing it. Now to go to walmart for some taco stuffs while I wait to see if it’ll last over 30 minutes now. Booted to the desktop right now so so far so good lol. Thanks again for all your help man, I really appreciate it. Enjoy this virtual beer

So unfortunately the laptop still shut off after 30 minutes. I’m just gonna swap the mobo at this point I’m not sure what else could be causing this problem. I appreciate your help through all this though man

A motherboard replacement shouldn’t be required. Can you compress and attach the new MEInfo -verbose & MEManuf -verbose reports again to see if the ME firmware is indeed repaired? Also, compress & attach the dumped SPI image and the one after performing the CleanUp Guide to try it on my end as well and double check.

Here are those files you asked for. From what I understand the firmware is still no good correct? Is there a repository where I can just grab the ME firmware for my chip and then reflash the ME with that? Also I am starting to get pretty good at this pinmod lol.

meinfo.txt (2.33 KB)

memanuf64.txt (912 Bytes)

spis.rar (5.18 MB)