Legacy on ES1-132

Hi,how can i enable Legacy boot on ES1-132?

@rodrisbx - I assume you mean this BIOS??? https://www.acer.com/ac/en/ID/content/support-product/6975;-;
I checked BIOS 1.26 -

Boot Mode:, VarStoreInfo (VarOffset/VarName): 0x79, VarStore: 0x1234, QuestionId: 0xA015, Size: 1, Min: 0x1, Max 0x2, Step: 0x0 {05 91 0C 05 0D 05 15 A0 34 12 79 00 04 10 01 02 00}
One Of Option: UEFI, Value (8 bit): 0x2 (default) {09 07 0E 05 10 00 02}
One Of Option: Legacy, Value (8 bit): 0x1 {09 07 0F 05 00 00 01}

Use this guide to learn about using and booting to grub and setup_var, you can start at step 5-6, since I’ve gathered the info for you above
[GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash
Alt boot to grub when no boot to EFI on exit page, you will need to use this method to boot to grub >> [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

At grub prompt type the following to change default UEFI boot to Legacy Boot >> setup_var 0x79 0x1

I´ve get an Can´t modify variables on efi error

Show me image of the command given and the error, so I can see it all on same screen.

@Lost_N_BIOS The error of the photo

15574758918216383093641714607128.jpg

@rodrisbx - Thanks, sometimes this happens. Lets check to confirm it didn’t apply, do setup_var 0x79 by itself, and see if it tells you offset = 0x1 or not (If not, then we need to try other way, or I make you mod BIOS which is probably easier)
If it’s not 0x1 - then download the Intel ME System Tools package V3 from section C2 in this thread - Intel Trusted Execution Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Win64 folder. Select that Win64 folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTW64.exe -bios -d biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
https://www.windowscentral.com/how-add-c…creators-update
https://www.windowscentral.com/add-open-…menu-windows-10
https://www.laptopmag.com/articles/open-…ator-privileges

Also, immediately after you successfully run the command above and get the biosreg.bin file, test writing it back using command below, so we can see what if any error that gives you
If error, show me image of command entered and error given. If any error before flashing, stop, do not try to proceed, show me command given and error
FPTW64.exe -bios -f biosreg.bin

@Lost_N_BIOS he gives me an 0x2

Flash Programming Tool gives me an : error 397 there was a communication error between fpt and the TXE

I think that error happens cause i don´t have the TXE driver…

Now i´ll try to install it :slight_smile:

@lost_n_bios i was on Windows 8.0 x64,but now i’m updating to win10 x64 to install the txe driver

@rodrisbx - Again, please edit your posts if you need to add a new thought, you do not need to make several posts in a row, thank you.

Yes, you need to install the correct TXE ME FW drivers before you can use FPT, sorry I forgot to mention this. You do not need to update to Win10, and I would suggest against that personally, Win8 is bad enough.
Since Acer seems to only offer the “Win10” driver, download the V3 Win8-Win10 version from this thread - Intel Trusted Execution Engine: Drivers, Firmware & System Tools

For when you get there , FPT MUST Be ran from an Admin Command prompt as I mentioned above, it cannot run from regular command prompt or power shell.

Ah,i’ll install TXE drivers and Windows 10,Windows 8 is sooooooooo awful

Because my laptop only have TXE driver for 10

@rodrisbx - You do not need Win10, see my edit above for driver link. Also, probably same driver we have linked in that thread, since Win8/Win10 = same stuff/rubbish So Acer driver probably install on Win8 anyway, if not use the link above and get driver here it’s direct from Intel

If you hate Win8 you’re going to hate Win10 worse, please slow down!

@Lost_N_BIOS Here´s the link to download the bios : https://drive.google.com/file/d/1ZCd2voW…ew?usp=drivesdk
@Lost_N_BIOS I tried flashing it like you said to test the file but it gived me an EOM prevents IFWI Prepare to Update from completing,and i given FPTW64.exe -bios -f biosreg.bin command

Any error you are trying to describe, I need to see an image of this please, so I can see command you entered and the error all on one image.

Now, stop messing with this for now except for to give me that image, I am leaving and wont be back until tonight.

here @Lost_N_BIOS

@rodrisbx - Thank you for the image, please wait, see my edit above - Is this a laptop or desktop? If desktop, please remove the cover and inspect the board up close and look for 2pin headers with or without jumpers and see if you find any that say ME/FD/FDO/Service etc.
Be sure to check above memory slot too, sometimes they can hide there and people don’t notice due to the memory clips, but usually they would be near the bottom areas of the board or on side near power cable connector.

plutomaniac I’ve not seen this FPT error, do you know the cause or resolution?

It´s a laptop

Don’t worry, if we can’t flash mod BIOS, which we still have not even tested using stock update method
There is other ways to do the variable change we tried initially, although those may fail too so you may end up with only one option >>

You may want to go ahead and order a flash programmer now, because if you purchase cheap it can take 3-5 weeks to arrive. You need CH341A flash programmer + an SOIC8 test clip with cable
Here’s example links at ebay, you can find faster shipped for more $$ from other sellers or other stores like Amazon or Newegg type places
https://www.ebay.com/itm/382486015977
https://www.ebay.com/itm/201316582787

@Lost_N_BIOS Is it still possible to succeed by placing MOD Bios or by H2OUVE?


First time seeing this. EOM should mean “End of Manufacturing” so the error is the result of some sort of security measure.

If you want to try mods or similar invasive moves, I suggest you get a programmer. Apollo Lake uses IFWI v2.0 which combines the BIOS/IAFW and CSTXE regions into one. The IAFW also has 3 sub-regions if I remember properly. Note that the IFWI itself may have checksums as well. The problem is that UEFITool does not work with IFWI as support hasn’t been added yet. So you cannot rebuilt it. If you want to modify the IAFW/BIOS via UEFITool then you might be able to do stuff but, again, it does not recognize the sub-regions. It may work though. In such case, you can replace the IAFW sub-region of the IFWI using Flash Image Tool from CSTXE v3 System Tools.

@plutomaniac So,i will need a programmer to do anything related with UEFI?

How can i replace iafw sub-region of the IFWI using Flash Image Tool from CSTXE v3 System Tools?

Will ACPI work?

I give up

Because i’m afraid of brick

And laptop isn’t mine,is a family PC

Please close this topic

@rodrisbx - please wait sorry I thought maybe plutomaniac would notice this today and offer me some thoughts on that error, but maybe he’s been busy (or maybe he doesn’t know)?
I will send him PM and ask if he has any info to help me on this one
- sorry about that, not sure how I didn’t see his reply when I posted this!
You may have to order a CH341A flash programmer + SOIC8 test clip cable - then there will be no issues or concerns, you can always go back to original BIOS dump (Don’t be scared, it’s OK, and easy to do, plus it’s cheap @ $6 total)

We can try something else while we wait too, download this package and from each version folder, run the following commands at command prompt from that folder (select folder, hold shift, press right click, choose open command window here)
http://s000.tinyupload.com/index.php?fil…339416875325914

H2OUVE.exe -gv vars.txt
H2OUVE.exe -gs -all Setup.txt

Once you’ve done that from each folder, rename each vars/setup text file to it’s respective version, so we know what’s from what version. Then package all into a zip and upload for me


Thanks for your thoughts plutomaniac - we first see this error when trying to FPT flash back the stock dumped BIOS region, so haven’t even got into mod BIOS yet
However, due to what you mentioned, I will run stock BIOS through FITc and edit the BIOS region there from components folder, then rebuild and see if it looks same and or just send that file as a first test.

I did a simple edit to setup, replaced with UEFITool and then compared stock/mod in NE and it looks exactly the same at parser comments, so I think rebuild went OK. (Same OK check when rebuilding BIOS region inside FITc folder too - will compare outimage and my UEFI test next) - post edit also looks OK in MEA
All looks OK/Same as my other edits, after proper rebuild with FITc too. Disregard my previous fail here if you saw it, I did that without running through the guide