lenovo W541 ME update

My laptop is Lenovo W541, it is bricked,I repaired it with an old motherboard.
the old motherboard ME firmware is strange, It is version is
reference at https://download.lenovo.com/pccbbs/mobiles/glrg22ww.txt
W541 ME Firmware is and higher version, why my motherboard ME Firmware is

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2017, Intel Corporation. All rights reserved.

Intel(R) ME code versions:

BIOS Version: GNET90WW (2.38 )
MEBx Version:
Gbe Version: 1.3
VendorID: 8086
PCH Version: 4
FW Version: H
LMS Version: Not Available
MEI Driver Version:
Wireless Hardware Version: Not Available
Wireless Driver Version: Not Available

FW Capabilities: 0x01101960

Intel(R) Anti-Theft Technology - PRESENT/ENABLED
Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED

TLS: Disabled
Last ME reset reason: Power up
Local FWUpdate: Enabled
BIOS Config Lock: Enabled
GbE Config Lock: Enabled
Host Read Access to ME: Disabled
Host Write Access to ME: Disabled
SPI Flash ID #1: 20BA17
SPI Flash ID VSCC #1: 20052005
SPI Flash ID #2: 20BA16
SPI Flash ID VSCC #2: 20052005
SPI Flash BIOS VSCC: 20052005
BIOS boot State: Post Boot
OEM Id: 00000000-0000-0000-0000-000000000000
Capability Licensing Service: Enabled
OEM Tag: 0x00001043
Localized Language: Unknown
Independent Firmware Recovery: Disabled

FWUpdLcl64.exe -F ME9.1_5M_Production.bin -OEMID 4C656E6F-766F-0000-0000-000000000000 -generic -allowsv -y
Intel (R) Firmware Update Utility Version:
Copyright (C) 2007 - 2017, Intel Corporation. All rights reserved.

Communication Mode: MEI
Checking firmware parameters…

Warning: Do not exit the process or power off the machine before the firmware update process ends.

Error 8746: Firmware update not initiated due to invalid image length

how to update this motherboard’s ME firmware?

I am a rookie to Intel ME flash,I have roughly read Intel ME firmware tool user guide, not too understanding, help please,many thanks!

Please edit your posts if you need to add more info, new thoughts etc and it hasn’t even been a whole day yet, thanks. Also, slow down and wait for help, before you end up bricking the board again

First, to answer your initial question about why the ME FW is older, probably because the new board is on an older BIOS, or you have not ran the ME FW update package from the manufacturer download page.
Please link the driver and download page for this exact system, or confirm if this is the correct page - https://pcsupport.lenovo.com/us/en/produ…-w541/downloads

You do not need to use FPT, and you should never use the -erase command (If that’s even a thing, this would = brick and FPT does exactly what you tell it so it would = brick in a hurry as soon as you rebooted)

First, install the latest BIOS from the link above

Then download this package if you have not already - https://download.lenovo.com/pccbbs/mobiles/glrg22ww.exe
After you update the BIOS, run that ME FW update package again, and what does it tell you, same image length error?

If same error, see below for now

Based on your output above, OEM ID is wrong in this stock package command (4C656E6F-766F-0000-0000-000000000000) Go to location below, and edit the meupdate.cmd file, and make that all zeros, and remove both instances of -allowsv since it’s not needed here, then save and run the cmd again from there

If this all still fails, please wait, plutomaniac or I will help you update manually without using HP cmd/tools package.

Again, you do not need to use FPT or modify flash descriptor, please be patient

Sorry, I didn’t make myself clear. The BIOS is latest,
FWUpdLcl64.exe -F ME9.1_5M_Production.bin -OEMID 4C656E6F-766F-0000-0000-000000000000 -generic -allowsv -y
is w541 Intel Management Engine 9.1 Firmware GLRG22WW package MEUpdate.CMD command line!
update firmware an error 8746 occurred! This problem has been bothering me for many days!

Thanks for you help, I will test it as soon as possible!

Test it:

change MEUpdate.CMD with FWUpdLcl64.exe -F ME9.1_5M_Production.bin -OEMID 00000000-0000-0000-0000-000000000000 -generic -y

same error, error 8746,wait your help,thanks!

@zmgbyn - Now, please test same as above, but remove -generic

And, you are confirming you’re already on latest BIOS correct? What windows are you using 32bit or 64bit?

Can you dump ME with FPT, so I can check current onboard ME FW settings >> FPTw.exe -me -d ogme.bin
If me.bin created, zip this and send to me

Is this a desktop system, or laptop? If desktop, please inspect the board and look to see if there is any 2pin headers possibly with label FD/FDO/ME/Service written on the board near them *be sure to look above/below memory slots, sometimes header can be hidden there by the memory tabs.

Meanwhile, please try this, download this package MEupdate1-MEupdate5 and see if any work, if all same error, then go into 9.0 Tools folder, and run same MEupdate1-MEupdate5

my laptop is Lenovo ThinkPad W541, BIOS Version: GNET90WW (2.38 ) is latest,OS is windows 10 64bit 1809,down above and test as you write, all the same error 8746.

run fpt64w.exe -me -d ogme.bin :

Error 26: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.

from https://download.lenovo.com/pccbbs/mobiles/glrg22ww.txt is Initial release for ThinkPad T440p, Added support for ThinkPad W541.

My motherboard is,so I think this motherboard is strange!

run MEInfoWin.exe it report: Host Read Access to ME: Disabled Host Write Access to ME: Disabled ,I think must modify flash descriptor.

Any suggestion? thanks!

First, try FPT as I suggested (not x64), and be sure you are using Admin CMD Prompt >> FPTw.exe -me -d ogme.bin
I’ve never seen read access be disabled!? Do you get the same 8746 error if you try to flash from DOS using ME FW Update tool for DOS

ME FW you have on the board now just means at some point in the past, one of the original BIOS had that, or the other owner updated to that version, nothing strange there.

Yes, if you want to FPT write ME, the FD must be unlocked, or a jumper placed on the FD/FDO/ME/Service 2pin jumper, if you can find one on the board.
Using ME FW Update tool does not need the FD unlocked, and should be working for you, so see below

As for the actual MW FW Update error, please wait >>>

plutomaniac do you know the cause of 8746 MW FW Update tool error?
I edited many variants of the default batch flash tool, removing flags and editing OEMID etc, none helped - package at post #6

Run "FWUpdLcl64 -save upd.bin", compress and attach the output file.

I am so sorry too late to replay, I am on my business trip, thanks!

me.rar (996 KB)

zip format:

me.zip (1000 KB)

Your motherboard is using the 1.5MB SKU, not 5MB. You can update to the latest ME 9.1 1.5MB firmware from Intel Management Engine: Drivers, Firmware & System Tools.

You are quite right, I download Intel ME 9.1 1.5MB Firmware v9.1.37.1002 and update ,ok.
It seems like my motherboard is not original, original ME firmware is 5M,is it possible flash ME form 1,5M to 5M?

clear it.

No it’s not. The replacement mobo is probably for some other SKU without vPro or similar.

No it’s not. The replacement mobo is probably for some other SKU without vPro or similar.

Many thanks for your help !
I do not quite understand, My original motherboard ME is 5M, why the motherboard replaced ME is 1.5M, can I ask the repairer replace and flash the CHIP with dedicated external programmer?

As I said, it may be that the replacement mobo is from another Lenovo model which is fairly similar but comes with a mobo without vPro functionality or similar. What chipset/PCH model does your replacement motherboard have?