macbook air Me region corruption bar freezed help

Hi friends, I’m having this odd issue with this Macbook A1466, this board came totally dead, so I fixed it I traced the problem back to a PM_SlP4 signal corrosion on one of the spi flash points.
After it I see boot sequence it’s slow… but it enters to OSX and once you login loading bar freezed at the end. I ran ASD and got the following error Me Engine not found. I went ahead to desolder the SPI rom and flash it with another good Bin from one site I found ghostlyhacks. This bin had me region clean , so I only edited to add serial and hw , once I flashed and soldered it back. Machine turns on but question mark folder. SSD it’s not seen.
I think this has to do with some corruption with the original bios or me region. So would be grateful if anyone can help me out. I’m attaching original backup of the bios dump.

b1.rar (3.91 MB)


There are 3 generations of A1466 families. I assume you are talking about EMC 2632, meaning MacBook Air 6,2. I extracted the ME region from the latest Apple BIOS .scap file (MBA61_F000_B00_2020-06-10_18-10_D86274AF.scap) and replaced the one at the provided dump. Flash "b1_fix.bin" back and the ME firmware should be healthy/operational. Anything else is either BIOS/NVRAM or hardware related.

b1_fix.rar (3.87 MB)

MBA61_F000_B00_2020-06-10_18-10_D86274AF.rar (4.11 MB)

Thanks plutomaniac, I have some questions, I tried to flash the SPI rom which in fact is soldered QFN style. I’ve got an Rt809h programmer, but I wanted to avoid soldering. So I checked all communication lines MISO,MOSI,CS,VCC etc. and soldered to the test points on the mainboard… then I did some sort of assembly with cables going to the socket of the programmer. This didn’t work IC wasn’t detected, I even tried soldering cables to the XDP connector and still same thing. Now why is this happening all connections were tested for continuity. There are cables selling on china with XDP socket to use on rt809h without any additional circuittry. Or do I need to bridge some logic?.
So many thanks for the modding you did. May I ask what would be the correct steps to clean the me region of the original dump and reinject a clean ( if possible Stock RGN).
This is how I did myself but I kind of forgot.

1) Use MeAnalzer to check the Me version
2) Use uefitool to check if Me region checkum is corrupted.
3) once I have the Me version number , use MEinjector to inject same version or higher.

What happened on this macbook which by the way was a 820-3437B board, was really odd… Loading bar freezed. but I would like to know or at least check inside the MEregion descriptors what was corrupted which generated this fault, is it possible/

Thanks again

  1. I do not know the answers to all these low level hardware questions, not my area of knowledge
    2. Do not follow junk guides from places which have no idea how to work with Engine firmware (i.e. GhostlyHaks)
    3. Do not use junk “tools” from people who have no idea how to work with Engine firmware (i.e. “injectors”, “cleaners” etc)
    4. Read Intel Management Engine: Drivers, Firmware & System Tools to understand Engine firmware (RGN is not what you need)
    5. Read [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization on how to properly clean Engine firmware