ME Firmware N/A after reflash

Hello there, I found this forum these days trying to solve my problem, but yet I couldn’t, so here we go:
I have a Colorful B85ak v21 and a few months back I ended bricking my BIOS and bought a CH341a (black) to reflash, it works fine now, except that the bios don’t show any info about ME Firmware


No matter how I reflash or what version I use, its always the same result, using ME Analyzer with the .bin it shows that the file has the FW

I can’t install ME drivers, theres nothing related to it in the Device Manager and even in DOS I receive errors
MEINFO
MEMANUF

I can’t describe exactly what I already tried because I don’t understand a bit about this, I’m just trying everything I see and looks related to my problem haha don’t even know what exactly ME is, but i now that before the brick there was info about it, and now it dont and this is really bothering me, so any help´it’s welcome.
Sorry if something that I wrote it’s confusing, but english it’s not my language.
Thanks.

Re-flash the entire 8MB SPI image using the programmer. Then reset CMOS, restore BIOS defaults and check again. If that doesn’t help, follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization on the 8MB SPI image, re-flash using the programmer, reset CMOS and check again. If both don’t work, the problem is at the BIOS and not ME firmware.


There is any advanced mode to re-flash? Usually what I do is: connect programmer > read chip > erase > check > select bios > write > check again and this doesn’t solve the problem, I also tried using another 8mb chip.


I followed the “D3. ME 7 - 10 & TXE 1 - 2” part, also nothing solved.
There’s a JME jumper and in the bios there is this option “ME FW Image Re-Flash – Enabled or Disabled” tried to reflash with both options and nothing

I tried to reflash using afudos, works fine, everything looks okay

But then I used the /O command to save my current rom, did it two times, one for each reflash, and the rom only has 4mb, same if I try to use Afudos on Windows, and using the ME Analyzer, shows me that there is no ME Firmware anymore.

It does not flash ME. For AMI Aptio V only microcode is flashed.


It’s aptio 4

Remove, or move jumper, this disables ME >> Pins 1 and 2 shorted:Refresh the BIOS. Pins 1 and 2 disconnected:can’t refresh the BIOS.
As does the BIOS setting ME Reflash but only for one session (leave this disabled)
You must also completely remove all power for one minute after you fix the ME FW


Sorry, I got a little confused with the translation, should I leave with or without pins shorted?

Move to jumper only on one pin after you’ve updated BIOS. Jumper on both pins only when you want to flash the BIOS/ME

Same result, I think I will gave up on this, nothing seems to solve :confused:

make DOS bootable USB with all files from FPT DOS Folder, then Issue this in command prompt >> FPTw.exe -greset
Or drain all power for one minute, remove PSU Cable, CMOS battery, then short power on pins for 10 seconds or clear CMOS for 10 seconds, and then let sit for 1+ minute.
Then connect all power and check again.

If issue persists, dump your current BIOS contents with programmer and upload for me to check out.

Nothing changed. The dump its the file I get using -d spi.bin? It’s attached bellow, and ME Analyzer shows it has ME FW

SPI.rar (3.88 MB)

@danielhld - Sorry, I meant dump with programmer. This will work though, can you please link me to original BIOS download from Colorful, this BIOS you sent has broken FIT Table and I want to see if stock BIOS has that (I’ll fix it anyway).
That has nothing to do with ME, but it should be corrected. I also see some good settings hidden from you in BIOS I’ll enable once we fix your ME
Also, if you have it, please send me a dump of your BIOS chip before you re-wrote it to fix the bricked BIOS

What chipset is this system, if you are unsure please post an image of CPU-z motherboard tab.

plutomaniac - waiting for his original BIOS dump (hopefully), or a link from Colorful with ME in it already, but I see this when dropping in FITc
Can you tell me what Colorful has originally set for this value (And it’s hex location in ME FW) in case it should be that and this is what’s causing the issue since he ran it through FITc already, so I can put back once done with FITc clean/UPD (or I’ll send one each, FITc corrected and original put in manually)
“No Emulation - Desktop” also concerns me, but need to see the OG BIOS first, maybe it should be that way but I assume it’s not ideal

invalid-SMBus.png

Ignore that message. If the user actually follows the instructions I gave above using the programmer and only the programmer, then it will work again if the issue is ME related. Otherwise BIOS disablement.

Thanks. I checked BIOS and ME FW, nothing disabling ME that I see, however that jumper and the translation for it’s use is confusing and I suspect this has something to do with it.

I have never noticed the JME jumper before, it has no pin on it, I modded the bios a few times trying to unlock some OC options, the ME FW always stayed installed, I don’t have the backup before the first time I programmed it

cpuz.png


The original file show the same error using FIT
I also attached the dump using the programmer

OriginalWB85AK25.rar (3.87 MB)

dump.rar (3.88 MB)

Show me image of the JME jumper, how is there no pin on a jumper, you asked before where to move the jumper to connect.

If you program in properly BIOS with ME FW then it will be there. Are you erasing, blank check, then open BIOS file, write then verify?
Thank you for original, I will check it tonight when I have more time. I will fix the FIT issue and update/clean ME FW for you

Sorry, I expressed myself wrong, it only has two pins and I never used any jumper connecting them
With the programmer I usually follow these steps read > erase > blank > select bios > write > verify

IMG_20190605_142532.jpg

@danielhld - Thanks, I see what you mean now with the jumper. From their description >> Pins 1 and 2 shorted=Refresh the BIOS (allow BIOS/ME reflash). Pins 1 and 2 disconnected=can’t refresh the BIOS (No BIOS flash or ME Flash possible).
Since you are using programmer none of that matters, but if you want to flash BIOS with stock flash method, you need to put jumper on.

Here is BIOS with ME redone, just in case there is some issue we didn’t see (I see boot guard was set to unknown), and fixed FIT table.
Put this on with flash programmer, then remove all power from the board for 1+ minute (remove 24 and 8 pin power cables, remove CMOS, short or press and hold power on button for 10 seconds, then wait 1+ minute)
http://s000.tinyupload.com/index.php?fil…133797769603315

I think I already tried changing some values following the steps of the “Clean Dumped Intel Engine” tutorial, tried again with your file, motherboard beep 3 times and didn’t boot, used the programmer through another PC and it boots, but yet no ME.
One observation about this mobo it’s that the bios chip it’s soldered, and I had to desold and in the proccess I lost a soldering point, but the mobo also has the soldering points for placing a socket, so I adapted.

I don’t have any high resolution pic, but it should be visible
Old

adptation.png


New

adaptation2.png



Both chip are of the same size and I can connect the original chip using the adpter that came with the programmer and I usually try the same steps with both, including you last one, the results are always equal.
I tried to dump the files again, using the programmer, MEA accuses no ME FW and FIT gives me an error, while using the -d spi.bin command it looks fine in both.

programmerdump.rar (551 Bytes)

SPI.rar (3.88 MB)