ME Firmware N/A after reflash

That is strange BIOS I sent you did not work, maybe due to fixing the FIT Table but that doesn’t seem right, maybe should have used other tool to do it, hard to know without more testing.
Sorry you lost trace for the BIOS! You should have picked up SOIC8 test clip w/ cable instead of having to desolder each time.
Here is same BIOS I made previously, but without touching FIT (So this only has redone ME FW) -…656581991629622

You’re programmer dump above is not a valid BIOS read (All FF in hex), so for that chip you need to find other software version that works properly for it, then you can safely read and write to it.
What is that chip’s ID, and what software version are you using?

The original chip it’s a 25Q64FVSIG


And the one I’m using is 25Q64FVAIQ


The programmer version it’s 1.29, but I also have 1.18, 1.30, 1.31, maybe I can try using all of them to see if anything changes, there’s also a command prompt version, but I still need to learn how to use it.

User 1.30 (or 1.34) and choose 25Q64BV. No need to use command prompt version, I’ve tested these chips and they work on regular CH341A software

1.30 gives me this error, I can continue flashing after clicking "OK", but now I am trying with 1.34


That is normal, I see all the time, carry on

Neither the versions worked, the result it’s always the same, even let the PC without any power cable and cmos battery for around 30 minutes.

His motherboard can read quad spi bios chip? He have better to use 25Q64FVAIG.

It doesn’t matter what his board can read, for now, this can be changed later at ME FW level. The issue right now is programmer and chip, unless he finally was able to write successfully? Not sure, he didn’t clearly say this yet.
Also, all W25W64FV = same in regard to this, all are dual/quad operation possible - see page 86 - - but yes, due to “Q” this means default QE=1 at status register 2, can’t that be changed with ASProgrammer in the protection bits options?
Did you get verified write yet @danielhld ? If yes, then yes, we may need to edit your ME FW to enable quad BIOS function - send me a copy of the BIOS you are using and I’ll set that for you. if that fails, then you’ll need to get a different dual SPI function chip instead like the original.

It didn’t work, no matter how I flash or wich version of the programmer I use.
What exactly do you mean with “verified write”?
A flashed copy or the file before the flash?
If I use the programmer or AFUWIN to save my current bios it only save a 4mb file like those I send before, I only managed to get a 8mb file dumping the spi.bin

spi.rar (3.88 MB)

@danielhld - I mean did the programmer tell you buffer and chip match after the write process, when you verify? If you do not get that, then BIOS was not properly programmed to the chip.

Are you selecting the wrong ID/Size when dumping with programmer? A dump of any W25Q64 chip should be 8MB file even if it’s an invalid or empty (FF/00) dump.

Boombastik may be correct above, I’m not 100% sure if you can change the chip to non-Quad operation, if you can I’m not sure how it’s done exactly (If not how I mentioned above)
The BIOS may be reconfigured to use Quad operations though, this is done at ME FW level using FITc, but you’ll have to test if that helps or not. Quad operations are currently disabled in the BIOS you attached above

Please wait for reply from plutomaniac before I change this for you so you can test if it helps.

plutomaniac to enable quad operations on the SPI BIOS above, at FITc PCH strap 1 currently both dual flags are enabled, if I want to switch to quad or enable quad, do I disable the duals and enable quads, or leave duals enabled and enable both quad settings too?

Ah, ok, yeah, I always verify and its the same size, but I was not chosing the ID when dumping, now I got a 8mb file.
PS: for some reason the file its going from 8mb to a few bytes when compressed, don’t now if it’s norlmal since every other file it’s reduced to 3mb.

dump.rar (541 Bytes)

Verify and “Size is same” are not related, nor does “size is same” have anything to do with what were doing here, unless you have differing sizes (Checked in hex only)
But since you were having size issues when dumping, probably same when you were doing writes too. Redo it all again and be sure you are selecting correct chip ID.
Check dumped files in hex, if it’s all FF or 00 then it’s invalid dump, you need to use another software version or different chip ID (as I mentioned, you need to use BV not FV for these chips)
That is why your compressed file is so small, this is invalid empty BIOS dump, I didn’t download above file to check this as I don’t need to I already know from your comments.

My mistake, its acctually this message
[[File:Sem título.png|none|fullsize]]
But yeah, with hex it’s all FFs
I will try redo everything and check with hex now

I don’t even know what dual/quad operations are. There is however the help text at FITC which might be of help.

Guys really thanks for ALL your help, I managed to solve the problem.

I was doing a cleaning on the PC and decided to resold the socket and clean any rest of solder paste, now the ME it’s back. This was one of the first things that I tought to do but was too much trouble, it’s kind of frustrating that I spent a week trying to reflash this thing and the solution was a 30 minutes work haha

But thank to you guys I learned a few new things about BIOS, so win-win xD


plutomaniac, thanks anyway, it’s OK I hoped you’d had previous experience changing those It’s how the BIOS is read/written to, like dual or quad channel.
I’ll see if the help text explains anything about if one needs to be disabled if you enable the other.
* I checked, sorry I thought you meant actual full “help” like F1 type help, not the little help blub there on all the settings I’d already read those before I asked.
I’ve changed this before a few times for people, but can’t remember if I disabled the dual when enabling quad, or if both could be enabled at once allowing the chip to be the deciding factor.

@danielhld - cool you got it going again! So what was the issue, maybe bad solder joint?

I guess so, it was a little dirty with solder paste, maybe a short, don’t exactly now, but the it works now o/

Solder paste, or flux paste? Solder paste, yes, maybe a short or maybe a cold joint, but if only flux it shouldn’t short.

Yes, good thing is it’s working now

Stinky sticky paste haha

I’ve got some stinky too! I always add some alc or thin flux around area when I heat paste, helps it flow and stay where it belongs too.