Missing Intel ME firmware

I have a Lenovo M73T(tiny) that boots but doesn’t shutdown/reboot, and in the bios screen it doens’t list a ME firmware version? I’ve also cloned (chip off programmer) the ROM from a working M73T (same model) and no luck. I’ve opened both rom files in UEFItool and the ME regions seem to match? In windows I can’t install the IMEI or AMT drivers tells me I don’t meet requirements. is there a seperate rom? What am I missing?

Try resetting the TPM and updating the BIOS.

Also, manually re-flashing the ME firmware in case if it’s corrupted is a way to fix your problems.
Intel Management Engine: Drivers, Firmware & System Tools

Hi Eray, I’ve tried all of these. Trying to update via Intel software fails since it requires the driver to be installed but driver won’t install since the ME firmware is missing. As for reflashing the Factory firmware I’ve done this a few times chip off with programmer but in the bios it does not list a ME version so it’s not flashing the ME region. As mentioned I’ve copied a ROM (from same model pc) that has working ME firmware and programmed that and same result it reports no ME firmware in BIOS? Sorry if I’m missing a step somewhere.

Post the backup of your original bios before flashing/ changing anything and the bios you’re using now.

Hi lfb6, here’s the original backup of the ROM (m73_noME) and the copy I used of the rom used from working M73. Thanks for any assistance with this.

Sorry it won’t let me upload more then 6mb, I’ll private message you the gdrive link

@maddog3115 Both images still have ME firmware, you can check this with MEA or by opening the images in UefitoolNE
MEA https://github.com/platomav/MEAnalyzer/releases


One reason for the behaviour tou’re reporting is a corrupted Intel ME, so next step would be to clean the ME region of your own image following this guide:
[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

Follow “D3. ME 7 - 10 & TXE 1 - 2”. Your current ME version is part of the Intel ME 9.0 Firmware Repository r11, use Intel ME System Tools v9.1 r7, post the result before flashing.

Hi LFB6, thanks so much for the help… this is the result using MEanalyzer from the bin I generated


When I flash it to a rom the PC no longer boots it boot loops?