Modded Intel AHCI and RAID Drivers (digitally signed)

You can find the download links below:


Can you mod the recently released drivers (version 4.5.4.1031 WHQL) because the v4.3 drivers are over 1 year old?

EDIT by Fernando: Unneeded parts of the fully quoted text removed (to save space within this thread)

Here are the requested download links:


Note: I have included the HardwareIDs of all known Intel SATA AHCI and RAID Controllers from ICH7R up, but this does not automaticly mean, that they will properly work with all of them.

Any feedback from users, who have tried one of these mod+signed drivers, is much appreciated!

EDIT:
Meanwhile I have tested the 64bit variant of the freshly modded and signed Intel RSTe driver v4.5.4.1030 with my Z97 system running in ACI mode.
The installation worked flawlessly by using the “Have Disk” button and doing a double click onto the file named iaAHCI.inf.
As you can see here, the Intel SATA AHCI Controller of my system is now listed within the “Storage Controllers” section of the Device Manager (the previous location was the “IDE ATA/ATAPI Controllers” section):

Intel RSTe AHCI driver v4.5.4.1030 on Z97.png


Additionally I have done a benchmark test:

Z97-AHCI-850EVO-4541030.png


My first impression: Compared to my recently tested Intel RST(e) drivers of the v13/v14 line (look >here<) these Intel RSTe drivers v4.5.4.1030 are less performant. Nevertheless they seem to run very stable with my Z97 AHCI system.

Hi Fernando. I recently bought an ssd drive and I installed windows 10.
My motherboard is asus p5kc and my processor intel e8400. I installed p5kc-1203_slic-ahci_v2 rom before I installed windows, I changed in bios from ide to ahci controllers and when I entered windows I checked and I saw that I have storahci instead of iastor.
I tried to install your drivers Universal Intel RST Drivers+Software Set v11.2.0.1006 mod+signed by Fernando, I did setup the win-raid certificate, but when I try to install theς drivers, It stops with a message "the setup program failed to install one or more device drivers. Setup will exit."
Am I doing sth wrong? Is there a way I can install the drivers?

@Guybrush23 :
Welcome at Win-RAID Forum!

That is quite normal, because Win10 doesn’t have any in-box Intel AHCI driver. What did you expect?

After having successfully imported the Win-RAID CA Certificate, you should manually “update” the driver of the “Standard AHCI Controller” from within the Device Manager.
Why did you run the installer of the complete Intel RST Drivers & Software Set? That doesn’t make any sense for AHCI users.
Regards
Dieter (alias Fernando)

Thank you so much, I thought I had to setup in order to enter the drivers.
Everything went perfect, thanks for your advice and for your great effort!

Here are the requested download links.
Any feedback from users, who have tried one of these mod+signed drivers, is much appreciated!


Thanks for this update, everything works with the P67 chipset (Asus P8P67 PRO), just like with the previous version :smiley:
Funny thing is that I don’t need these drivers anymore because after two years Intel just posted a solution to the infamous HDD click problem when you have a Samsung HDD and the 13.x-15.x drivers:

Now I can use the newest “normal” IRST drivers

Hello,
I try to make drivers with digital signature … but the link does not work.

EDIT by Fernando: Since the links didn’t work for the public, I have removed them.

@vanden :
Your posted link was not working for you, because the related guide had been moved a long time ago into a hidden Forum section, which is only visible for Win-RAID Forum Team members.
Unfortunately I forgot to remove the link from the start post, but I just have done it.

Let me explain, why mrces2’s guide is not available for the public:
1. Our Forum member mrces2 had written his guide just for me to give me the required knowledge about how to digitally sign modded drivers. It was never his intention to offer his guide for the public.
2. As owner and legally responsable person of this Forum I don’t want to risk unneeded conflicts with the manufacturers of chipsets.

Hoping for your understanding
Dieter (alias Fernando)

Ok


But it’s a pity … I just wanted to make a win7 screen drivers compatible with win8 / 8.1 / 10 … I’ll look if there are no other solutions …

It is no big problem to get modded drivers installed without the need of giving them a digital signature, even on Windows 10. You just have to disable the “Driver signature enforcement”.

Update of the Start Post:
Changelog:

  • new:
    • “Universal 32/64bit Intel RST(e) AHCI+RAID drivers v15.0.0.1039 mod+signed by Fernando”
    • "Universal 32/64bit Intel RST(e) Software v15.0.0.1039"
  • removed:
    • “Universal 32/64bit Intel RST(e) AHCI+RAID drivers v14.10.0.1016 mod+signed by Fernando”
    • "Universal 64bit Intel RST(e) AHCI driver v14.10.0.1016 mod+signed by Fernando"

By the way: After having installed the mod+signed 64bit Intel RST(e) driver v15.0.0.1039 onto my Z97 AHCI system, I got very promising benchmark results (look >here<).

Good luck with these freshly modded and digitally signed Intel AHCI/RAID drivers!
Dieter (alias Fernando

For test I installed modded 15.0.0.1039 on my Z77 system, Windows 10 x64 and no problems but I came back to 13.1.0.1058 WHQL - IMO old driver is just better…

1. Intel RST(e) AHCI driver v13.1.0.1058 WHQL, Windows 8.1 Pro x64:



2. Intel RST(e) AHCI driver v15.0.0.1039 mod+signed, Windows 10 Pro x64:


Try this tutorial:
http://woshub.com/how-to-sign-an-unsigne…-windows-7-x64/

But use ‘-a sha256’ and maybe ‘-sr localmachine’ on ‘makecert’ as sha1 might be obsolete these days.

Edit2:
Or even better… this one: http://stackoverflow.com/questions/84847…ning-on-windows

On the other hand i’m not sure if its possible at all as Fernando is not signing the driver, just the .inf file. The driver is still signed by Intel.

A new additional digital signature of the real drivers (= *.SYS files) is not necessary, because their code stays untouched. I always just modify the associated *.INF files and nothing else.

Hello Fernando,

Is there also a driver for this controller?

1
2
3
4
5
6
7
 

Standaard AHCI 1.0 Serial ATA-controller
PCI\VEN_144D&DEV_A800&SUBSYS_A811144D&REV_01
PCI\VEN_144D&DEV_A800&SUBSYS_A811144D
PCI\VEN_144D&DEV_A800&CC_010601
PCI\VEN_144D&DEV_A800&CC_0106
 
 

The other controller does work with your driver, its details here:
1
2
3
4
5
6
 

Intel(R) SATA AHCI Controller DEV_8C03 added by Fernando
PCI\VEN_8086&DEV_8C03&SUBSYS_171D1043&REV_05
PCI\VEN_8086&DEV_8C03&SUBSYS_171D1043
PCI\VEN_8086&DEV_8C03&CC_010601
PCI\VEN_8086&DEV_8C03&CC_0106
 

Yes, the Samsung SATA AHCI Controller with the DeviceID DEV_0800 uses the in-box MS AHCI driver named storahci.sys.
There is no Intel or Samsung AHCI driver available, which supports this Controller.

thanks a lot

@anewday :
Welcome at Win-RAID Forum!
Regards
Dieter (alias Fernando)

Yes !
I thought we should always boot in “Driver signing enforcement” mode … then it’s just necessary for install it !

Thank you, I’ll watch !

EDIT by Fernando: Unneeded part of the fully quoted test and blank lines removed (to save space)