Modding BIOS su FUJITSU SIEMENS ESPRIMO P720 E90+ MI5W

  • Recommend to connect the flasher not via USB- hub but directly to the PC

    - Link to dump says ‘file is uploading’

    - What about:

https://www.dropbox.com/s/fm2y2059pm6eyj…ujitsu.Bin?dl=0



Try this:

https://www.dropbox.com/s/fm2y2059pm6eyj…ujitsu.Bin?dl=0




It immediately gives me this error on the first command you recommended. If it is not strictly necessary, perhaps it would be easier to work with a graphic interface application.

FPTW64 1.jpg

  • You used ME tools v15 instead of 9.1.

    - The CH341 dump you provided is longer than expected and contains a lot of errors when parsed with UEFItool NE compared to the stock bios. It’s not a proper read/ good backup.

e.jpg

I downloaded the 9.1 version you recommended but it keeps giving me errors:

FPTW64 9.1 -1.jpg

Those commands are supposed to be run on the corresponding Fujitsu system. Bios dump you posted does contain a ME 9.1 so those commands should work on such a machine.

That’s a pity since you don’t have a trustworthy bios dump to work with.

Ok. So what do you suggest me to do?


@Rothwang

- Which program did you use for reading the bios chip with the ch341 programmer?

- Did you run the fptw64 command in the booted operating system of the Fujitsu Esprimo P720 E90?

Hi guys,

i have a fujitsu board d3222-A1 and i inserted the nvme driver to the bios rom file. but i cant get the bios back to the mainboard. if i use the dosflash with the updated rom file on the bootstick, it didnt take the new one. is there any other.

I’ve found something in the manual. but i dont know how to tell at the start do insert the .rom file.
ftp://ftp.kontron.com/Services/Software_…-Tool_HowTo.pdf

does anyone has an idea? or do I need a special programmer?

i’ve flashed the bios via afudos from ami to the bios. after the second change, the board does not startet anymore. 3 times beep sounds are repeating, the display is black and i cant do anything, to flash the original rom file back to the mainboard. anybody could help me?

First of all, did u get a CORRECT DUMP with the CH programmer, lb6 said that it was a BAD dump…
Did u compared the dump contents with the spi chip contents…

Im not saying to give up…we r all aware that OEM bios r sometimes very tricky to mod do to their own structure bios file, unaware of little things that we do not have knowledge.
As i said earlier its always a risky operation, specially on this OEM machines, as u saw in the pdf provided…they do advise not to use AMI tools, AFUDOS flash may not know to flash it properly and fails.
On the other hand, the FSC EFIFLASH may not accept ur mod file or only works with the partial bios update files from FSC.

Well if u have a correct dump from early state as functional, i do suggest ur CH program it again and start over.

@MeatWar Didn’t say anything about Krakau25 dumps, last 2 posts are different user.

@lfb6 ur rigth sorry m8…indeed the post#24 dump was referring the original topic user, my apologies.

No reason to apologize, just mentioned it to avoid confusion and unnecessary work.

Hello everyone.
I tried for a month to extract, modify and reflect the bios. If I connected the device to the Fujitsu motherboard in off line mode I could extract the bios but it had too many errors, as detected by the kind users of the forum who followed the post, while if I tried to work on the bios from the same motherboard, as lfb6 suggested, ie with the clip attached to the chip, the system did not even start.
Eventually I became convinced that, as some of you pointed out, the operation is very risky, if not impossible, for some OEM motherboards. I sincerely thank those who have helped me to try that method so far.
I then decided to follow the method proposed in the thread [Guide] NVMe-boot without modding your UEFI/BIOS (Clover-EFI bootloader method), and he immediately succeeded!
The only problem is the pharaonic slowness of the boot, about two minutes! I tried to set the debug operation to “false”, but it was already set to false, so now I really don’t know what to do to fix the problem.