Modified NVFlash v5.667.0

@gQx @Vernnon password for v2 is 634987dvfk. No need to keep the password behind closed doors anymore all the testing that we could do is done.

@belikeimpasta sorry I have no experience with a 3060ti or any nvidia GPU since the GTX980 as that was the last era of nvidia GPUs worth tinkering with anything since then is paper not physical experience.

1 Like

@ket can you check the password? Tryied 634987dvfk and 634987dvfk. (with dot in the final) and doesn’t open…

@Vernnon that password is for v2, not third version. I’ll have to dig around some more to find the password for v3, it might have been lost when one of my pen drives got corrupt. Patched third version doesn’t need a password, first versions password is; erm_pui,.6y8

worked here with this pass bro, tks!

Will this work for mobile Quadro RTX 3000 GPU? Starting with Pascal mobile Quadro, flashing modified vBIOS resulted in black screen (vBIOS is signed and required signed for mobile Quadro).

All I am trying to do is remove UEFI gop from Quadro RTX 3000 to get it working in older laptop, but not sure if that breaks any signatures.

I have hardware programmer too but just wanted to see if nvflash finally can flash mobile gpus again.

only works HWprogramer “1.8V” in best SKYPRO or similar quality flasher
i mod my MXM-TDP and all works nice “no signature corruption” :smiley:

or try last GOPup “app here on forum” this is possible flash in NVFLASH for repairs UEFI problems :stuck_out_tongue:

or like my MSI - GOP status “VGA is hybrid vbios” gpu-z shows bad info ,.,hwinfo or nvflash is ok
all about nvidia gop / app in last posts

I need to remove UEFI GOP from vBIOS not update it similar to here: [Guide] Remove UEFI Image from NVIDIA vBIOS - #18 by brothertax

Laptop has no uefi and any gpu with uefi gop in vBIOS causes no boot. Not sure if removing uefi gop using that method and flashing with my ch341a programmer will brick card. MXM Quadro have signature requirement in vBIOS. Idk if that mod alone will break any signature.

and did you read the topic?
if you not have hybrid or legacy vbios ,.,.is impossible use this card on LEGACY
or in bios CSM BOOT - VGA MODE - LEGACY “this disables GOP”

send your notebook name and gpu ID / SUB-ID
i will try find compatible vbios or setup

Alienware M17xR3

You will not find anything that will make it work online.

Only option is bios mod to fix UEFI incompatibility or vBIOS mod removing UEFI GOP portion of vBIOS on the RTX 3000 MXM card.

but when have full uefi card ,.,.not works without GOP …this is problem :smiley:
send vbios or ID + subID ??

and bios is INSYDE ? .,.,.,try find on TECHPOWERUP - vbios in HYBRID structure / or must contact gpu manufacture for LEGACY vbios “if is this possible for new cards”

AFAIK no modern GPU has a “legacy only” vBIOS, they are all hybrid/UEFI now and have been for some years. The last GPU you could really dive in and mess with was the Polaris cards for AMD or the Maxwell II cards for nvidia. GPUs are boring as shit now.

but hybrid must works also on legacy mode ?
,…,my hybrid/UEFI vbios works fine under LEGACY and UEFI mode “pascal MXM” :face_with_raised_eyebrow:

also legacy vbios probably exist “or any corrupt” i saw some MSI notebooks and they didn’t have UEFI signature “PASCAL / RTX”

Yeah…but is putting modern RTX3xxx MXM on an hybrid UEFI 2011 system.
Bios cant load/deal with the NVdia hybrid vbios legacy part or own GOP
the RTX3xxx requires a modern CSM module on bios itself.

i agree
or like another notebooks - EC fw /PEG setup / SA setup / EDID compatibility ,.etc
I have also up-gradable notebooks and is impossible without lots mods usage another GPU !

and RTX on older system looks like madness + old CPU .,.TDP mod on PASCAL or RTX

1 Like

Alienware M17xR3 ? - best try pascal gpu + TDP 150W is ok from MXM “lot users using more - 200W” and still works good

also this gpu is in best range for yours others HW ,.,benefits from RTX is minimal here :smiley:
easy app for TDP mod - TDP tweaker “but need HWflasher + 1.8V adapter” and configure custom TDP in AFTERBURNER .,.and all works nice :smiley:

if you no need QUATRO ,.,i recommend normal gtx1070 - best for you “gtx1080 need power cable”

Hybrid vBIOSes exist to support older systems that don’t support UEFI, I forget the specifics but essentially the only way to use a vBIOS in legacy mode on a UEFI system is to completely rip out the GOP, which in turn breaks the vBIOS encryption in place to prevent tampering to an extent this was true even for Polaris cards vBIOS mods broke the UEFI support and you had to do a specific fix for that if you didn’t want to run in legacy mode only. Then there’s other stuff with modern GPUs such as the checksum and the possibility of modern Windows systems possibly not even loading the display driver with such vBIOS changes so… good luck breaking the encryption. Theres a reason things like more power tool exist and its not because people lack the knowledge to modify vBIOS and tailor them precisely to their needs among several reasons it is because manufacturers got tired of RMAing cards users “broke” and didn’t know how to unbrick them or lacked the ability to do so.

Just for the record, my favourite GPUs of all time because of how much you can customise them and the performance you can get out of them when properly optimised are the Polaris cards, those things are still potent 1080p cards and aren’t too bad at 1440p in a lot of titles still.

1 Like

This is why ill never part with my Gigabyte X470 Gaming7 WiFi its worked with every GPU ive thrown at it going back to Nvidia 8800GT

I miss Lost n bios, i do hope hes ok.


Sorry I use google translate.

For the needs of the graphics card firmware research, I modified the last two versions of nvflash, mainly modified 7 jumps so that the program will not go to “Invalid firmware image detected”, because it is an experimental project, it may destroy the function or An unknown situation occurred. Please feedback if there is any situation. (5.6 MB) (5.7 MB)


Hi wudimobile,

I’ve tried both nvflash versions, trying to flash Alienware’s 3080ti mobile, but it catches subsystem ID mismatch right at the end.

Any help would be appreciated :slight_smile:

Are you writing to a different model of vbios?
For 30-series, I don’t know what verification has been added at this time, so any modifications to vbios may not pass verification, perhaps using programmer to write to the chip will work.
I can’t offer any more help at the moment.