Motherboard Asus Q170M2 ME Firmware

Hi guys,

I have an issue with my ME firmware. I bought it for using integrated KVM (half of year). So all worked, but my firmware had an affected by CVE-2017-5689.
So i raised case to Asus, after half of year they issued new version but it didn’t work with TLS (possible it can be related to these https://intel-openport-v8.hosted.jivesof…m/thread/118770). In any case Asus asked me to contact to Intel, I raised an case to Intel but they told me they didn’t provide ME FW to customer and i should contact to Asus.
This is very annoying thing, i informed Asus about it (i guess it will take another half on year), i would like to update any worked version for my motherboard and forget about it. KVM + TLS are working.
I guess this forum can help me to do it (or not) but i don’t know how to start to avoid “brick” my motherboard.
Could anyone help me to find FAQ maybe or describe how i can check an opportunity to flash my ME Partition.
Thanks in advance for any useful info.

I replied to you on twitter some days ago. However, now that more details got shared, it looks like you can easily reflash the CSME firmware on that board.

As described on the manual (1-13), set the DIS_ME jumper to “Disable”. Download the latest ASUS BIOS/SPI and use UEFITool to extract the “Intel image” portion (size 0x1000000). Be careful to not flash it directly with the AMI Capsule on top like ASUS delivers it.


Then follow the CleanUp Guide with the 16MB SPI image you extracted as input. At step 4, use the latest CSME v11 Corporate PCH-H RGN firmware as seen at the ME thread. Once you have the 16MB output of the CleanUp Guide, download CSME System Tools v11 and use Flash Programming Tool with the command “fptw -rewrite -savemac -savesxid -f output.bin” followed by “fptw -greset”. After the reboot, shut down and set the DIS_ME jumper back to “Enable”. Check if the CSME firmware is operating properly by running MEInfo and MEManuf tools.

Hello plutomaniac,
Thank you for you help but could you please assist one more time, i stucked at step 9, because you are described only for ME9 but i have 11… And to be honest do not have an idea which step should i use 9,10 or 11.
Thank you.

Are you reading the correct section of the guide? I don’t think so. You need to follow “D2. CSE (CSME 11 & CSTXE 3)”

Yes thank you for that, my bad, one stupid question, you wrote use latest v11, is it related 11.8 or i can flash Intel CSME 11.21 as well?

11.8 is the latest for your platform