MSI Tomahawk Max BIOS HPET


I have a problem with my bios where there is no HPET option to disable it. MSI told me that it is not planned to be put on the BIOS.

My motherboard is : MSI Tomahawk Max with B450 chipset and the version of bios is 7C02v37.


@Neodyme6 - Can you already see >>> Advanced >> Integrated Peripherals?? If yes, show me screenshot of this page (via F12 to USB)

Yes i can.


@Neodyme6 - Here you go -…504246491765974

If M-Flash says no, then dump BIOS using method outlined at “Annex” Section of post #1 and send to me
[Guide] How to flash a modded AMI UEFI BIOS

If, after flash, you still do not see setting, let me know, I only did single type edit (Setup x2) in case secondary change is not required.
If it’s still missing, then two more bytes need changed

Ok, the flash bios went well and the option is active in the bios so I disabled it. On the other hand, I am still at 10mhz with wintimertester. Is it normal ?

@Neodyme6 - Have changed things before with BCDEdit? Ifg yes, see my comments here, under change log, about HPET and my testing, be sure to look at that image image too
[OFFER] Gigabyte Z390 M Gaming UPD + Completely Revised Blue Theme

Summary, I found best timer results with BCDEdit /set useplatformclock YES (ie system default)
If you do not see changes with useplatformclock Yes/No + BIOS disabled/Enabled, then you need the other HPET disabled instead (in Chipset >> South Bridge >> SB Debug Config >> SB Misc Debug)
Let me know, results of your testing four ways like I did for the results/info shown in link above. If you see the same always no matter what, then you probably need this one instead

If I have to add chipset for you, you will need to pick a submenu item to swap it into (ie replace). Normally I do this in OC section, with Memory PactchID, but your BIOS does not have this submenu.
Do you use CPU specifications or Memory-Z in OC section? If yes, what about >> Advanced >> Super IO Configuration << Do you use this? If not, I can put it there, all settings inside will remain default (or I can change first if you need)

I did several tests and where I get the best performance is when HPET is disabled in bios and on windows. The system seems to respond much faster. I don’t use Super IO Configuration can you put it there please ?

hpet off win + bios disabled.PNG

hpet off win + bios enabled.PNG

hpet on win + bios disabled.PNG

hpet on win + bios enabled.PNG

@Neodyme6 - Sounds like it’s working then, and what you mentioned above is exactly in line with my own testing I linked you to
I can’t tell from your images what is what though, I don’t know what to look at with that program.
I don’t game, or make videos/audio, so none of this affects me, so I’m not familiar with how to check any of this etc. Other than the way I checked in the thread I linked you to above.

If you still want the other setting, OK, I will do, but that is a very involved edit (takes me a few hours of tedious data collection before doing actual edit), so you will have to give me some time to do it.

Okay, well thank you for everything me too I think it worked because I see a great difference.

@Neodyme6 - I thought so! You’re welcome!
So, you don’t need access to the other SB one then, correct?

Yes, but I don’t want to bother you, you’ve already done a lot. If you want to do it, do it, I’ll be happy to do it but otherwise it’s okay. The problem remains that I am at 10mhz when I should be at 3 and a few.

hi Lost_N_bios… what did you change? i need to disable hpet on a X570 tomahawk… i do have amibcp but i dont know what you are changing… did you set just HPET to user?
i miss the HPET and coolnquiet settings

@Neodyme6 - We can first test changing the other setting in the background, this is much easier, and then if that makes what you expected, then I can take the time to make that menu visible for you if you wanted.
Do your tests with CPU-z like I showed in my image, maybe that is the only type of timer that shows it in that way you were expecting, or that shows the timer that goes that low etc (there is several timers to be checked)
The main thing though, timer amount aside, is if your issue is fixed, the problem that made you look to disable this, if that’s fixed then that’s all that matters no matter what any timer shows

But, as mentioned, I don’t mind to do the further edits, just takes time to get it done
Here, please test, this has BOTH the SB one and the one I made visible to you disabled now by default, test w/ and w/out >> BCDEdit /Set Useplatformclock Yes/No
For this, after M-Flash, clear CMOS, enter BIOS and load optimized, save/apply/reboot back to BIOS to make all other changes you want, then test.…529437024332470

@blackfirehawk - AMIBCP not used here (I never use for edits), but for BIOS at #4 >>
Setup module x2 edit (Upper and lower region of BIOS)
+ AMITSE/SetupData module x2 Access Level edit (Upper and lower region of BIOS) required << AMIBCP does this only, in regards to menu visibility, and only to the upper level of the BIOS (ie older CPU’s area)

Ohh! Sorry, I checked to be sure, this one for now (First edit only, post #4), has only Setup Module edits x2 (upper and lower region of the BIOS) to unsupress the setting so it’s visible (Access Level not changed).
So even if you used AMIBCP and it edited both areas of the BIOS, it would not reveal this setting due to it’s supressed in setup.
The above BIOS has all this mentioned edited too (Setup x2 modules, AMITSE/SetupData x2 modules + NVRAM x4 modules), due to needing to change defaults of a hidden setting
AMIBCP does NVRAM changes, top portion of the BIOS only, when you change defaults, but it also does not do them all and only does top area, so not ideal for this BIOS, for anything really

CoolnQuiet located at >> Overclock section >> CPU Features << Can you see this submenu, if yes, show me image of this page with “OC Explore Mode” set to Expert


There is No submenu under OC section that is called CPU Features

I have a x570 Tomahawk WiFi and i want hpet disable and coolnquiet disable…
And i dont know how to unlock them
the bios seems extremly restricted to me…
all i have tried it set the settings to "user" with amibcp… but iam not very familiar with this tool… i didnt even find coolnqiet in Amibcp to unlock


I feel a big difference when QPC is at 10mhz than when it is at 14mhz. I did the procedure and it is smoother when it is at 10mhz and I get better performance. I didn’t find the SB option in my bios and I don’t see any difference with the previous bios.

useplatformclock = no.PNG

useplatformclock = yes.PNG

@blackfirehawk - Please link me to your BIOS download page, are you saying Neodyme6 board is not same model as yours?
It’s OK if you can’t see CPU Features, I can make visible for you then, just need to see root (and top to bottom) contents of OC section then (just at root level)
Please take new screenshots of ROOT of OC section, top to bottom, put in a zip. Do not use camera, please use F12 to screenshot to USB
As mentioned, AMIBCP cannot be used here, at least not for what you want, and or at least not without other edits being done first that AMIBCP cannot do
Don’t worry, I will make what you want visible

@Neodyme6 - You will not see the option in the BIOS I sent you last, it’s just disabled by default (Both the one that is hidden, and the one I made visible for you)
From your images above, it looks like you do not have windows default set yet >> bcdedit /set useplatformclock TRUE
That, or when those images were taken, BIOS HPET was set to enabled? Are you using latest Windows 10 version?
With BIOS HPET set disabled + useplatformclock true, you should get 3’s across the board with CPU-z timer, or around that at least, it’s what I see in my testing - (Bottom left corner)

No my HPET was indeed disabled and I don’t get the 3mhz you get when I disable it in the bios and type the command BCDEdit /Set Useplatformclock true… and my windows is up to date.

Very odd, maybe due to windows versions not same now as when I tested etc, I don’t know? I don’t know/use anything that HPET affects, so my only way of testing/knowing what’s enabled/disabled is via the CPU-z method I showed.
What made you want HPET disabled, and does either BIOS I sent you now work better in regards to that, or still same issues no matter what? And, did either BIOS seem to work better than the other, if yes, which one?
If it’s the later one, then I will make you BIOS with this menu visible somewhere, that way you can enable/disable both HPET at will, and see if you can come upw ith better results via mixing enable/disable on one or the other etc

I believe that there was no real difference in reality with the 2 bios and the HPET option and even with the original version before I also had 10mhz…

That would be odd, for that to happen ONLY with this motherboard, when all others change this properly once you edit or make visible etc. And this contradicts what you said at post #7??
Try /set useplatformclock YES instead of true, maybe true is not setting it anymore same as Yes does? I use Yes in my testing, and the only time I seen 10 or above is with this set false and or BIOS HPET enabled
You may also need to reboot after any BCDedit, I am not sure? So be sure to do that when you test