msi z270-a pro only works with two ram memories

Hi, the msi z270-a pro motherboard only works with two ram memory cards when I add one or two more and it won’t boot anymore. Now I am using with two 8gb modules and I have two 4gb modules unused because of this problem. The cpu pins are fine, the cables are also well installed on the motherboard. So I don’t know what the problem is that the pc only starts with two ram memories. I also tried the ram slots and they all work. I cleaned the slots with a fine brush and also cleaned the ram slots with an eraser but nothing, it does not work. Also when I changed the motherboard I did a clean Windows 10 installation. I attach a Windows image where you can see that it does not recognize neither the processor nor the installed ram and the second image is the most curious one which is something connected to the M.2 but I do not know what it is, that component connected to the m2 already came with the motherboard I bought.
Well I hope you can help me to solve this problem.
Thank you very much in advance.
Best regards.

hdfghhdsdfgh.jpg


ghkffdfhhdfh.jpg




Note to moderators: This same post was published in another forum less specialized than this one. I hope here to be lucky and with your help to find a solution. Thank you very much in advance.

Maybe you forget to disable xmp in the bios?
If every module has has different xmp it will not start.



is disabled. Thank you very much. Best regards.

This seems to be a m2 to pcie adaptor.

@Virus - So, you tested each slot one by one with one of your 8GB Sticks, and memory shows up properly? If yes, then no slot issue, or CPU pin issue (maybe).
Did you test both slots with two memory in pair, using slots 2+4 from CPU (2nd from CPU and furthest from CPU, these should be loaded first).
If you tested those with two sticks, then the other two, and both ways all memory shows up properly, and you can see proper total amount in Task manager >> Performance / Memory area, then no bent CPU socket pins

If all discussed above is OK, then it’s possible these memory are just not compatible. I would not mix 8GB and 4GB modules anyway, this is only asking for issues such as this.
Memory is cheap now, try to at least get matching sizes, speeds, timings, but ideally if you can get matching kits at the same time this will be better for compatibility so you know all IC’s used in each kit should be same type

I would also go ahead and update to latest BIOS in case you are on older BIOS with some bug. Then in BIOS load optimized defaults, save and reboot back to BIOS to make other changes you need, then go to windows.
What CPU are you using?



I’m using an i7-7700. I took out the heatsink and changed the thermal paste and reinstalled it. But still the pc doesn’t work with three or four ram memories, it only works with two. Now I have an 8gb module and a 4gb module. I also updated the bios to the latest version, but it still doesn’t work. I took a picture of the motherboard cpu slot to see if you guys see anything wrong with it. What I can check is that it works with 4gb+8gb, with 4gb+4gb and with 8gb+8gb. I also set the bios to default. Thank you very much. Best regards.

Translated with wwx.DeepL.com/Translator (free version)

IMG_20200616_125115.jpg


1.jpg

As mentioned, the memory kits may not be compatible, or at least not when all slots are filled (that is harder on the board and or CPU memory controller)
It’s never ideal to mix different sized modules anyway. So, best thing for you to do is get more 8GB sticks, same speed/timings as your current would be best.
You may need to adjust memory voltage and or raise VCCIO for this system to be able to run mixed 24GB of memory

What do you expect anyone to see in that blurry socket image?? Please take it again more clearly, and from a few different angles if you want us to check socket pins for you.
And best to take the images from off to the side at a downward angle, not straight down from above. In the BLUR I can see at least several areas/pins that look bent, but that could be all due to the BLUR, sorry can’t tell at all with that image
Also, blow the dust bunny out of there too

In the above task manager image, I see 2 of 4 slots filled and 12GB showing up properly, so looks like they are working together at least when only 8+4GB is installed.
Now, please move those two sticks to the alternate slots, does everything still work and show up same in task manager in the other two slots?
What memory speed do you have set, and what main timings? And what voltage are you setting for memory voltage, try adding a little here and set VCCIO to 1.1-1.25 to see if that helps


when I put the two memories in the other slots I had blue screens.

Try again in the same two other slots, but alternate the sticks. If no boot, then show me better images of the CPU socket, may be bent pins causing those slots (or one of the two) to not function



1.jpg


2.jpg


3.jpg


4.jpg


5.jpg


6.jpg


7.jpg


8.jpg

Well seems that u have an ALIEN in the socket…or not. It seems to cover 2 pins, now depending on the material…it can prevent correct pin connection.

@Virus - So, what is result of what I said to test??

Thanks for images. CPU bottom images all too blurry to see if anything missing or damaged. But, in one it looks like there may be some thermal paste on the pads too, clean this off with alcohol too.

I agree, as mentioned above, looks like thermal paste chunk in there to me, and it looks like some in socket near bottom too, but pins may be OK there
To remove this, use light haired paint brush tip dipped in alcohol (ISO - 90%+ is best, but 70 should be OK)
Lightly brush in the direction the pins are laying at that area, re-wet with alcohol, repeat, until the thermal paste is all cleared, then let dry.

Next time you take socket images, no flash and bright room works best. Good angles there though

Apart from cleaning the cpu, I tested the ram memories. First at two 4g and then at two 8gb, no error marked memtest86. What I could see in that program is that the two 4gb files were 17-17-17 and the two 8g files were 15-15-15. Will this have something to do with not running the pc with the four ram memories?

U mean u cleaned the socket…related to wot we observed in ur photos, the debris were in the socket not in the cpu itself.
Different timings in RAM modules usually r rounded by the bios to the lowest found in all modules…as long as the higher one can drop it, here sometimes lays the problem and the so called compatibility issue.
U can check all the timings supported in each pair (equal pairs i mean) of the modules using HWinfo or Aida64, test it using default bios settings and off course no XMP profile enable.
This can be ur case or not…and if not u can have an HW issue on the memory controller of the motherboard.



This will tell the thermal paste on the socket? I put a Masterair ma620p on top of it, I will see how I do it because it is a complicated heatsink to remove and then install.

1.jpg

Yes that’s it and as @Lost_N_BIOS also noted, i did saw on the bottom of the socket some other not so conclusive area that may be affected.
Use a nice lamp and a magnifying glass to do an exhaustive search on the socket for debris, clean it as was already instructed to u by @Lost_N_BIOS post
or a more uncomfortable approach can be done with a needle or tweezers carefully clean the debris and always try to cover it whenever the socket is not populated.

Attached are screenshots of the bios out there you see something that by setting it up can make all 4 ram’s work.

1.jpg

2.jpg

3.jpg

4.jpg

5.jpg

6.jpg

7.jpg

8.jpg

9.jpg

10.jpg

11.jpg

12.jpg

13.jpg

14.jpg

15.jpg

17.jpg

18.jpg

The bios looks ok but I would recommend you to unplug the pc, remove the CMOS battery for a couple of minutes for it to reset everything. Reflash the bios using intel fpt instead of MSI M-flash. If it still doesn’t work, you may have an hardware problem (bad cpu, bad socket, bad motherboard)
Because you bought the motherboard used and it came with a M.2 to pci-express adapter, I guess your motherboard was used for mining cryptocurrency and that kind of hardware has a lot of stress on it.

Looking at bios used bank slots, it is advised to be as 1rst channel populated the A2-B2 (U have A1-B2), use the motherboard manual.
Now looking ur modules…running 2 very different modules specs, not even an equal frequency…2400 and 2133, very bad choice, its always recommended a similar pair of modules using dual channel memory banks.
Now if the 2 other 4Gb modules that u have are also a complicated mix of specs…putting all them 4 together…then yes, i do believe that u can have here a bad situation on ur hands.
U can mix modules from manufacturers but in modern dual channels motherboards, the modules have to be the same size and frequency, preferentially from the same manufacturer if u want to achieve a stable system.
As always…this is only my perspective view of ur situation, no statements or miracles here. Good luck.

@Virus - Yes, image on post #15 shows the thermal paste I was talking about cleaning out (and some below that, in bottom middle of socket (but that may be OK)
Set ALL memory to 17-17-17 and try again - But, as mentioned, always hard to mix memory, especially different sized modules, it may work OK with pair, but when you populate all slots it’s even harder on the board/CPU/Memory controller.
So you’ll need to loosen timings, and add voltages as I mentioned, then “maybe” it will work

I advise you remove the 4GB modules and only use the 8GB modules, until you can purchase more 8GB modules of same speed and timings at least, same model would be most ideal.