Need help getting proper speed from SSD

Hello everyone,

Last few days I’ve been doing some research and I stumbled upon this website. Hopefully, this is the right place for this question. I have an A8N-LA motherboard which is very old ~2005. It’s running Windows 7 64-bit. I recently installed an SATA 3 SSD on it via the SATA connection. I know that this motherboard supports SATA 2 (3 gb/s) because I see my other hard disk in the bios listed as SATA 2 (3 gb/s) but for some reason the SSD shows up as UDMA 5, not SATA 2 in the bios. When I perform speedtest via CrystalDiskMark, I get speed of ~130MB/S instead of double that. Additionally, in HWInfo it states Drive Controller: Serial ATA 6Gb/s @ 1.5Gb/s. Is there anything I can do to ensure I get SATA 2 speeds? Please let me know if I need to provide additional info about my system.

First thing to do is move the port the disk is connected to, try switching the ports for each HDD. I see conflicting info on HP site, two SATA ports, or four? Try them all one by one and see if all are the same for the SSD.
Some ports may be controlled by a slower controller than the main one you were originally using, try moving the SSD there first and see if speed is the same.

It’s an ASUS A8N-LA (Nagami) v1.02 motherboard with the latest BIOS that I know of: Phoenix AwardBIOS v3.11. It has four SATA ports. I tried all four ports and all of them produce the same speed. I have attached some pictures for more information.

BIOS - Advanced Tab.jpg

BIOS - HDD Detail.jpg

BIOS - SSD Detail.jpg

BIOS Main Tab - HDD.jpg

BIOS Main Tab - SSD.jpg

Device Manager.JPG

nForce SATA Driver.jpg

SATA Ports.jpg

SSD Driver.jpg

In first image I see there is two SATA Controllers, so it’s likely one is slower than the other. Probably faster ones are SATA1 or 2. Are you using the latest chipset and SATA Controller drivers? If not, check chipset for model info and download latest drivers from Nvidia

Where is your IDE/AHCI setting, or some really old BIOS only show SATA or IDE as choice then you want SATA? Make sure that is set to AHCI or SATA. If you are currently on IDE mode, you will need to make some registry changes in windows before you change BIOS to AHCI…-the-boot-drive

UMDA label can be ignored in many instances, but you do have a speed issue. What does it show up as in CrystalDiskInfo? BIOS is so old, it doesn’t even know what a non-spinning disk is, that is likely why it’s messed up looking.
And it does appear you have the SSD currently in one of the last SATA ports, for now move to first so it shows up in the top 1-2 on first channel.

Sometimes, this can only be fixed by a clean operating system install. If you are OK with that, it may be quickest option to try and solve the issue.

Please post a link to download your BIOS, I am unable to find one, and HP site does not show drivers or BIOS I checked several HP sites. Once I have copy of the BIOS I can possibly get a better look at what’s going on and if updating anything is possible.

Thanks for your detailed reply. SATA ports 1 & 2 belong to SATA 1 Controller and ports 3 & 4 belong to SATA 2 Controller. I’ve tried all of them and they are all producing the same speed. I did get the latest drivers from NVIDIA; the chipset I have is NVIDIA GEForce 6150 LE / Nforce 430. The latest drivers are here:…spx/14875/en-us - you are correct in that it’s a really old BIOS and there is nowhere to select IDE or AHCI.

In CrystalDiskInfo, I am consistently getting 135 MB/s read and 110 MB/s write. Actually, this was a clean install and I don’t mind doing it again if I can figure out what to do to fix this.

I am attaching all the files that came with the BIOS package. I had to add .apk at the end of each file since it wasn’t letting me upload.

Thanks again for taking the time to help.

Flash.exe.apk (29.5 KB)

311.rom.apk (512 KB)

Installer.exe.apk (514 KB)

sp26834.rtf.apk (1.74 KB)

WinFlash.sys.apk (5.5 KB)

Thanks for the info and files. So, in BIOS, on the SATA Controller settings, what is the option there only disable/enable?

Zip file would have let you zip it all up and add, all I need is the rom, let me check and see.
I meant what does it show the transfer speed and mode as in crystaldiskinfo, like you see here


You may have better luck/speed on a single disk RAID enabled setup, but I am not sure if that can be done on Nforce chipsets like it can for Intel.
The odd part is your normal drive gets proper speed and disk detection, but SSD does not. Do you have other SSD you can test quick on this board, to see if maybe the issue only with this certain model SSD?

You’re welcome, I may not be able to help but I’ll take a look and see if there is anything noticeable that can be done.

* Edit - Do you have flash programmer, to recover from failed BIOS flash? I can update NVRaid module, and I see UDMA mode in the BIOS is disabled by default which I can enable (Not sure if that would work or help though, due to info below at techpowerup link)

Little tips here might help too, about the default windows controller driver?…ing-windows-xp/

Seems SATA1 is the default, and only IDE or RAID For these boards, due to cheap chipsets per this about NF4 chipset three variants

But, maybe no one edit BIOS to enable UDMA like I am thinking to try?

I need you to give me the hardware ID’s of your NVIDIA nForce RAID Controller via (thanks @Fernando - at ) NVIDIA nForce RAID Controller - Open the “Storage Controllers” section of the Device Manager > do a right click onto the Controller > “Properties” > “Details” > “Property” > “HardwareIDs”.

Maybe then Fernando can direct me if I get lost, on creating best updated rom for your system.

We’ll use the 9.87 for NF4 from this thread (And I spent 30minutes + looking for old 5.5-5.60-6.94, all along we had it here at win-raid) - AHCI & RAID ROM Modules

See also, this for better drivers
NVIDIA: Optimized nForce Driverpacks for Vista/Win7-10

Yes, that’s correct. In the BIOS, you can only enable/disable the SATA controller. For IDE the options are primary/secondary/both/disable. I’ve attached the snapshots of CrystalDiskInfo for 3 drives: IDE HDD, SATA HDD, and SATA SSD.

Unfortunately, I don’t have another SSD to test with.

I don’t have a flash programmer, but I can get one if what you see in the BIOS file looks promising. My BIOS chip seems to be soldered on to the board. Attached is a picture.

Thank you for the links to the tips. Regarding the first one, it’s not applicable since there are no RAID options in my BIOS. Regarding the second one, attached is a picture of the NVIDIA chip. Not sure if you can tell anything by looking at it.

What does it mean to enable UDMA mode? I mean, currently, I see the SSD in UDMA-5 mode. Does that mean it’s enabled or disabled? I would think it’s enabled.

In my device manager, the only thing I see related to this are the SATA controllers (attached pic). The hardware IDs for those are below:

NVIDIA nForce Serial ATA Controller 1


NVIDIA nForce Serial ATA Controller 2


BIOS Chip.jpg

Device Manager.JPG

NVIDIA Chip.jpg




Here’s what I was talking about, enable UDMA modes (All disabled by default) I see ACS-3 standard in your SSD image from crystaldisk, this is correct for SSD, but the 150 above that isn’t

Sadly, for that type of soldered on BIOS chip, there is no clip-type adapter. So flash programming is out of the question unless you can do that kind of soldering. Which also means flashing a modified BIOS is very risky

RAID may only appear with two similar disks installed, and like I mentioned it still may not be an option with a single disk on your controller like it is possible with Intel controllers.

UDMA is like a transfer mode, you want 6 or 7 (Like ATA100 vs ATA133 etc or UMDA100/UMDA133). Ultra ATA/100 = ATA-6 - Ultra ATA/133 = ATA-7 - These really apply more to IDE devices though.

Ideally you want/will use above UMDA-6 or 7, but you want it to at least show UMDA-6-7 as those are the max. 7 is max, but board/BIOS may only be programmed to show up to mode 6 or even 5 may be the max value programmed back then
SATA is not measured in that same way, nor uses that terminology, so you shouldn’t see any of that with an SSD, but since board was made long before SSD it doesn’t know what to do (It’s probably trying to report to you somewhere the drive stopped spinning too)
I also read that many older chipsets like these don’t report the data correctly no matter what, so programs can’t detects things properly with modern or even older hardware.

What speeds do you get with the SSD connected to the black SATA1 port, using CrystalDiskMark? Your spinning HDD does not show correct mode in CrystalDiskInfo either.
How about a comparison image please, SSD and HDD in CrystalDiskMark. Set zero fill (File, test data, zero fill), then set it to run 5 tests at 100MB for the HDD test and 5 @ 1000MB on the SSD

Thanks for the hardware ID’s. I am unsure if BIOS flash is safe in this instance, but @Fernando may be able to best advise me on relative safety since he is familiar with editing and inserting this module into these older BIOS and has had many reports back from users on test BIOS while modifying the NVRaid modules for others.
We’ll wait to see what he says the risk level is, but ultimately up to you to decide of course. I’d advise against it if he says it’s a high risk flash, since you cannot easily use a flash programmer to recover

I see. Here is the comparison between the SATA HDD and SSD using the settings you mentioned. Let’s see what @Fernando says. If it’s safe enough, I’m willing to flash it, especially, if he knows of other people who may have tried the same thing. Thanks for your advice; I appreciate it.



You’re welcome, and Thanks for the image comparison! It’s definitely not good for the SSD, it’s maxing out 1.5Gbps as expected
Did you align the partition on the SSD? It shows correctly aligned in AS SSD? I know this is not the problem here, but wanted to check to be sure while it came to mind.

Many people have flashed modified BIOS into these boards, but many failure too, and I’m not sure how people were recovering back then, if at all.
Desoldering chip maybe only way to recover that type of BIOS, which would involve 4 solder sessions too one to remove from board, one to solder to PCB adapter to put in programmer, then desolder from adapter and resolder to the board.

I’m not sure I understand what “align the partition on the SSD” mean.

@Lost_N_BIOS :
Although I didn’t have the time to read all posts of this thread, here is my short comment:

  1. It is possible to set any on-board NVIDIA nForce SATA Controller to “RAID” without the need to create a RAID array (only disadvantage: The user will not be able to boot into the existing OS thereafter).
  2. Flashing a modded BIOS is always somehow risky, but according to my own experences the worst case after having flashed a BIOS, which contains a wrongly modded NVIDIA nForce RAID ROM module, is an unbootable system. I was always able to recover everything after a reflash of the latest original mainboard BIOS.
  3. If you want, you can send me your modded nForce RAID module and I will do a look into it.

Thank you @Fernando for the info and reply!

1. I can help him deal with via registry edits, maybe, but I’m not sure if same Intel edits work on nForce? If not, he said clean install is OK to redo, so this may be desired outcome, with updated NVRAID module.
2. Thanks for this info, that doesn’t sound as bad as many bricked BIOS bad flashes. I agree, no boot to hard drive can be fixed easy by reflash proper BIOS from DOS.
3. Will do, once I do the mod, thank you again!

@corrosion - that’s not a good sign
It’s OK for now, sometimes operating system will auto-align for you, lets check first and if it’s not aligned I will show you how to align next time around .
It’s not easy with already installed OS, but can be done, however see my thoughts above clean install may be coming anyway so we will wait if it needs fixed and just do before next clean OS install

Please open AS SSD -…4&download_id=9 (Download is at very bottom of page, little cardboard box w/ green arrow)
Select your SSD and then send me image (no test run needed, but you can if you want)
You will see some numbers on left under SSD name and FW version, driver used, Green OK or Red Bad

Hi to everybody,
Could you advice me with my question:
I have motherboard BIOSTAR NF4U AM2G with chipset Nvidia Force 4 Ultra.
I gave this computer to my parents many years ago. Three months ago I made its maximal modernisation including installation of SSD compatible with SATA III and Windows 7 x 64.
But SSD runs only on SATA I, not SATA II that indicated in specification to my motherboard and chipset.
I tried different SATA ports on motherboard but he still runs at SATA I speed - up to 139-140 Mbs/s. Also I tried to install drivers for Vista x64 from official web site Nvidia, but it didn’t help me.
Can I made run SSD on SATA II speed?
P.S. TRIM, NCQ, SMART functions are active.

Welcome to the Win-RAID Forum!

Since your problem obviously is not driver, but BIOS related (old nForce chipset SATA Controllers and their BIOS modules don’t know anything about SSDs), I have moved your post into this already existing thread about the same topic and hope, that you will get help here by our Forum member Lost_N_BIOS.

Good luck!
Dieter (alias Fernando)

This sounds promising. Yes, I am okay to do a clean Win 7 x64 install. Attached are the screenshots from AS SSD. I’ve included for all my drives. SSD has 2 partitions so there’s 2 for those. Question about my IDE drive: why does it say “pciide bad”?

Also, came across this link:…-the-boot-drive

Do you think this would be applicable to me since I don’t have any AHCI options in my BIOS? Do you think it’s worth trying anyway?





@_RAMZES - I can possibly update your BIOS NVRaid module, according to @Fernando 's guides, but I am unsure if you will need to either run single Disk in RAID Mode, or if the insertion of the module by itself allows the controller to function properly (SATAII) without need for RAID Mode enabled?
Please give me your device ID’s per post #6 on page one.

Since I cannot test the BIOS, it may brick your motherboard. Your BIOS is removable, so you can use this type flash programmer to recover if needed. I would feel better if you order in advance, in case something is wrong with BIOS and recovery is not easy.
Fernando said usually only disk not bootable, but you never know and since you have this option available to you (corrosion does not) it may be good investment for you to have anyway, can save many other modern type boards from bad BIOS flash too.
You need adapter from this seller (Which you can get now or later, let me know if you need now I will add link) for soldered on modern boards like MSI, Gigabyte but for Asus/Asrock you do not need anything else chip fits into programmer already.

Nano USB Flash Programmer

Fernando, can you clarify, hope you know what I mean, does this update help only if RAID is enabled (Single disk or not), or does it also help possibly even if RAID not enabled?
I assume maybe you knew from all the past reports on similar mods done with NF4

@corrosion - thanks, see how it shows Green OK on your SSD, that means aligned. Usually best for first partition is align at 1024k, exactly as yours is now.

Fernando can better answer to us about if the NVRaid module update helps or not in this NF4 situation, or only if when RAID is enabled with single disk does it help.
From what I read it always helps, but I did not see specific addressing of this issue in the topics I was reading, only that updating the module improved results for many users years ago when these were used by a lot more people.

I will look at editing the module and BIOS for you tonight, then send to Fernando first to make sure he thinks it all looks OK (Since you can’t easily recover if flash is bad, worse than just disk failure I mean)

Thanks @Lost_N_BIOS and @Fernando. Sounds like a plan. Looking forward to the end result.

Since the RAID ROM module is only loaded while booting, when the on-board SATA Controller has been set to “RAID”, I don’t expect, that a modification of the RAID ROM has any effect on the system while running the SATA Controller in IDE (or AHCI) mode.

Thanks! So no matter what, clean install is needed, and setup all ran in single disk RAID mode, for this to have any effect.

Ran out of time, may not get to mod tonight, sorry @corrosion - Will edit this if I end up getting it tonight