[Need Help] Modify the value of options not provided in AMIBCP

Hello everyone !

I want to completely disable the CSM Support and remove the CSMCORE & CSMVIDEO modules from my AMI Aptio4 UEFI, to make my mainboard to boot via a pure UEFI environment.
This can also clear the BIOS ROM space for inserting other modules.

First time, I try to delete these 2 modules directly with MMTool ,but debug card show me D6, It means graphics card was wrong.
Second time, I try to modify the ROM file I got first time with AMIBCP, to change the value of the CSM option, but AMIBCP does not show alternative values for CSM options. After I simply modified the values of several options that I thought might be related to CSM, I flashed the ROM file into my motherboard, then the debug card show me D6 again…

So I try to flash a normal ROM file into my mainboard, after normal booting, manually change the options on CSM in the BIOS, restart after saving, confirming that it is a pure UEFI environment,and shut down. Then I using a programmer to backup the BIOS ROM file from EEPROM, and use MMTOOL to delete the CSMCORE & CSMVIDEO modules in this rom file, then flash it back to the mainboard. It worked fine! This proves that the BIOS can boot without these two modules!
BUT! When I use CLR_CMOS jumper, It can’t start normally again! the debug card always show me D6…

Who can help me to disable the CSM Support and remove the CSMCORE & CSMVIDEO modules ?

Thanks in advance!

--------------------



CSM is used by default for the first boot after refreshing the official BIOS, so I cannot directly set the value of Launch CSM to disable. The BIOS will warn me that “Current VideoOpRom operates in CSM mode and needs to be manually changed to UEFI Only”,so disable CSM needs 2 steps:
Boot option filter needs to be changed to UEFI Only
Launch PXE OpROM policy needs to be changed to UEFI Only or Disable
Launch Storage OpROM policy needs to be changed to UEFI Only
Launch Video OpROM policy needs to be changed to UEFI Only, save and reboot to BIOS
Then Launch CSM needs to be changed to Disable

Download BIOS: https://download.colorful.cn/MotherBroar…20V20/1006N.rar

If possible, hope to delete the PXE module as well

@June_Da_Pek - I will check it out for you, if there is stored values for optimal/failsafe of the things you mention that would be what’s causing this, and there should be even if you can’t see in AMIBCP (should be in NVRAM at top of BIOS and internal in Main BIOS volume + AMITSE/SetupData).
After you clear CMOS fail safe would be loaded until you load optimal, so that’s what causes the reset and failure at that point of your test.

No modules need removed, you can simply change everything so that it’s defaults no matter what are UEFI mode. That would be more ideal than removing modules, why do you need PXE removed (it can also be disabled, only used if you boot that way)

@Lost_N_BIOS
I also think these default values are related to NVRAM, but I don’t know how to modify NVRAM…
I have tried to use WinHEX to compare the [Programmer backup from normal Launched CSM boot official BIOS ] and [Programmer backup from normal UEFI boot official BIOS ], but WinHEX show me they don’t have any different…
Then I have tried to use Universal IFR Extractor to compare the 2 extract txt files [UEFITool extact Setup module as stc file], and fixed the differences between them, maybe I do somthing wrong, It also doesn’t work…

Cause I want to reclaim the space occupied by useless modules to insert other modules, So I have to delete this 3 modules(CSMCORE,CSMVIDEO and PXE)

I know how to edit NVRAM, not a problem. I can show you if you want, but it’s a bit complicated and hard to explain, I need to make a guide sometime (if I ever have time!)
Changes made by AMIBCP are done on NVRAM (but not all NVRAM, so you have also edit other NVRAM if you want to change it in all places in BIOS), and it also changes the stored default optimal/failsafe value for each setting at AMITSE/SetupData module too.
Any “Text” change made in AMIBCP is saved in setup module. This is only time you would see some change in setup module or IFR, if you changed something text-wise in AMIBCP (like the name of an item)

Here is some information I’ve posted for others before, about editing NVRAM, it’s tricky to do and hard to explain, I need to make a guide about this
NVRAM edit explained - Determine configurable aperture size from BIOS file
Setup and NVRAM editing here as well - [Help] Unlock advanced menu on 2019 Acer Predator Helios 300 PH315-52 (5)

And here is how you edit AMITSE/SetupData module - [Request]Maximus XI Hero - Unlock AMIBCP

You probably do not need more space, only need to know how to insert what you want, properly. I suggest against removing those modules, something else could be removed instead if free size is a must, but I bet it isn’t and you just need to do something differently.
What are you trying to insert, that you don’t have room for?

As I mentioned, I can edit all that for you if you want me to?

I think I really need to delete that modules to reclaim enough space…

In fact,the reason I send this thread is because I can’t insert other modules what I need…
I create a report for official bios used MMTool, but the report show me a wrong message: my BIOS has just 4MB, the Firmware Volume : 02 have 7KB free,5232KB used, ???,it more than 4096KB ?
OK,no matter how big it is, I just need not less than 340KB free space, so I compressed CORE_DXE use MMTool and create a new report, this time the Volume : 02 have more than 1MB free sapace, then I try to insert all modules what I need. but in this time, when I try to insert the largest module file into BIOS, MMTool will reports an error (Independent of insertion order): “reconstructVolume: root volume can’t be grown”, this error maybe means we don’t have enough space…

I think the CSM support is useless for me, so I begain to do that…

I will learning how to modify the NVRAM and AMITSE from your thread, I like to try these things myself, but I am not sure I can understand you correctly, so I hope you can help me do that

--------------------------------------

I have tried to modify by myself according to this thread: [Request]Maximus XI Hero - Unlock AMIBCP ,Because I only understand a part of the thread…

The result: I failed…

Maybe it’s because I did the wrong thing or misinterpreted what you mean …

OK, I will do the edits for you about the settings, don’t worry, as I mentioned it can be difficult, especially the NVRAM Stuff.
Please attach and explain what you need inserted too, that way I can look into that for you as well, and see if you really do need room to insert, and if so what other possible things you can remove or resize instead etc,.

http://s000.tinyupload.com/index.php?fil…318269805577186

This 7z files what I want to insert incloud Ozmosis 167XMAX and NVMe, Total: 322KB

@ June Da Pek - Thanks. Do you have flash programmer? If yes, I want to send you one quick edit test, where I resize main boot logo/splash, to make more room (if needed) I may not need, but noticed this is huge image so can be compressed to 67kb and look same, if your board will boot with it
I have not gone through process I do to get stuff to fit without removing anything yet, so may not need to do that, but it would be first thing I would look to redo instead of removing anything.

* Edit - I think you were right, sorry! Space is needed, but I think it can be made by resize of boot logo/splash + insert all with my dancing process
If you have flash programmer, let me know, I will send you test BIOS with resized logo for initial test, then if OK I will insert all you wanted, and then look at changing the default setting stuff you wanted.
Also, what is that NVME Module? It’s not the correct one we would advise you normally use for modern NVME mod/insert (NvmExpressDxe_4.ffs).

* Edit 2, while waiting on above answer, I started to look at changing default settings for you etc, and I see this below??
Looks like you are not using correct AMIBCP, all settings you asked about are there and visible, use AMIBCP 4.55

CSM-BCP.png

Yes,I have flash programmer. I never thought of a boot logo before, because it looks so rude…
I don’t know what is this NVME Module, I got it from internet, It can be used in my mainboard.

Ooh! it’s unexpected! I used v4.53 before! I feel like a fool…
Let me try v4.55…

@June_Da_Pek - Good you have flash programmer!!
That is old NVME, not sure if from board BIOS, or one we used to use for NVME mod, but current latest one we use is NvmExpressDxe_4.ffs and you can get full size or compressed version (TINY/Small) here in the “This is what you need” section
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Yes, 4.55 you can see and edit those settings you wanted but, they size stuff, we’ll have to sort out.
I can insert all with logo removed, but that is not ideal, best to resize to smaller, or make 1px tiny black square etc if you don’t care about logo.
There is maybe other things that could be removed instead too, I didn’t check, but if you don’t use Wake on LAN then LAN module could be removed, also possibly other small logo images too

Almost forgot! Since you have flash programmer, make a backup and be ready to recover in case you need to. Then test this BIOS, flash how you normally would, however you created the file you sent me
Let me know if it boots OK, and if LOGO is still shown at bootup. This has no other changes, only logo resized as test to see if this method of compressing that BMP is OK on your BIOS or not (maybe could be replaced by tiny JPG or PNG too, more tests let us know later)
http://s000.tinyupload.com/index.php?fil…186456389826082

Ok,I replace the small version NVMe module.
In fact, I use v4.55 set all boot OpROM to UEFI only and close the CSM Launch,then I delete all CSM modules. Now it can booting in pure UEFI environment, that’s good.
The ROM has enough space now, It doesn’t need delete the boot logo, but I also will change another one for beautiful.
If you want me test

,I will flash it and report to you.

Great you sorted all that out now, nice work!

Boot logo, yes, if you want something else, change to another BMP, replace RAW Body with BMP (extract current RAW Body and save as BMP, look in hex, ect, you will see it’s just BMP
As for the file I sent you, that was stock logo, but saved as RLE compressed, 4xxKB vs 67KB. So if that boots, and you can only use BMP, you can at least keep using RLE compression with BMP and keep KB’s size smaller amount.
It may be possible to use JPG or PNG, but only testing would let you know (be ready to recover if you test)

1 Like