New Cpu/Mobo New Issues

Happy New Year to all.
I just register to make a question since you might be the last people you might be able to help me. I recently bought a new cpu and a mobo. 10900K MSI meg ace, and while everything is on default settings my system is hacing micro stutters especially when try to game. I have tried old/new nvidia drivers, old/new os windows version, MS drivers only, mobo drivers only… and many tricks found on google but microstutters are still there. Tried latencymon and found HDAudbus.sys, ndis.sys, wdf01000.sys, storport.sys, dxgkrnl.sys to have high interupt to process latency. If i disable-fix one then another is poping up.
I post here because i found a 3yo thread to another forum, where a guy had exactly same issues like me and exactly the same files. He found that he had to install a different mei file (not the one found on mobo site) in order to solve his problems. Any opinion? 2 weeks now i am struggling to fix this.
Thank you in advance

Can it be a driver or something can be broken damaged? I will really appreciate any info - opinion. Thanks again

I might be wrong, but try to look at your RAM. Maybe swap the sticks or leave just one of it (then the other one) and see if something changes.
Update your BIOS and if possible (when nothing helps) get another memory (from a friend or whatever).

Thanks for your reply. I hope i am not messing up your thread. I have 4 sticks 3200Mhz cl16.
I tried 2 of them, then the other 2, and also just one. Nothing changed.
I know my memory isnt on qvl list of mobo, but it is in qvl list of the memory brand. Also tried with higher dram voltage, and other timings. No luck.
Can it be a mei driver or whatever this is? The weird thing is that when i make a benchmark my scores are identical to other similar systems like mine. So it seems that everything is ok. But it isnt. Also have never experience any bsod. I have also checked my test memory for 8h without any error. -.-

Please open separate thread for help on this issue. Not related to active topic. Have loads of ideas.

Edit: Didn’t realize which thread I was viewing. Apologize. Please ignore.

What i have tried till now.
Nvidia drivers old / news
Bios firmware update newest/old
Windows os version (x2)
Tried only MS drivers
Tried MSI (mobo) drivers
Tried old system NvMe2 disks w/o installing something, no drivers, no software.
Tried new NvMe2 disk.
Tried to turn on system without any plug in into the mobo. No usb, no fans, etc
Tried 1 stick ram, 2 stick ram, 4 stick ram.
Tried Dram voltage higher and loose timings.
Tried other displayport cable.
Tried other internet provider, other ac connections.
And many small things found on google.
Cant remember anything else right now, i am trying 2 weeks now without success.

Latencymon always find something.

Happy New Yea to you as well!

In the thread you mention, did he link the ME drivers, or give the version he used?
Latest ME drivers can be found here - Intel Management Engine: Drivers, Firmware & System Tools

Disable HPET in BIOS often can help with this too

Hi and thank you
No he didnt and that was 3 years ago.
Should i try to install one you think? I am not familiar with such things though.
HPET have tried before but can try again.
Also tried with xmp on/off
Also tried with cpu at 3.7 only… also 8 out of 10 cores …