nForce chipset problem with XP: How to check, whether the System drive is operating in SATA Mode?

Hi I have a quick question.

How can you tell if its operating in SATA Mode?

In bios for this motherboard (another one - not same since last post) there is SATA Controller option. The SATA Controller is enabled in BIOS. I successfully install XP with it enabled because neccessary driver has been nlite’d. One problem though. In device manager there is no ‘SATA’ (unlike the other motherboard, which was nvidia SATA controller)

So is the BIOS in option enabled or not? A GUI oversight perhaps?

Maybe I need to isntall correct driver? I have tried the “Fernandos Actual nForce Driverpack for XP 32bit v9.0” but that only installs SMBUS (and others) just not SATA.

(@fernando this motherboard is not the same as the one I smashed, they are both nforce though. XP had drivers integrated and so it installs on both)

Regarding this second motherboard:

@shorterxp :
SATA is an interface and IDE is a protocol.
According to your screenshot of the Device Manager your Disk Drives are SATA connected and running in IDE mode.

Please check the driver, which both listed “Standard Dual Channel PCI IDE Controllers” are using (right-click onto them > “Properties” > “Driver”).

They are all Microsoft, from 2001. All of 6 them, Primary and Secondary and PCI IDE you suggest.

FYI motherboard is 2008.

Wikipedia says SATA was launched 2000. This is a side curiosuty, if sata was introduced 2000 I wonder why nforce boards need drivers nlited? nvidia doing things in a non standard way at high level (and making things worse) I presume. nforce seems like nothing but problems… nvidia trying to capitalize on northbridge segment I guess

It is the XP in-box IDE driver named PCIIDE.SYS.
If you want, you can replace it by an nForce SATA driver v6.xx series, which is running in IDE mode as well, when RAID is not enabled within the BIOS…

They only need an integrated or loaded via F6) nForce SATA_IDE or SATA_RAID driver, if the on-board nForce Serial ATA Controller has been set within the BIOS to “RAID” or “AHCI” mode (only a very few nForce chipsets do support AHCI at all).
.

Hi thanks

There is no RAID option in BIOS, only SATA. BIOS has limited options, typical of 2008 OEM system.
I will leave SATA controller option ON in BIOS and try install driver v6.xx. Please suggest if this is wrong.
Thanks.

FWIW The reason I’m asking these questions, is obviously this system was not supported by XP so drivers have to be searched (a story I’m sure you know many times).
Anyway, the system has occasional drop-outs during intensive 3D application. I worry that is SATA controller related. Which is why :slight_smile:

NVIDIA Inspector.png



EDIT by Fernando: Inserted picture resized (we need information, but no desktop screens)


check all four IDE channels for runnning mode
if mode is dma/ultradma it is OK
if mode is PIO it is BAD, this mean windows has some issues with dma/drive and switched to slow cpu intensive pio mode

Okay thanks

Ok I’m still having issues. I think its related to nforce/OS/write caching. Anyone knwledgable on this subject?

Theres random freezes, in particular, during USB writing/reading. Single file copy OK. 1 big file, (the first time I saw today) it freeze at 95%. Usb has t be pulled for PC to respond.
It gets worse trying to write multiple files to USB 2.0 - its really slow. I can’t fathom if its something I’ve removed from nlite or if its nvidia bus drivers.

mabye nForce Driverpack for XP 32bit v9.0 isn’t ideal for this MCP73S01 HP Mini-ITX with latest bios, old socket 775 motherboard. Otherwise its perfect for my needs, it has two PCIexpress slots and its cheap to populate with parts. PSU is stable, i.e. I’ve checked the requirements. The CPU need 16A on 12v, the PSU supplied 18. All other wattages add up to under PSU rating , with 50watts spare.

my problem is similar to this “USB Headset Causes HP Computer to Freeze until unplugged”. Its also HP with nforce (surprise).

Wha alternative drivers exist to “Fernandos Actual nForce Driverpack for XP 32bit v9.0”? I can’t seem to find useful v6xxx drivers. I’d really appreciate help. I need to use XP, i have no choice for the software I use and this motherboard is great. Unfortunately the OEM doesn’t supply drivers on their site for XP, only vista and win7.

I will try official nvidia 15.57 pack from 2010 http://www.driverscape.com/manufacturers…ops/mcp73/12996

@shorterxp :
Ok, try it.
By the way: Did you find the other nForce driverpacks, which I am offering for Windows XP?

Hi Dieter
Hmm, Remix packs on the nforcershq forum, correct? I have not tried those.

For your interest here is a picture of this cool, rare little gem of a motherboard:


SPDIF out 192khz and 1394 firewire / networking. Its has it all. I plan to add SCSI to it via PCIe x1
They don’t make them like that anymore. Consumerization.

@shorterxp :
If you want help regarding the choice of the S-ATA driver, I need the HardwareIDs of your onboard NVIDIA nForce SATA Controller.

It doesn’t how up in device manager, (see post #1) I tried manual update of driver on Primary IDE as suggested. It shows yellow exclamation.
Whats weird is the nvidia driver installer, on both your v9 and official 15.57 packs, asks if to install nforce SATA driver (I click yes). When I reboot, it’s still primary IDE Device Manger.

There is SATA controller option in bios, when off, OS wont boot. with/without nvgts.inf slipstreamed.

Appreciate your invaluable help.

RE: USB problem. It happens with any HDD/SSD and/or USB stick combination. It could be anything honestly - insufficient PSU, nortbridge too hot. But I think its driver issue myself.

I didn’t tell you to update the driver of any device named “IDE Channel”.
If you want to change the SATA driver, you have to update the NVIDIA nForce Serial ATA Controller, which is one of the listed devices named “Standard Dual Channel PCI IDE Controller” (check the HardwareIDs!).

It must be shown within the Device Manager. Maybe you should look into the “Storage Controllers” section as well.

I manually read and entered for your conveinience

Standard Dual Channel PCI IDE Controller:
Hardware IDs:
PCI\VEN_10DE&DEV_056C&SUBSYS_2A65103C&REV_A1
PCI\VEN_10DE&DEV_056C&SUBSYS_2A65103C
PCI\VEN_10DE&DEV_056C&CC_01018A
PCI\VEN_10DE&DEV_056C&CC_0101

@shorterxp :
Yes, that is the NVIDIA nForce Serial ATA Controller.

Ok.
I force updated manual. If it fails, Last Known Good Config for backup.
With one channel updated: (restart as normal but yellow {!})



Applying nvgts.inf (15.57) to second channel, restart fails - BSOD.


I will reply tomorow with more tests from Actual driver pack v9. Did not realise how busy your on this forum :wink:
thanks again

Why did you try to update the driver of the “Second Channel” and why did you apply the INF file named nvgts.inf?

Edit: I see the confusion, “second channel” in #17 - I meant the second Standard Dual Chan. PCI IDE controller (theres two in list). Not the Secondary IDE Channel :stuck_out_tongue:

Hmm I don’t know, shouldn’t it should nforce in device manager? Only because you said

In my third post I thought were discussing the Primary/Secondary, not the Std Dual Chan. PCI IDE controller.
I’ve since realised which is is what now.

I applied nvgts.inf because its the only inf in the 7z archives that windows picks up.
I looked at your OneDrive repository. There is this one:
Fernandos non-AHCI nForce Performance Pack for XP 32bit v9.0.7z

If device manager shows IDE then that means it isn’t AHCI… care to comment?

@shorterxp :
Yes, you can install the nForce SATA driver, which is within the IDE\Win64\sata_ide subfolder of my nForce driverpack named “Fernandos non-AHCI nForce Performance Pack for XP 32bit v9.0.7z”.