Not able to write huge amount of data to Toshiba KXG50ZNV256G NVMe PCIe M.2 256GB

Hi all,

First of all, this is a great forum on which I already gathered a lot of knowledge for the past two weeks, but still not able to get my ssd PCIe working :frowning:

The ssd seems to deconnecting itself when writing a huge amount of data to it.
Have no clue what is causing this behavior. So created an account and here is my first post :slight_smile:

Some specs of my system:
Motherboard ZH77A-G43
Intel 7-series
SSD Toshiba KXG50ZNV256G NVMe PCIe M.2 256GB (PCI Express 3.0 x4) connected on a PCIe 3.0 x16 card
Previous my graphical card was added into that PCIe slot, but removed it temporary from my computer to exclude any impact.
2 HDD sata drives (one with windows 10 professional as booted system and another one with data connected to SATA3)
Installed the "pure 64bit OCZ NVMe driver v1.2.126.843 mod+signed by me (at 07/28/2019)"
Installed >64bit Intel RST(e) AHCI/RAID Drivers v13.1.0.1058 WHQL<

I updated the BIOS to the newest version and added the NVMe modules as my motherboard was not NVMe compatible.
This change was successful as I could see the ssd in the boot options overview.

The next step was making a clone from my hdd to the sdd drive. This was running fine until reaching around 1 GB. At that point it was hanging my system and mentioning bad sectors (used several clone progs).

I have also tested both hdd and ssd on bad sectors, but everything is fine so don’t think the drives are causing the issue.
ALso tried the clone program via USB boot whitout luck.

I have also read something about issues when working with SATA and PCIe/m2 together in one system.
So I disconnected the SATA drives and tried booting from usb to install a clean windows 10 installation on the sdd.
I succeeded after several attempts. Booting from ssd went fine, but after some minutes windows 10 was freezing again :frowning:
So cleaned the ssd and tried again, but didn’t succeed anymore in installing a clean windows 10 on the sdd.

Booted windows 10 again from the hdd on SATA3 and created a simple volume on the sdd drive.
Copy small data to the ssd works fine, but copying data of around 2-4GB will disconnect the drive.

As last step, I tried checking the ssd using CrystalDiskInfo. The read on the ssd gave me around 2700MB/s which looks fine, but the write will again disconnect the drive.
In the windows error log I could see an error like “Device raidport1 has been removed”.
Not sure if this is meaningful as my BIOS SATA is set in AHCI mode and not in RAID mode (or I am using wrong drivers…).

Also did some other tweak which I found on this forum as disabling LPT, but without change.

This is like my last resort to get this issue solved before smashing the ssd as I am out of ideas :slight_smile:
Any help is very appreciated.

Already thanks!

@Andy1987 :
Welcome to the Win-RAID Forum!
To exclude any issue of your currently used mod+signed OCZ NVMe driver, I recommend to switch to the generic MS Win10 in-box NVMe driver. If this shouldn’t help, please answer the following questions:
1. Why and how did you modify the mainboard BIOS? The insertion of an NVMe module is only required, if you want to boot off the NVMe SSD. Please attach your modded BIOS file as *.ZIP archive.
2. With which name is the NVMe SSD listed within the BIOS?
3. Did you already try to get Win10 installed in UEFI mode as bootable system drive according to point 4 of >this< guide? If not, why not?
Dieter (alias Fernando)

@Fernando ,
Thanks for your quick reply!

I already tested with several NVMe drivers including the one of Windows 10 (did nothing special for this driver as I presume you mean the driver which comes with the windows 10 installation). I also already tested it with OpenFabrics Alliance (OFA) generic NVMe Drivers without any luck :frowning:

1) I modified the BIOS, because I was testing the ssd first with a clover USB. As windows 10 was freezing using this method, I wanted to get rid of the clover usb (elimination of one thing) and so I modified the BIOS so I could directly start the ssd without the need of a clover usb. So yes, I want to boot from the NVMe SSD. See added modified BIOS. I think this part is ok as I could boot from the NVMe SSD at that time.

2) Not sure what you mean with this, but when going into the BIOS (before starting windows), I don’t see anything related to NVMe. I just see SATA, AHCI,… stuff. Should I see something related to NVMe in the BIOS after adding the NVMe to it? I thought it was just something in the background.
When entering the boot menu, I could see the NVMe SSD listed as something like Windows Bootmanager and between brackets the name of the SSD). As this was freezing after some minutes using windows 10, I finally cleaned the ssd again as I wanted to solve the write issue first and because I don’t want a clean Windows 10 installation but just a clone of my current windows 10 version from HDD to SSD.

3) I think I tried something similar: Creation of a bootable Windows WINPE environment, disconnecting every SATA and leaving just the SSD connected, but still same write issue.

Andy. (5.41 MB)

@Andy1987 :
The BIOS of your attached mainboard contains 3 different NVMe modules. Where did you get them and why didn’t you choose the easier and safer way by following >this< guide?
To check whether your currently flashed BIOS really will support booting off an NVMe SSD in UEFI mode, you should look into the “BOOT” section of the BIOS. There should be a device listed with the name “PATA” or “PATA_SS”.

@Fernando ,

I think I partially followed that guide, but I also combined it with the following guide:…i-mpower/136631.

In this guide they proposed to get the BIOS of Z97 which has NVMe supported and extract these 3 modules from it. After this I downloaded the newest BIOS version for my Z77 board and integrated the 3 NVMe modules. I think the only difference is that I didn’t input NvmExpressDxe_4, but the 3 other ones from Z97.

I expected that this was ok as I could boot from the SSD and I can see the SSD if a bootpartition is available on the SSD.

Do you think that the NVMe modules in the BIOS are maybe causing write issues to the SSD when I am logged in to WIndows 10?
I thought that the these NVMe modules were only needed to get the SSD booted which is working fine.

FYI: In windows 10 I can clone the boot partition of my current windows 10 installation to the SSD as it is only 570 MB. After this can see it in the boot options as bootable disk. So think that part is fine no?

Thanks in advance,

@Andy1987 :
If you want help, you should ask for it >here<.
I am not willing to offer support for users, who didn’t follow my guide.

Hi @Fernando ,

I will try to follow your guide this evening and hopefully it will be working after that :slight_smile:
Will get in touch this evening. Fingers crossed.

Thanks for the help,

@Andy1987 :
Ok, but please post your future questions regarding the NVMe support of your system into >this< thread.

@Fernando ,

Yes will do. I already tried to move my topic, but didn’t find any move possibility.


@Andy1987 Don’t use time on your bios. Bios support is only needed for booting from your NVMe disk.

Try booting your old Windows 10 pro (which version?), check if you can see the NVMe disk and controller, and which drivers are installed.

Then try writing data onto your NVMe disk/ reading data from it again. If this is working you might want to do more research on your bios. If it doesn’twork- try to reseat your adapter in the PCIe slot and try to reseat the NVMe disk in the slot. I had to do that once to get my system running stable.

Hi @Fernando , @lfb6

Seems working now with the Toshiba NVMe controller and 64bit Intel RSTe AHCI & RAID drivers v13.1.0.1058 WHQL:


Think the values are ok. No?

Thanks in advance,

Hi @Fernando , @lfb6

Update: When running the bench testing completely, it will do only one write:


In the logs I see the disconnecting error:
\Device\RaidPort1 was removed without warning

The READ score is very good, the WRITE one may be enhanced by checking both write caching options within the "Policies" tab of the NVMe SSD "Properties".

@Andy1987 :
Since the benchmark and functionality tests of your NVMe SSD have nothing to do with the thread "How to get full NVMe support with old systems", I have moved the last posts into your source thread.

Did you enable the "RAID" mode of the Intel SATA Controller?
Maybe you should unplug all other disk drives while testing your NVMe SSD.

Hi @Fernando ,

In the BIOS it is all set to AHCI. Yeah will trying cloning now :wink:
So no idea why is setting something related to RAID.
Now trying with the complete installation of Intel RSTe Drivers & Software Set v13.1.0.1058 WHQL


@Andy1987 :
Why do you want to clone your previously used system drive onto the NVMe SSD?
This is generally not a good idea and will not help you to find out the reason for your data transfer issue.

Hi @Fernando ,
Tried again several things, but I keep on ending up with a disconnected ssd drive and the device error raidport in the windows log.

I also tested a clean installation of windows 10 on the ssd from boot usb and no other sata drives connected, but also this didn’t work :frowning:

Any thought?


Please run the tool CrystalDiskInfo and post a screenshot of its diagnosis of your NVMe SSD.
What about the temperatures of your SSD?
It is not enough to write “doesn’t work”. You should let us know what happened at which point of the OS installation und which error message you got.

@Fernando ,
See below the requested printscreens.

Printscreen of first temperature test + bench (with heatsink):
[[File:first bench + temperature.PNG|none|auto]]

Printscreen of second temperature test + bench (without heatsink):
[[File:second bench + temperature.PNG|none|auto]]

The bench test will stop at the second last or last read point. After that the disk is deconnected.

The disk information of the SSD:


first bench + temperature.PNG


@Andy1987 :
I repeat: At which point the fresh Win10 installation onto the NVMe SSD failed and which was the message you got? Did you follow the advices of my guide?
Additionally I recommend to check your CPU and your Memory (no overclocking!).