Recent I got one NUC board that was witth the power “pin” damaged, so I did some soldering and replaced, after the first boot I discover the bios was with some kind of mod (the manufactor
had put a modified bios on the NUC I supose, so I went to Intel’s website and downloaded the latest update version, but I’ve tried everything and it doesn’t work ( the bios versions don’t match).
I tried it with the CH341 but does not work after or even boot, I think that because I use a upgrade version ?? so I had to go back to the old version and I am stuck ,
I want to replace the Bios because even I change something in Bios setting and after I power down are replaced by the "manufactor defaults"
Can someone help or give me some light on this ??
The Bios saved from NUC board is ARBDWi… and from Intel the last update is

Print 1.JPG

Intel Nuc bio files don’t contain a firmware image, they are more like a building kit for a bios, but they contain everything that is needed to construct a firmware image- one has to combine the different regions and the UEFI volumes to a firmware image.

So that means I have to "build " a bios firmware from the intel bios file, there is some tuturial or guide that I can see ?
Thank you

Intel NUC7i7DNH2E BIOS to flash with hardware Just for the structure. That’s for another model, but the bio file you mentioned looks quite similar.

And you might be missing a new GbE but possibly the old one will be fine. There should be a configured ME within the bio- file- compare settings stored in FD/MD for old and new image in FIT.

Another way would be to look for a dump someone posted somewhere…

I would like to thank you for your kindly help ,
I have it working now after some hours of work

I will attach the bios file if someone needs or have some bricked MYBE board

Thanks for the feedback! Good to hear that you got it fixed