NVIDIA: Optimized nForce Driverpacks for Win7-10


Thanks! This driver version is really installed! You are the best :slight_smile:

Hello Win-Raid Forum!

I need some help with the driver integration in Windows 2000.
Ive managed to get XP 64 bit running on my Z87-G43 with Fernandos modded Drivers.

Now I want to dualboot Win2000 because iam really a sucker for it and i wanna use this as one-decade Retromachine and daily it as much as possible (lol)

I fail badly with "iaStor.sys is damaged" all the time (ive tried it 10 times with ProfessionalSP4, Advanced DatacenterSP0 and SP4 and each with different drivers from here, aswell as "unisata" wich ends in an "unisata is damaged"
I have used x32 drivers all the time. Ive tried different versions and also chose different drivers, i think its DEV_C02 or DEV_C03 but however i get the iaStor.sys

Anybody has a clue?

@Dr.VTEC Welcome to the Win-RAID Forum!
The OS Setup message, that a certain storage driver (here: iaStor.sys) is corrupt, is usually caused by a mismatch of the architecture (32/64bit) between the OS and the loaded/inserted driver.
When you want to install a 32bit OS, you have to make sure, that the loaded or inserted driver is a 32bit one as well, and vice versa you should check, whether you have loaded/inserted a 64bit driver, when you want to install a 64bit OS.
Good luck!
Dieter (alias Fernando)

Hi

I’ve tried 32bit 8.9.8.1005
as well as 32bit 11.2.09.1006

It always kills the “iaStor.sys” so i guess iam doing something wrong?
But i have no clue… I use nLite just as before with XP.

Maybe something goes wrong with my iarstor.sys or my windows image isnt compatible?

@Dr.VTEC
For users like you I have written >this< guide.
Please read the start post carefully and follow my advices.
Good luck!

Is it possible to update the package to v18.37.0.1002? Thanks!

@gpvecchi
Yes, it is possible and I have done it.
Please give us your feedback whether it worked for your system (which chipset?) or not.

Yesterday I have updated the start post again by adding the "Generic 64bit Intel RST AHCI+RAID driver v16.8.4.1011 for Win8-11 x64" dated 05/21/2021 and mod+signed by me on 03/02/2022.

Meanwhile I have tested both recently offered mod+signed Intel RST divers v16.8.4.1011 and v18.37.0.1002 with my Intel Z170 chipset system.
Here is the proof, that both drivers worked:
[[File:mod+signed generic Intel AHCI driver v16.8.4.1011.png|none|auto]][[File:mod+signed generic Intel AHCI driver v18.37.0.1002.png|none|auto]]

mod+signed generic Intel AHCI driver v16.8.4.1011.png

mod+signed generic Intel AHCI driver v18.37.0.1002.png

I confirm 18.37.0.1002 modded drivers installed fine on my Z170. Testing them, apparently nor vantages nor disvantages…

It will always kill iaStore.sys with multiple 32bit drivers you offered and different images of 2000.
Ive tried to load "as normal computer" instead of F6 but then it will give a BSOD with bootable device is unaccecable, ive also burned it to CD → same

In general my process of driver integreation is correct, it works on XP ! There has to be an incompatibility while modding 2000… but i have no clue what it is
Ive also used BlackWingCats SATA driver wich interestingly stucks in "setup is starting windows 2000"

Could someone share a 2000 image with working 8 series driver so i can see if my hardware or image kills it? Would be great…

@Dr.VTEC If none of my offered drivers worked for your system, I cannot help you.
Maybe you will find >here< a usable W2k Intel AHCI driver.

Hello, @Fernando , and thanks for ur modded drivers!
I have a question - which driver actually will be the best for my chipset?
mb: Asus p5e3, its Intel 82801IR ICH9R.
os: win10 x64.
For now I use ur version of driver - 11.2.0.1006. So question is - is this the best, or smth newer will be better? And if so - which one?

@arinoki Welcome to the Win-RAID Forum!
For users like you I have started several years ago >this< thread. After having done a look into the table at the bottom of the updated start post, you will realize, that you are already using the “best” Intel AHCI/RAID driver for the Intel ICH9R Southbridge.
Enjoy the Forum and the performance of your old system!
Dieter (alias Fernando)

@Fernando Thanks :slight_smile: So nothing more to care about :slight_smile:

Hi Fernando! Is there any performance benefit for having this modded driver?

@Kr13
Since the driver itself (the *.sys file) has not been touched by me, the modification has no impact on the performance of the related driver. Only its usability with natively not supported systems has been enhanced by adding the missing HardwareIDs into the *.inf file.
Advantage for the user: Modern Intel RST/RSTe AHCI drivers can be properly installed even onto systems with an old/outdated Intel chipset/Southbridge.
This allows the user to find out the best performing Intel AHCI driver among the big variety of available, but natively not compatible versions.

@Fernando

Thanks for the response!

@Fernando hello again :slight_smile: So, I found some weird problem - MSI mode doesnt work with modded driver (11.2.0.1006, Intel 82801IR ICH9R) - I just get "inaccessible boot device" error on windows startup. And as I remember it worked with default drivers. So any way to fix it? What can be the problem?
p.s. editing registry back via console (linux) was some kind of challenge :smiley:

@arinoki
Supporters need more information than the message “the offered product doesn’t work”.
Which is the chipset of your system, which OS are you running, what do you mean with “MSI mode”, which were the working “default drivers” and why/how did you install the modded Intel RST driver v11.2.0.1006?

@Fernando
Sure.
Chipset - X38, southbridge - 82801IR (ICH9R).
OS - Win10 21H2 build 19044.1645 64bit.
MSI mode is message signal-based interrupts mode. Different from line-based (which quite old). And the most new PCs have even msi-x mode. Overall its used for reducing latency/cpu overhead.
Default drivers - that come with windows itself.
Modded drivers were installed by just right-click on two *.inf files -> install.