NVMe module integration to Gigabyte Z68P-DS3 legacy award bios help need.

Hi guys, i need help with GA-Z68P-DS3 (REV1.0) BIOS to work with NVMe ssd. I’ve tried clover boot loader but no chance.

now on I’m trying to open my a Gigabyte bios file like Z97PD3.F9 as it has a extension of F9. The goal is i need the NVMe modules frum Z97 and integrate to my Z68 Award legacy bios to use my M.2 NVMe ssd.

Can anyone have already moded bios, or integrate the modules for me? Or help me to integrate? Any help or idea would be appreciated

@yabay - I just replied to you on the other thread, will move my comments there to here and delete your other post. Also, moving this thread, since it is not a “already modded BIOS” post

Clover method will work for you, without BIOS mod.

@yabay - Gigabyte Z97 BIOS is neither Award nor Phoenix BIOS, so this is not the thread for you to get info from. Gigabyte BIOS are all .bin, so you can rename that F9 to bin if you want, however nothing you need to open that BIOS requires this, so not sure what you would need to do that for.
NVME rom can only be inserted into UEFI BIOS. So in your Z68 case, you would need to be updated to the beta UEFI BIOS already, have you done that?
If yes, send me a link to the Z68 UEFI BIOS you are using and I will do the NVME mod for you, nothing is taken from Z97 BIOS to put into Z68 BIOS?? That’s why I said I will do for you, I think you are confused about something

*Edit - never mind, I looked around, and only rev 2.0 and 2.1 boards have the UEFI BIOS, which you cannot flash to your board unless you have a programmer _ SOIC8 test clip cable. I can make BIOS mod to allow it, but big risk to you without programmer and SOIC8 test clip cable in hand already
And if your CPU is Ivy multiplier will be locked at 21 or 31, I can’t remember which, but those UEFI BIOS sucked back then, first one hybrid UEFI.

So you will have to use Clover method, or purchase CH341A + SOIC8 test clip cable, or new motherboard.

@Lost_N_BIOS I’ve tried the CLOVER but it didn’t worked. When i boot from clover (I’ve put it to my spare ssd) The boot process works fine, I’ve added the nvmExpressDxe-64.efi file to the proper folders as the tutorial said, but neither i can install win10 uefi or non uefi (as a try) nor from ordinary install, and i dont know if its clover’s or an hw problem, i cant manage boot or driver setup area in the clover cos it throws a red text screen when i press continue to save changes in the configuration page.

I’ve found a beta uefi bios for my GAZ68P-DS3, i will try to install this asap. (lazaj30’ post)


@yabay - Then you need to ask for help in the clover thread, that is your only safe option. You didn’t get it to work, that only means you need to change things in the method until it works, doesn’t mean it doesn’t work.

Ohh,you found a BIOS, good! If that is a BIOS for your board, not rev 2.0 or 2.1, then it will work, then we can modify NVME Module to that BIOS after you’ve updated to it, then you reflash again from within BIOS.
Here is that BIOS with NVME mod applied - http://s000.tinyupload.com/index.php?fil…572385144431417

You will then need to follow all steps exactly in this guide at step #4
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

When i try to upgrade bios from a usb stick wich has bootable dos ity says bios id mismatch.
Modding uefi bios is easier to mod award i think…

The file is taken from tweaktown stasio’s post…

What is wrong with this motherboard :frowning:

@Lost_N_BIOS Can we edit my award bios?

@yabay - First you must update using stock BIOS, using >> FLASHEFI.EXE Z68PDS3.U1A
If that does not work, download the rev. 2.1 BIOS, and use the flashefi.exe from that package instead.
Then after that you can reapply the modified BIOS I attached above in post #4

If you continue to get BIOS ID mismatch then that BIOS may not be for your board revision. You can try the following, with stock BIOS and FlashEFI from rev. 2.1 package if the one from Stasio link continues to fail

Show me image of CPU-z motherboard tab, and image of sys info from inside current BIOS (F7 or F9 I think)

Award BIOS cannot be edited to have NVME, but yes it can be edited, just not for NVME

I give him new link with replaced FlashEfi ,on tt forum.

He get UEFI Flashed now, or no? Tell him above BIOS I put NVME on post #4

Dear Friends, the upgrade process is seems fine now, Lost_N_BIOS And STASIO you are my hero!!!!

First I’ve downladed Rev.2.1’s bios pack and take Flashefi and put to my bootable dos usb stick, then it flashed to Z68PDS3.U1A then i tried the Z68PDS3M.U1A but it didnt, i flashed it with my new UEFI bios via Q-flash.

Now on i have both UEFI and nvme support. (ı can see a PATA device extra in my list)

For now all my ohther drives are disconnected except this os running ssd and nvme

There is a small problem remaining. with 2 different versions of Win10, I succesfully install them to NVME drive but when i restart it gives a error screen. 0x000000e

@yabay - Yes Z68PDS3M.U1A flash via Qflash correct?

To boot from NVME you need to do a clean install, follow all steps (exactly as written) in the “This is what you should do” section @ #4 (Installation of the OS onto the NVMe SSD:), and be sure to remove all drives except the NVME drive during this process, you can put back others once you are done.
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Yes Z68PDS3M.U1A file flashed with Qflash correct.

I’ve made clean install 4 times, the result is same. I’ve booted from win10 usb stick and entered CMD,

bootrec /scanos (ok found one)
bootrec /fixmbr (succes)
bootrec /fixboot (not success)
bootrec /rebuildbcd (pressed Y and success)

Aha! in the step 4 it says, GPT… i think my drive is now on MBR type, i’ll check now.

If any defective adjustmesnt seen by you?

I cannot see your images, use forum attach image feature in advanced replies. I do not know about this setting up Win10 / NVME, you’ll need to ask on the thread I linked above about NVMW Setups.

Yes, drive will need to be GPT, and you need to do a clean install.

Lost_N_BIOS Thank you again for your help, and also Stasio!!

As you mentioned, the m2 has to be GPT and the win10 also, the #4 guide really helps…

I fully installed win, drivers etc with no problem, 2 days before while i was using this with legacy bios + M.2 NVMe, the bench results were about 1150mb/s, then i installed win10 and use as a primary device, the speed maxes to 390mb/s… All updates done, trime eneable etc, bios settings been tried all combinations, nothing changes. I think there must be a restriction from the pci adjustments but there 2-3 basic adjustment in the new uefi bios. Can it be the new uefi bios restricts the speed?

links have same picture


@atto, crystal and AS ssd tests, clearly there is a restriction. in atto i can see the detailes and all i gaind is a stable 398mb/s nearly all lines except small data round.

@Lost_N_BIOS The M.2 is no more shown in bios now, i can see in the OS and write/read but in the bios section it disapeard, WIN10 installation shows and install.

@yabay - great it’s working now! Yes, Crystal Disk and AS SSD use compressed data for testing, you can set zero fill on crystaldisk if you want >> File >> Test Data >> All 0x00 (0 Fill)

I’ve take out and cleaned my graphics card, when i installed it again to the case, it didint worked and i gave a bios reset, then i lost my m.2 in the bios of this, when i updated the bios again from your mod file, its ok now can seen by bios runs with no doubt except speed issue…

"@yabay - great it’s working now! Yes, Crystal Disk and AS SSD use compressed data for testing, you can set zero fill on crystaldisk if you want >> File >> Test Data >> All 0x00 (0 Fill)"

now i’ve tested my corsair force series 2x raid0 ssd’s with crystal diskmark, they gives about 900mb/s in first time using after installation, then programmes added 700, but atto gives 1050mb/s everytime, In M.2 bench, crystal and atto gives similar (390mb/s)


No nothing changed with All 0.00 (0 Fill), although M.2 is in sotrage mode now and gives 350-400 mb/s :confused:

Besides, Lost_N_BIOS, the integrated module version can cause this speed restriction in the bios? Is it worth to try a nother module? If M.2 cant reach 1000+, our effort will become useless.


(can you see my image link?)

@yabay - yes I can see your image link. Module is inserted correctly, there is no other modules to try.

Some boards split graphic card lanes with SATA Lanes. How are you connecting the device? If PCIE slot, try putting in the top x16 slot and retest, the other slot is only x4. Or are you using the mSATA slot?
Make sure no other SATA device on last two SATA Ports on the Intel controller (4/5) Then test with using onboard graphics only, or with a PCI graphic card, so all PCIE Lanes are free
I checked manual, and mSATA slot only has SATA II (3Gb/s) speeds.

What main speed and lane speed does the device show up as in CrystalDiskInfo (Show image)