NVMe module integration to Gigabyte Z68P-DS3 legacy award bios help need.

Nvme drive is connected via PCI-E X4 M.2 adapter card, I changed the nvme with graphics card, the GTX 580 didint gave a post screen in Pci-e 16 X4 slot.

Use onboard graphics for a test, or old PCI graphics card. Or did the 580 work, boot to OS, just not display POST Screen (That might be normal, give it a bit, reboot a time or two, then see if it will boot to OS or not)

Show me image of CrystalDiskInfo, be sure to select the NVME drive. The only thing sharing bandwidth with the x4 slot that you might be using is the LAN

Looks like 1500ish may be the average limit of PCIE 2.0 x4

Did you test setting PCIE Gen2 instead of Auto on the miscellaneous settings page (Or Gen3 if using IVY, but I think this would only help the x16 slot run 3.0)

in X4 lane GTX 580 didint gave any screen, and a vierd beep heard. PCIE gen 1,2,3 auto tested, results are exactly same.

I’ve tried my old spare 8500gt standalone boots in X16 slot, but not 8500gt nor the gtx580 boots in the X4 lane

I have all these adaptors, tried all, no change.

Thanks, CrystalDiskInfo shows it’s only running at x1, that’s the issue. Are you sure those adapters are x4 speed, not just x4 physical connection?

@ Uefi, tried all combinations. No change.

Yess i’m sure all adapters are X4. Ok its running X1 now, but before the uefi upgrade how can i tested 1150Mb i dont understand.


This card is Pcie 3.0 x16 and reversable to standarts, and connected with m.2 in the crystaldiskinfo.

I have an OCS REVODRIVE 3 too, for 5 years it works in the X4 slot with no doubt.

I’ll try to connect the revodrive and see if there is a different info in the diskinfo.

Windows boot mode, UEFI, etc have nothing to do with this, so don’t waste your time there. The main issue I assume is this BIOS is extreme beta, Gigabyte’s early first jump to UEFI and they made it hybrid/legacy, half of it doesn’t work properly, and they gave up due to Z68 came out right then too so all UEFI progress moving forward was on Z68 and a few other P67 boards got 1-2 more beta like this one but none ever fixed the main issues (and this probably one of those, nobody noticed back then due to no one using NVME then)

Your best option is to go back to legacy type BIOS, and use Clover

* Just saw your edit. So the Revo works properly, full speed in benchmark, and x4?

This is so sad even with you priceless reccomendations :confused:

revo used to give 1000mb/s in legacy, in uefi its restricted too…

REVO drive shows up as SATA 6Gb/s, no PCIE Speed is shown? See if this app will show you REVO lane width being used
Utility to view some info on PCI devices

What CPU do you have installed, if Ivy, do you have a Sandy one to try? Some CPU Ivy or Sandy worked better on the UEFI than others, but it depended on what you were trying to do. If you have both, try other and see if same, if it’s same, best bet is to go back to Legacy type BIOS.

Revo posts Pcie speed during post screen (as seen above, black one) According to post it shows X1 5Gbp/s

I have only 1 cpu, i5 2500k sandy.

x1 but 5Gbp/s sounds like something "Marvell"

Best to use legacy type BIOS for Sandy Bridge CPU, so your best bet it go back to legacy and use Clover method for your NVME.

Did you test NVME in x16 slot, use onboard graphics and see how the NVME speeds are there. Of course if that worked, it would mean you’d have to stay on integrated graphics to use it like that
But it would be interesting to know if it shows up full x4 speed like it should or not.

I thick it’s the problem is not about the bios but the adapter and the pic-e x4 slot.Try the clean the golden finger with an eraser and clean the pic-e x4 slot with little broom.

If it is so,I suggest you try to flash it back to legacy bios.And try to boot the system with other disk to open the crystaldiskinfo,to have a look with the nvme SDD.

I’ve switched to o/b graphics and put the m.2 to the x16 slot, yes now it has capability of pcie 2.0 x4. My standstill Raid0 config is same as the speeds, so no need to back to legacy bios.

Anyways, with my mobo which has a standart capability of pcie 2.0 this is the max results i think.

Los_N_BIOS you are such a nice person , helped with all these…

@yabay - Thank you too! It’s good you got it working properly now, but this means you loose your good graphics card use correct?

@gloobox - good tip, I didn’t think to clean or reinsert, sometimes that does fix lane width issues - best to check that yabay!

@Lotst_N_BIOS , I’ve sent a message to GIGABYTE offical e-support and they replied. They sent me an upgrade from U1A bios to U1C, There the post screen logo changed and also some improvement in the menu selections but, the seconds X16 lane speed remains as X1… I reported the remaining problem, see if they can make anything.

edit: they replied

Dear Yabay

Thanks for your reply.

BIOS U1c is the latest version we had. Due to this is old model, we would not update new BIOS. In addition, this motherboard doesn’t support Windows 10.

Sorry for the inconveniences.

Best Regards,


I will give a try with win7 if it makes any better than 1000Mb/S, But again i need your help integration the nvme module to the new bios.

The new bios file is below:


PC: we have a good database for GA-Z68PDS3, so maybe it can be useful to the other users if the moded and uefi files added to the bios download list in the forum?

Dear @Lotst_N_BIOS, i succesfully inserted nvme module to the new bios and can see my m.2 in the UEFI section so, for you there is no need to be work on that. According to gigabyte’s message,i’ll give a try with WIN7 64Bit asap

ps: As its worked proper (same speed with my Raid0 config) there is no need to replace the good GFX card and use m.2 in the cards lane. So i’ll try with win7 if there is a major change.

Great you got new BIOS and were able to modify it already too @yabay

link speed x2, isn’t that better now than before? I didn’t look back, but thought it was stuck at x1 before correct?

Thanks for adding BIOS file for others, adds to my pile too

Link speed didnt improoved, still shows X1 in WIN10 , i will tell if any change under WIN7…

For the forum





Ohh, I saw x2 in second image above (now removed?)

From the gigabyte, as its stated, This UEFI BIOS not compatible with win10, then i installed WIN7 64bit again if it make any change? frustration

The 2. pci lane remains the X1 speed. I reported this to gigabyte e-support againg :slight_smile: war continues

I see now, it was your image in post #34 I saw 2 but it was speed, sorry I confused that and though it was link width, I see it correctly now that I look again.

Hopefully they will take the time to test and fix this for you!