NVMe Problems with AOC-SLG3-2M2 Card

ok i am trying to understand this a little
I have the X10DRU-i+ board and using the AOC board with NVME WD black sn770
do i just take a backup of the bios that is on the board now and than add the nvme stuff to it or use the latest from the website?

Also what string would i add it was not real clear what i need to add to the supermicro board

Provide the latest bios file from the Supermicro server, i dont want to create/login in their page. Also provide correct model of the AOC board.
Ill check it for NVMe support on it.
But usually needs NVMe mod

EDIT: The bios 521 already supports NVMe as it contains the AMI NVMe DXE module on it, no NVMe mod required.

I tried the uefi tool but it had greyed out options for insert
it will not let me upload the file as i am a new user
This link should work without signin
This is an X10dri-t4+ and a AOC-SLG3-2M2 card with 2 WD Black NVME drives.

ok that is odd than it will not boot off the NVME cards that are in the system on UEFI or BIOS mode

Presumably you know how to configure the bios as pure UEFI mode and the correct installation of the OS as UEFI, EFI compatible GPU (The ASPEED seems so), secure boot etc…
So all that remains its hw issues, incompatibility/setup (The AOC maybe…).
What else can we say…
Even much…much more older chipset/motherboards will work with NVMe with mod or by default supported…

I dont see the X10DRi-T4+ on the AOC compatibility list and i dont see the WD SN770 on the NVMe test list.
AOC-SLG3-2M2 | Add-on Cards | Accessories | Products - Super Micro Computer, Inc.
M.2 List | Supermicro

EDIT: Search results for ‘X10dru-i+’ - Win-Raid Forum (level1techs.com)

I was wrong the board is the X10dru-i+ here is the link to the 3.4 firmware
this one may not have it.

in the search what am i specifically looking for on that?

what also i am noticing odd is during an install of truenas for example it can see one nvme but not the second one on that card, it will let me install as either UEFI or BIOS but will still never boot to the NVME no matter what configs in the bios i set.
I have set everything to efi and still no luck booting to that nvme.

I see the search but is there something i should be specifically look for in the search? only 5 items there.

@wesleyh @MeatWar
Since this discussion has much more to do with the in-use M.2>PCIe adapter card than with the mainboard BIOS, I have moved the related discussion into the “Interesting PC Hardware” Forum section.

Start working, all details on my posts to that users…who didnt report back…

EDIT: I said to read my posts… this bios has no CSMCORE, its inserted in Vol01.

ok i am trying the MMtool since the uefitool cannot insert for some reason but it says look for CSMCore there is no CSM core and it looks like with these the drive is in the 01-5C section but i want to confirm

There is a CSMDxe also

You only have to type the Vol. Number, which is “01” for all listed DXE drivers.

I think i got it right can you confirm it looks right?
X10DRU2.zip (5.2 MB)

will i see the build date in the bios change with this version?
also how can i confirm the system took the bios update as it did not look like it loaded the update.

Seems correct and original pad file still present in mod, report back and you can later share it, for future user guidance, on the thread:

Good luck

EDIT: Im sure that you know the risks on such mods… users always should bare their system value. Its all their decision… there no “cry” later, only headaches and more work.

it did not take the change at least trying to update from the BMC going to make a USB next.

EDIT: It works now with that same BIOS i uploaded. you cannot update using the BMC but you can using a boot USB stick and use that file. once rebooted it found the Drives right away and booted the OS that was installed to it

Glad you made it, enjoy it and good luck.