[OFFER] Acer Aspire E5-572G Modded Bios


I want to share the modded Bios I created for the Acer Aspire E5-572G notebook.
The official bios 1.09 was used as a base.
I’m offering three flavours: Microcode 01, Microcode 07 and Microcode 21.
Microcode 21 is the latest available microcode, this is the Bios you want to use unless you want the special properties of the other microcodes.
Microcode 07 is the latest microcode that allows using the full turbo clock speed on all cores (using single core turbo with all cores).
Microcode 01 is the one you should take if you want to try this. I wasn’t able to get it to work on mine (i5 4210m, HM86), but your mileage may vary.
In case you want to always use an older microcode, I’m offering a script for windows that’ll keep the OS from using a newer microcode (compatible with Windows Vista to Windows 10). Frequency and other things can be set up with ThrottleStop (use the latest version).
I’ve also included an overclocking enabled ME firmware that should (hopefully) allow overclocking on the HM87 equipped notebooks.
There are two flavours of this notebook available: Ones that use the HM87 chipset and others that use the HM86 chipset. Overclocking is only possible with HM87 as HM86 isn’t capable of overclocking (tested it myself).
Additionally I offer a collection of Bios, EC, ME and FD files of this device, in case anyone wants to experiment with these for a bit (EC Modding, etc.).
I will update this bios in case there are newer parts available.

Any feedback is welcome!

-Advanced Bios Options unlocked (Advanced, Power tabs and additional options in the existing tabs)
-Nvidia 840M/940M VBioses replaced with adapted 940MX VBios with unlocked TDP Limit, unlocked Boost Table and some OC (1306,5MHz GPU/1070MHz Memory - with general usability in mind) + all voltage sliders unlocked for editing with Maxwell II BIOS Tweaker
-Intel Management Engine: Updated to + All Locks Unlocked + Overclocking Enabled For HM87 Notebooks + PAVP (Protected Audio/Video Path) Enabled
-Flash Descriptor unlocked
-Microcode updated to version 21 (respectively downgraded to 07 and 01)
-Intel GOP Driver updated to 5.5.1033
-Intel VGA Bios updated to 1042
-Intel RST OROMs updated to
-Realtek Lan OROMs updated to 2.037/2.64
-Applied a few useful BIOS patches by CodeRush (Unlock CPU Power Management Register (useful for Hackintosh Users)/Disable BIOS Lock/Disable SMI Lock)

Flash procedure:
1. Copy the BIOS file to an empty and with FAT16/32 formatted usb stick.
2. Unplug the AC adapter.
3. Remove the battery of the notebook - you can unlock the battery on the backside.
4. Plug in the USB flash disk.
5. Press and hold <Fn> and <Esc>, and then plug in the AC adapter while still holding <Fn> and <Esc>.
6. Press the Power button. You can now stop holding <Fn> and <Esc>.
7. The BIOS flash should now begin, the fans will spin up at max speed and the power led should blink. It should take between one to two minutes.
8. After everything is done, you can reinsert the battery and go to the BIOS (F2). There you may want to change some settings (the BIOS flash erases all previously chosen settings).

Recommended Bios settings:

F12 Boot Menu —> Enabled
D2D Recovery —> Disabled

Boot Configuration: Numlock —> On
Thermal Configuration: Cpu Thermal Configuration: Bi-Directional PROCHOT# —> Disabled
Chipset Configuration: RTC Lock —> Disabled
Chipset Configuration: IFR Update —> Disabled
Chipset Configuration: BIOS Lock —> Disabled
ACPI Table/Features Control: TCO WatchDog Support —> Enabled
ACPI Table/Features Control: WatchDog ACPI Table —> Enabled
ACPI Table/Features Control: ACPI Memory Debug —> Disabled
ACPI Table/Features Control: PEP Graphics —> Disabled
Extended ICC: Use WatchDog Timer For ICC —> Enabled
Extended ICC: ICC Locks after EOP —> All Unlocked

User Access Level —> Full

Wake on LAN —> Disabled
Advanced CPU Control: xAPIC Mode —> Enabled
Advanced CPU Control: Package C-State Demotion —> Enabled
Advanced CPU Control: Package C-State Un-Demotion —> Enabled
Advanced CPU Control: ACPI 5.0 CPPC Support —> Enabled
Advanced CPU Control: ACPI 5.0 CPPC Platform SCI —> Enabled
Advanced CPU Control: Package Power Limit MSR Lock —> Disabled
Advanced CPU Control: Long Term Power Limit Override —> Enabled
Advanced CPU Control: Long Term Time Window —> 128

Module names (for replacement/update):
GOP Driver: 7755CA7B-CA8F-43C5-889B-E1F59A93D575_256.ROM
Intel RST: 382F560D-17A9-4887-BD9C-EB439C1CC482_1654.ROM and 501737AB-9D1A-4856-86D3-7F1287FA5A55_1781.ROM
Intel VGA Bios: 8DFAE5D4-B50E-4C10-96E6-F2C266CACBB6_1743.ROM
Nvidia 840M VBios: D336DBCB-33C1-4D15-A06F-C3FF405C6A68_1749.ROM
Nvidia 940M VBios: C09F4207-D557-47D0-A4B5-1E4B6459E519_1761.ROM
Realtek LAN: 0A33D14A-7B60-4C58-9194-DED0812F9B2B_1767.ROM and E8991F69-D813-4116-A2C2-61E304ECBD72_1533.ROM
Intel Microcode (integrated in file): PADDING_2702.ROM
Management Engine: Integrated in BIOS image, HEX Editor needed for replacement

-BDMaster from Bios-Mods.com for providing the way to unlock the bios
-Donovan6000 for his very helpful guides and insights on Insyde bios modding
-Andy P whose PhoenixTool I used to replace the modules
-Plutomaniac for providing the used Intel ME firmware and the Intel ME System Tools to properly configure it for this notebook
-Ultrax5 from TechInferno for providing his OC enabled ME firmware for 8-series systems which I used as a reference to unlock the feature for this notebook
-SoniX for his Intel VGA Bios update guide and the OROM, Microcode and Intel VGA Bios database he maintains
-Pacman for sharing the latest Intel RST OROMs
-CodeRush for providing the included BIOS patches
-WerePug from overclock.net for providing the way to unlock the Nvidia VBIOS voltage sliders for editing in Maxwell II BIOS Tweaker
-The author of the Maxwell II BIOS Tweaker which I used for editing the Nvidia VBioses
-All the other people who shared the used OROMs/Microcodes/Firmwares/Useful Information etc.

-13.09.16: 1.09a - Initial release
-03.10.16: 1.09b:
Unlocked a few more options that I missed before - everything that can be unlocked should be available now
Overclocking enabled ME is now included by default (no disadvantages for HM86 notebooks)
Applied a few useful BIOS patches by CodeRush (Unlock CPU Power Management Register (useful for Hackintosh Users)/Disable BIOS Lock/Disable SMI Lock)
-22.10.16: 1.09c:
Changed Nvidia GPU idle voltage from 0,94V to a more correct value of 0,76V - thanks to Maison1 for bringing this matter to my attention
Unlocked all sliders in the Nvidia VBIOSes for editing with Maxwell II BIOS Tweaker - thanks to WerePug from overclock.net for posting the way to do this

Acer Aspire E5-572G - BIOS 1.09c - Microcode 01
Acer Aspire E5-572G - BIOS 1.09c - Microcode 07
Acer Aspire E5-572G - BIOS 1.09c - Microcode 21

DeleteMicrocode Script for Windows
Acer Aspire E5-572G BIOS-ME-EC-FD Collection

Anyone tried(succeeded) to update newer InsydeH2O BIOSes (atleast CPU Microcode) ?

So actually someone made it, good work man. The link up there is my thread, asking If someone used H2OEZE tool to update a BIOS, and I guess you did it manually here. Great job again.

Anyways I have E5-573G (no removable battery, but I can unlock advanced settings with Fn + Tab key, restart and then get back into BIOS again which will have advanced settings unlocked). This way I will flash mine through Intel FPT by unlocking BIOS flash.
Can you actually try to use H2OEZE tool (link in my thread) to update all this without doing it manually, or just post a DIY manually updating BIOS tutorial. I guess the tool will work…

I’m willing to mod mine and flash it, and probably give you modded BIOSes (If you want ofc) so you can share them too!

Great job again, and thanks in advance.

Sadly H2OEZE isn’t compatible with the BIOS of this notebook, the normal file (without stripped headers) doesn’t offer me any options and the file with stripped headers (using Insyde Bios Extractor) crashes the program.
I tried this with all available BIOS files and a dumped one, but the result is the same.

However, I can write a little guide to make these changes manually tomorrow.
I can also update the microcode of your BIOS file that way.
Is there anything elso you want to have changed/updated while I’m at it?

First of all thank you for your offer of updating my BIOS. It’s unfortunate that you can’t open your BIOS with the tool… first plutomaniac encountered bug with microcode add button then this, that tool is sure buggy.

Anyways since I wan’t to preserve stock settings, I wanted to upadte only the Microcode to 24, and guess the GOP, Intel RST, Intel VBIOS and Realtek LAN OROM wont hurt too :stuck_out_tongue:

BTW, does the v15 Intel RST work well on your 8-series chipset since Fernando and others suggest that branch for 100/200 series ?

Ok, I will take a look at it later on.

The v15 Intel RST works pretty well here (subjectively not slower than the default and v14 ones - I haven’t done measurements). I’m only using a single drive though, so I can’t say anything about Raid performance.
Which Intel RST OROM do you want to have integrated?

Well since it works fine (and I don’t really bother to use RAID), the same as you used.

I compared my dumped BIOS image with the standard file just now, and it seems like we’ll need to use your BIOS dump to preserve the unique identification of your notebook.
You can send me your BIOS dump with PM, if you want.

Dump sent via PM.

EDIT : Hope I’m not late. When you updated your BIOS with the RST you included the EFI driver too or just the OROM one ?
Probably since I’m using UEFI, it should actually boot the EFI one instead.

Well if it’s too much hassle for you, I’ll just wait the tutorial and add it myself, I’m really fine with that.

I updated both the EFI driver and the legacy OROM.

Got your BIOS dump and already did some of the necessary modifications.
But while I was at it, I remembered that we can’t do it this way.
Unlike my notebook yours should have Intel Boot Guard activated.
This will keep your notebook from booting when it detects a BIOS that isn’t signed with the vendor’s key.

So, to be able to flash the BIOS later on, we’ll first need to disable Boot Guard.
To do that, we will need to mod the ME firmware.
Under Advanced: Chipset Configuration there should be the option “Me Fw Image Re-Flash” in your BIOS.
You’ll need to enable this option and do a dump of the Me Firmware with Intel FPTW afterwards (fptw -d Me_dump.bin -ME).
If this is successful, you can upload it here and I will disable Boot Guard for you.
Then you need to flash the modded Me firmware and afterwards we can finally go on to the modded BIOS.

Well it’s unfortunate, but even with that setting enabled to accept ME FW Reflashing I just can’t dump the ME firmware, the CPU still doesn’t have read attributes to that region (referring to what the FPT error was).

It would be better not do this, since probably I will come to another set of obstacles and prevent me flash the modded BIOS on the end, now I’m glad that I didn’t flash that firstly modded BIOS by me with only the CPU microcode.
Thanks for the help so far and sorry for wasting your time on this…

EDIT (Hope you see this) : Actually there is a setting called Intel Platform Trust Technology that can be disabled via Advanced chipset settings in BIOS and I wonder, is this setting related with the one you mentioned that checks BIOS FW on boot ?

That setting won’t help I think, but maybe you have the setting “PFAT” under Power: Advanced CPU Control? That’s the setting related to BootGuard.
But I have found a pretty interesting post by CodeRush in the meantime here and found out that Boot Guard enabled BIOSes have special signatures. So I compared a BootGuard enabled BIOS (Thinkpad T450s) with the one of this notebook and have found out that this BIOS hasn’t got BootGuard enabled. Sorry for the confusion I caused there.
I will look into finishing the BIOS mod for you now and send it to you when I’m finished.


Didn’t find that setting there.

As matter of fact I’ve been reading in the past that HP does RSA sign on their BIOSes, dunno if it’s related with this.

And don’t hurry take your time.

Update: BIOS 1.09b is now available!

Unlocked a few more options that I missed before - everything that can be unlocked should be available now
Overclocking enabled ME is now included by default (no disadvantages for HM86 notebooks)
Applied a few useful BIOS patches by CodeRush (Unlock CPU Power Management Register (useful for Hackintosh Users)/Disable BIOS Lock/Disable SMI Lock)

I have put the modded overclocking Nvidia 840M bios into a MSI GP60 bios. It works due to it is the same graphics card with the same memory as in your laptop.
But what I noticed was that the idle voltage of the 840M rose from 0,78V with the MSI standard 840M bios to 0,91V with the NVIDIA 840M modded bios from your laptop bios. So in idle more enery is consumed.
For a short time under usage the GPU is at boost frequency of 1306,5MHz. After a while the GPU throttles at 90°C to a GPU frequency of 996MHz at 1,00V with the memory still at 1070MHz all the time.
What have you seen on your laptop for a behavior between the standard and modded Nvidia 840M bios?
I have taken all the values from GPU-Z.

For me, the idle voltage is the same with both bioses (0,943V). Your card’s bios probably has lower voltage settings by default.
Here the card works without throttling even when using a stress test for over an hour (OCCT) as the temperature is still quite a bit away from 90°C.
As I have activated a higher boost frequency, the GPU will use a higher voltage and the cooling of your notebook simply can’t keep up.
What you can do is to change the bios settings with Maxwell II BIOS Tweaker to fit your notebook (lower idle voltage, limit boost voltage and manually test working frequencies).
Here’s a guide: http://www.overclock.net/t/1590562/attem…os-editor-guide
You can copy the voltages from your original bios. To get the best result, you’ll need to test how far you can go yourself (I recommend OCCT).

An idle voltage for the 840M GPU of 0,943V is not correct for a mobile chip, see here for comparison with a desktop chip: http://www.anandtech.com/show/8526/nvidi…x-980-review/21. Please ckeck yourself. It seems to be that in the bioses you mention something is wrong. In the Maxwell II bios tweaker for your moded bios in the tab voltage table a voltage for CLK6 of 743,8mV to 831,3mV listed. It did not have success to mod your bios to take a idle voltage in the mentioned range or the idle voltage of 0,78V I had before with MSI standard bios so I switched back.
Thanks for the support.


Could you upload the VBIOS of your gpu for me so I can have a look at it?
I might be able to change the voltages of this VBIOS to match yours.
Having lower idle voltages would be interesting for me as well.

Here are the original VBIOSes for reference: 840M + 940M from Acer Aspire E5-572G and 940MX from Lenovo T560 (base for the ModBIOS, unlike most 940MX VBIOSes this one doesn’t have a hardcoded memory frequency that can’t be changed with the Maxwell II Bios Tweaker).

The sub device id in the file can be changed from MSI to Acer with a hex editor and the CRC of the file in Maxwell II tweaker repaired. I named the file to .APK from .ROM due to only these format are allowed to be uploaded in this forum.

C5D7EAAD-B218-482C-A909-E3B8CDB00E94_1095.APK (35.5 KB)


Here’s a VBIOS with adjusted idle voltage and all the sliders in Maxwell BIOS Tweaker unlocked (device and sub device ID are adapted to your card): https://drive.google.com/file/d/0B4NHIBM…EZTX21SWms/view
I adjusted the voltages to match those of your original VBIOS, you can further adjust the idle voltage with the slider that currently shows 775mV.
As for your throttling problem under load, you will have to reduce the core frequency till the card doesn’t throttle anymore (the voltage of the according boost step will be used).
Then based on that voltage you can see how far you can overclock so that it still works properly.
After that is done (and you tested your overclock for stability), you can create a new VBIOS based on that (or tell me the values and I’ll do it).

Also, according to my tests, overclocking the memory frequency is very beneficial for this card and can give a pretty nice performance boost without the card getting noticeably hotter/drawing more power.

Thank you very much. I tested your modified bios. The idle voltage is now pretty close to the origin idle voltage of 0,78V. In GPU-Z it is between 0,8410V and 0,8370V. I will mod and test futher.