[OFFER] ASRock Gen 2-3-4 Meltdown-Spectre Fixed Efi's

The topic outdated AsRock official support team updated every Gen 3-4-6-7-8 mobo bios with latest microcode.

can you update the z97m killer bios?

It’s already been updated to the latest with version 2.10.


Thanks for your efforts!

I flashed your modded H86 Pro Bios and it works fine with the spectre microcode!

But on my second PC, a Z68 Extreme3 Gen3 Board, several things like GOP UEFI are missing from your bios file. Seems like you used version 2.30 for your update.
The newest bios version is Beta 2.31 with Windows 8/10 support. Can you please mod 2.31 too?

Z68 Series change to latest beta version efi with UEFI GOP supports

Thank you so much!

I wonder when they will update my ASUS Z97-K ??
Now still on Bios version 2902 from 2016…!

@7alvoo - I don’t suppose you could add Z68 Fatal1ty Pro Gen 3 BIOS 2.23A as well?

I think I’m the only human that owns the asrock z97 pro4. There are sparse resources available (even from asrock) for it specifically making it tough to tweak and troubleshoot. Anyway, if you find the time, I would certainly appreciate a spectre mod for its UEFI.

I’m glad you like Asrock, but personally I’m never getting the brand again. Had tons of annoying issues with it (mainly dealing with power issues, USB, documentation, support, and perhaps security).

Z97-K very good , reliable and stable MB .
Only updating BIOS seems to be a problem , my latest is from 2016 , while no defence against latest spectre and meld-down…!!

Just in case, if you run Windows 10 then you will receive updated microcode (Spectre/Meltdown) through Windows Updates hosted in Windows Update Catalog:

KBs linked in that page got updated with new microcodes, so we need to wait and check regularly.

Pete12: asus mobo efi update possible and easy but I’dont know how possible to flash teh modded bios, maybe recovery mode? I do not know the update procedure.

chinobino: added

Tom Esquire: I think this asrock z97 pro4 is a great motherboard that offers awesome options at very affordable prices official efi update already available.

mbk1969: It is possible to use the processors without using a bios microcode without the motherboard natively supporting it but it is significantly more instable and worse.

Just a quick heads up: the modded BIOS for ASRock Z68 Pro3 in the OP bricked my board. I think it’s because the new microcodes have different sizes and some offsets aren’t right after modding. I tried it before and it works fine if I only update one microcode and not both Sandy + Ivy Bridge (tested only for Sandy Bridge). No biggie though since I have a programmer and could restore everything.

Sorry for you wasted time, i’m remove the file, thank’s the feedback.

I had the same problem as Dogg with the Z68 Fatal1ty Pro Gen 3 BIOS, it got stuck on POST code 15.

I tried 3 sets of RAM before I finally pulled the Dip8 BIOS chip and reprogrammed it.

It looks like it’s the same situation as the ASRock Z68 Pro3 - you have to choose which microcode you need updated, Sandy OR Ivy.

I appreciate the time and effort you put in to mod and host the files though.

Thank’s the feedback, i’m removed the z68 series.

Pls mode z77 extreme 4 bios.

What are you talking about? I was only pointing out that updated CPU microcode can be loaded both by BIOS and by OS itself. After microcode is loaded into CPU all instability can be caused by microcode itself and not by the method of loading (BIOS or OS).

Nah. The Z68 Fatal1ty Pro Gen 3 requires a microcode offset of 0x800.
This is can be fixed easy.
Simply replace ffs (GUID 17088572-377F-44EF-8F4E-B09FFF46A070) at
Volume 01 Index 01
Volume 02:01-00 Index 03
with attached .ffs

!! NOTE: The attached microcode ffs is ‘fixed’ for offset 0x800 and only contains 2D/1F microcodes !!

Check your PM

And edit: If you guys WANT help post a link to your bios versions!

Glad i didn’t flash the Z68 Extreme3 Gen3 yet…

So i updated


first with UBU_v1_69_16 (raid etc.) and then the cpu microcode with the new UBU v1.70.a16-DEV. Changelog says: alignment in a container with microcodes at 0x800, if required.

Does that happen automatically? Are these now correct offsets?


Thx for a reply.

Edit: I attached my bios file.

mod_mod_Z68E3G32.zip (3.89 MB)