Hi everyone,
I am attaching, my bios with all the updates and a complete graphic restyling to the bios.


- White Boot Logo
- New Theme Style Carbon

- Update OROM IRST SATA with Trim Mod
- Update EFI IRST SATA with Trim Mod

- Update OROM VBIOS SNB-IVB 2171 (12/08/2014)
- Update EFI GOP YB 3.0.1030
- Update EFI GOP SB 2.0.1024

- Change/Update LAN OROM Intel Boot Agent GE 1.5.62
- Update LAN OROM Broadcom Boot Agent 20.6.0
- Update LAN EFI Broadcom UNDI: 20.6.7

- Update ASMEDIA OROM 1061 0.97

- Update Intel CPU Microcode 0306A9 YB: 1F #Spectre fix for IvyBridge
- Update Intel CPU Microcode 0206A7 SB: 2D #Spectre fix for SandyBridge

- Update Intel ME

- Add Samsung M.2 Support



Last Update:
03/08/2018 Extreme 4
03/08/2018 Extreme 6


Hi, I would like to download your file. Unfortunately I am unable to do so. Could you please help?

Could you please tell me how did you change the bios style ? Is it possible to do on Asus motherboards ?

This is just what I did to change some of images on my UEFI. Please, if you are not sure what you are doing or even you don’t know how to recover you motherboard from a bricked bios, don’t try this.
I’m not responsible for a damaged motherboard, thermonuclear war or whatever other problem you get following these instructions.

You have to locate which uefi modules have images and then, replace by your images.

I did a script to extract images, it uses UefiExtract (thanks to CodeRush), cause it create folders with GUID as name and it helps a lot the task of locate and replace the files. (thanks to lordkag, that creates the huge amount of code of my script :D)

All you have to do is put the script files on the same folder of UefiExtract and UefiFind (from UBU Tool), and drop your uefi rom over the “extractUefiImage.bat”. After some time, the extraction will be complete and you will have a new folder called “yourRomName.ext.dump” with the extracted images.

In ASRock Uefi, images normally have a header with 4 bytes, 3 of them represents the filesize and 1 is a separator (I don’t know how is the Asus header).

Example of image without the ASRock header:


We need to check the filesize to add it to the header:


But, before we calculate this on hexadecimal to put to header, we need to add 4 bytes (the header) to filesize (75989 + 4 = 75993) and them, calculate:


After we obtain the filesize converted to hexadecimal, we have to include this to the file header, but from right to left. As we obtained 128D9, we put in the header D9 28 01. The last ("19") is the separator:


After this, we need to use UefiTool (thanks to CodeRush again) to locate the GUID where is the file that we want to replace:


After locate the GUID, we need to navigate to the "path" as the path we get after extract the files. In this case is "68BA3E2A-9992-47E6-A087-1C2CC9874CA5 -> Compressed Section -> Raw Section":


Then right click in it, and select "Replace as is":


Then, select the new image with the new header and save the uefi and, flash it.

I’d love to edit the UI design of some of the firmware I’m modding, would you have any interest in tracking the right part in the firmware down for me to edit while I make all the other changes I normally do @jcorrea ? :smiley:


@jcorrea Awesome Here is a link to the latest firmware for the Biostar X370 GT7 I’m currently working on. Its default UI design sure does look dated and old, well laid out, but it looks very musty with no vibrance at all. If you need some example screens of the UEFI UI let me know.

DL Link: X370 GT7 firmware

This uefi rom worked with my script. I got the rom images. The uefi background is at guid EFCB2FDB-0662-4A59-A5D7-03033EA97CAE. The header is like as ASRock, contains 4 bytes. Try to extract that with UefiTool, looking for this GUID, and use HxD hex editor to open the extracted file. You will see this header: "CF A5 01 19", the first 3 bytes is the filesize (from right to left, 01 A5 CF, that means the file has 107983 bytes), the 4th is the separator ("19"). Remove the header and you can edit this file as you wish and, try to add the new header as I explaned on early post. Then atach the edited file here and I will see if this is correct.

Edit: forgot to mention about the filetype, as you can see after the header, there is a "type header", FF D8 FF, this means that this file is a jpg file.

@jcorrea thanks I’ll look in to that a bit later I’ve just finished all of the surface editing with the GT7 firmware. I’d like to try and fix some of the bugs the GT7 firmware has but the only bug I think us modders might be able to fix is the CPU speed being reported incorrectly by task manager when the CPU is under load.

@jcorrea I extracted the file and changed the header but i cant find a download link for UEFIextract or UEFIfind just links to what appear to be source code files. As I’m on the subject I’ll ask as it seems like you would know. I’m trying to locate memory voltage in the BIOS for my GTX980, its memory is Hynix H5GQ4H24MFR -R2C and assuming Gigabyte haven’t undervolted it should be 1.5v. I’ve searched for the Hex values and found 2 entries (3 if you count the entry I found going left to right but I’m pretty certain thats not what I’m looking for) I was wondering if at a glance you could tell me if either of the entries I’ve located in the screenshot are the right values for memory voltage. Thanks! :slight_smile:


You can find UefiFind and UefiExtract on Ubu Tool. Sorry about your 980, but I don’t even know what these values means.

@jcorrea do you have a link? I can’t seen to find Ubu Tool either. Google is failing me.

Ubu Tool:

@jcorrea uefiextract doesn’t seem to be working for me :frowning: it either closes when I drop the UEFI file on the batch window, or when I run it as admin it just sits there and does nothing until i close it manually.

EDIT: I think its working now just dropping the rom over the batch file without running it looks like its working.

Do you have python installed?


@jcorrea I don’t but it seemed to work anyway :stuck_out_tongue: I’m going to install python and extract again to make sure everything extracts properly.

Without python, the script will not to be able to extract the images from modules. You will only have all uefi modules extracted to a folder.

@jcorrea ok thanks, python is unfamiliar to me I’ve only done some worth with perl. Is this error going to cause a problem?


Yes. You will only got all uefi modules, without extract images from them. Install python and everything will be ok.

@jcorrea I have python installed (v3.6.4) when getting that error.