[OFFER] ASROCK Z77 EXTREME 4 & EXTREME 6 - CARBON THEME BIOS

@ket
Is python at yours path enviroment variable?

@jcorrea I don’t think so. I think I might have found the problem though I clicked the first python download link I saw assuming it would be x86 and x64 but looks like it might of only been for x86. Going to install the python version i just downloaded for x86 and x64.

@jcorrea I have the images extracted now I needed to do the process on one of my other systems though for some reason my main system seems to really hate python I’ll look in to that another time. The issue I’m having now is that all of the files extracted are read only and nomatter what I do the damn files will not let me edit them even with using tricks like grant admin full control.

EDIT: Hopefully that issue is solved now. I hate windows.
EDIT 2: Yes and no. Now windows is whining about the directory being too look despite overriding its 260 limit which means I still can’t edit anything. Moving the file I want to edit, editing it, then trying to move it back doesn’t even work.

@ket
You don’t need to put the file back to the path. You only need to get the GUID (on folder name) to replace the right module (the file you edited) on uefi with UefiTool.

@jcorrea Ah ok, I was thinking the structure needed to remain unchanged. I’m on my way now . Would you have any interest in helping me track down and try to fix a few things in the Gigabyte Gaming 5 and Biostar X370GT7 firmwares? It doesn’t look like Gigabyte or Biostar are ever going to fix them. In theory they shouldn’t be difficult to fix I just need someone who is more familiar with UEFIs once they have been completely taken apart. Heres the things I’d like to fix for each board;

Gigabyte Gaming 5

Locate LED presets for RGB fushion to correct preset values for orange colour
Locate and replace memory compatibility table to fix broken 2400 and 2667 memory straps (I’m assuming this would be its own module so easy to directly replace once found)


Biostar X370GT7

Locate and replace memory compatibility table
Fix wrong memory frequency shown in the UEFI when memory frequency is at 3333MHz or above
Fix Windows Task Manager grossly misreporting CPU frequency when under load (this is a specific bug to the GT7 no other X370 board I have reviewed has this problem)

@ket
Do you have a way to recover a bricked uefi if something goes wrong? Cause everything about memories and behaviors are very sensitive, and I’m almost sure that we will get brick sometimes before we get a “patched” uefi.

I do, I’m all set up my end.

EDIT: @jcorrea , I’ve finished editing all of the images for the UEFI (my god there are a lot of them for the GT7 firmware… about 100!) after editing the images I manually added the missing information using HxD and made the image a bin file which should have made the file compatible with the main firmware image (I think) so I updated one of the baked-in images and tried the firmware out. Results were so-so, it sort of worked but some things were missing that shouldn’t have and the updated image displayed some odd corruption.

After editing the jpg files what exactly needs doing to convert them for use within the main firmware image? Thanks

@ket
sorry, I did’t see the edit cause it didn’t appear on the history. After edit the jpg, you only have to add a new header and, replace that on UefiTool. On my ASRock it did work, but my board is a little bit old (a Z77 Professional), not sure how it will work with brand new motherboards. About the new image you get after edit, could you please attach the “old” and the “new” images? I will take a look on that, to try to understand what could cause the “glitches” you got.

About the fixes on Gigabyte and Biostar boards, I think we would start with Gigabyte Gaming 5, to replace the memory compatibility table. In this weekend I will take a look on that.

Forget to mention that I was “teaching” JAVA RESTFul to my wife and because of that, I was a little bit away from the forum.

@jcorrea No problem :slight_smile: Attached is a small archive of one of the new UI parts for the GT7 along with the original UI part. For reference the Gigabyte memory compatibility table once found I’m thinking would be best replaced with the memory compatibility table from the Asus ROG STRIXX X370-F. I’ve reviewed and tested 5 different X370 boards now and the X370-F seems to have the best compatibility with Samsung B-Die memory which is what most people are using on the Zen platform. Fixing the broken 2400 and 2667 dividers is going to be an added bonus. No idea why Gigabyte haven’t fixed that it is ridiculous that they haven’t.

Download link: Clicky

New release!
Also available for Asrock Z77 Extreme 6 :slight_smile:

Complete Changelog:

- White Boot Logo
- New Theme Style Carbon

- Update OROM IRST SATA 13.1.0.2126 with Trim Mod
- Update EFI IRST SATA 13.1.0.2126 with Trim Mod

- Update OROM VBIOS SNB-IVB 2171 (12/08/2014)
- Update EFI GOP YB 3.0.1030
- Update EFI GOP SB 2.0.1024

- Change/Update LAN OROM Intel Boot Agent GE 1.5.62
- Update LAN OROM Broadcom Boot Agent 20.6.0
- Update LAN EFI Broadcom UNDI: 20.6.7

- Update ASMEDIA OROM 1061 0.97

- Update Intel CPU Microcode 0306A9 YB: 1C
- Update Intel CPU Microcode 0206A7 SB: 29

- Update Intel ME 8.1.70.1590

- Add Samsung M.2 Support



DOWNLOAD

Z77 EXTREME 4
Z77 EXTREME 6

@jcorrea have you had a chance to look at the Gigabyte firmware?

New Update

CHANGELOG:

- Update Intel CPU Microcode 0306A9 YB: 1F #Spectre fix for IvyBridge
- Update Intel CPU Microcode 0206A7 SB: 2D #Spectre fix for SandyBridge



DOWNLOAD:

ASROCK Z77 EXTREME 4
ASROCK Z77 EXTREME 6



Friend, this update from yesterday has fix for Meltdown and Specter for Ivy Bridge?
I thought I was still going to leave the Intel table from Microcode for Ivy Bridge and Sandy Bridge.
I thought it was still in Beta phase the Second and Third Generation Intel

Yes, with the latest microcode for both Ivy and Sandy, Specter and Meltdow are fixed.

Some screens:



Even if there is no performance optimization, there is no real loss in performance either in the benchmark or in gaming :slight_smile:

Hi, Ubro92.

Could you please build and share modded bios without Theme/Spectre/Meltdow?

Thanks in advance



Hello, removing those changes, there are not many advantages, in that case use UBU tool to update only the modules that interest you, or you can download the bios of Labview :slight_smile:

Labview Bios: http://www.mdclab.it/intel-socket-1155.html
UbuTool: [Tool Guide+News] “UEFI BIOS Updater” (UBU)

ubro92, thank you very much for your hard work on this BIOS mod!

I am currently having some BIOS corruption issues on my Asrock Z77 Extreme4 that I believe stem from repeated hard reboots due to RAM (GSkill 2400Mhz) and PCI-E Wifi card (Archer T9) incompatibilities. I have been running with the latest 2.90 (not the beta 2.90P) BIOS, and have already flashed the Winbound BIOS EEPROM chip with my CH341A EEPROM programmer to repair the corruption. I am still seeing boot issues, and was hoping that your updated BIOS will potentially resolve some of these issues that are resulting in “A2” Q-code errors. Even if it doesn’t help, at least the modules will be up to date!

Question: Is your BIOS using the latest version of the modules as of today? I notice that you have some newer versions of the modules in your BIOS than http://www.mdclab.it/intel-socket-1155-z77-extreme-4.html, but was curious if yours actually contains all the updates and more? Are there newer modules since your latest changelog post?

Thank you!!!

@Ubro92

I have an Extreme9 z77 series, does your BIOS mod also update so that we can use the mini pci-e for an msata ssd? As of now it can only be used for wifi and bt however, I read on another forum someone mentioned they modded their extreme6 z77 to use it to read an ssd, however, didn’t reference how, only left their BIOS with a broken link.

Also, how did you get M.2 Sata to work when there is no slot? These changes are very exciting btw, great work man.

Hi, I’m sorry if I answer only now, then my bios has all the updated modules to the latest releases, those of Lab instead are less updated.

The problems of corruption are certainly due to the various flashes, theoretically the problems should disappear completely using a programmer and reprogramming the bios-chip and in case of damage replace it.

Also that cpu mounts? Ivy bridge and sandy bridge differ for the memory controller, the sandy bridges support a maximum of 1.575v, higher voltages can damage the DDR3 controller integrated into the cpu.

Unlike with ivy bridge, you can install 1.65v DDR3 modules without problems.

EDIT: With the last Labview update of 04/01/2018 all the modules are updated like my bios so the difference is reduced to the theme only and to the M.2 module :slight_smile:



Hi, the integrated M.2 module guarantees compatibility in case of SSD M.2 installed via pci-e or Sata adapters to be detected at boot in case of OS installation on these.

For SSD msata, theoretically should work if connected by pcie with adapter unfortunately I have no way to do tests so I can not tell you more :frowning:

@Ubro92

Thanks for such a fast reply. When I said msata I specifically meant via "mini pci-e onboard" not via pci-e insert slot. I tried by "mini pci-e" where normally the bluetooth/wifi module goes, and from stock BIOS it does not work. There would be a possibility of approximately 100mb/s gain on msata module vs SATA 6Gbps channel from my testing and the technology limits. Not a huge boost but would be nice if for free had only BIOS supported it.

Currently my BIOS has slic2.0 for OEM Win7 activation, does your modded BIOS have this as well?

Thank you anyway though. :slight_smile: