[OFFER] Asus Crosshair V Formula 1703 mod BIOS

Yes windows boots fine and in the boot order all the devices is listed perfectly no problems there the only places where it does not show correctly is in the sata config page where with the original bios it used to show the drives in the list now its just showing there is none. Thats the only part i have found so far not working


And if you check here its fine


Boots correctly no problems at all


I had the time to look into it this weekend and i have the same SATA drives missing in the list on my PC. I suspect that drives are not reported there because they are managed by the new AMD AHCI ROM v3.3.2.0 for DEV_4391 that is faster and was missing in the original Bios. As free time permits, i may try to see later if i can find a way to correct that. But for now, the module is working as expected because they are all in the boot order, AHCI settings are also working and everything else is fine. Enough so that i didn’t realised this myself before your comment that they were missing there. Thank you for the good catch of this little bug.

Awesome :slightly_smiling_face:yea everything else works 100% have yet to find a problem

have this been fixed in the bios yet? :slight_smile:


No, i didn’t had time to look at it yet.


Hi Phoenix48,

I believe we are working on similar problems just on different sockets. My mod is somewhat working now, may I trouble you for some of your wisdom regarding my problem?

My thread is here > [Request] A8-7680 UEFI Microcode Update for HP Pavilion 23-P149 (2)


I can give at least one good advice: Don’t try to update the AGESA. This will only cause you, at best, new bugs and weird things happening and, at worst, it can also brick your PC. You can update anything else, but don’t change the AGESA.


Hey, I’ve been kicking around updating my BIOS with your wizardry from here for a while now. I tried reading back through a bit and think I follow about the two chipset versions and whatnot, but there’s a lot going on to some of us (me…) that this is kinda new to. Is the state of things pretty good as far as me dropping this on my board? I feel like it’s reported pretty stable and good, but I’m not in a position to replace anything, even though this would give the perfect reason to finally upgrade after, what… 10 years? lol


Yes, you will have no problem upgrading your Bios. You should use the stable v17.

Upgrading the USB chips firmware is optional and don’t require the update of the Bios. But for the USB chips, you should follow all the instructions in the spoiler in the first post very carefully because upgrading with the wrong firmware can brick your USB 3.0.

Hello dear Phoenix48! Please make mod 17 of this bios but without Meltdown and Specter patches

So, I installed the v17 Bios and I am not able to boot from my NVMe drive. Using a Samsung 980 EVO and PCIe 4x adapter in the bottom slot. Current configuration is MSI MECH 5700XT (x16, TOP SLOT), ADAPTEC 71606 (3rd x16 slot, x8 electrically) and Samsung 980 EVO 1TB NVMe in bottom slot (x16 slot, x4 electrically). I am able to see the NVMe in Windows (1.6 GB/s) and I tried cloning my boot SSD (SATA EVO 850) to the NVMe with the NVMe being GPT first and then MBR second. Neither will work. All I see in the bios for boot order is PATA and Adaptec ASR-71605. The EVO 850 gets roughly 484 MB/s both testing using Samsung Magician. All four ram slots are populated btw for a total of 32gb and CPU is an 8350.

The system must be installed in UEFI mode, no clone advisable, a clean OS install is the best option.
Unplug all other drives and the ASR, read the guide and the section “4 - Installation of the OS onto the NVMe SSD” concerning the OS installation:


My personal PC is a Crosshair V Formula Z flashed with 2201 BIOS including latest Microcode/OpROM updates.

I clone 2 or 3 systems a week on average & unless there’s something special about booting from NVMe drives either GPT or MBR should work fine. I prefer MBR myself.

Which imaging software did you use to clone the drive? I use Macrium Reflect.

I would first try the SSD in the adaptec slot to see if it’s at least recognized, that would be a start.
Also, enable CSM under BIOS boot menu options, enable UEFI & Legacy as well as “boot from PCI devices”. option.

See how you go.

Cloning is quite OK.

The 850 Evo is SATA not NVMe, so you won’t gain anything from installing it in a PCI-e slot.
My 860 Evo tops out at ~500MBps.

Thanks for the info MW. I did a fresh install of Windows 10 on the Samsung 980 EVO NVME and it booted fine. I had all my other drives disconnected just to be safe. Kudos for this firmare update! Now I just have the pain of reinstalling software… :slight_smile:

Just as a side note, when I went to install the AMD SATA RAID/NVME driver, I received a error that installing the SATA RAID driver would disable boot capabilities from the NVME. So that is may be why the clone did not work.

Samsung Magician Stats:
980 EVO => NVME => PCI-E 2.0 x4 => 1.6 GB/s
950 EVO => SATA 6G => ADAPTEC 71605 SAS => PCI-E 2.0 x8 => 484 MB/s

Typo… fixed. :smiley:

Thats a lot of cloning for my taste… im not fund of it but done plenty back in the time of the old Norton Ghost in dos. Data drives, an emergency clone…sure, but not my choice for a PURE UEFI system, not talking about the “windows garbage” left behind on an old OS against the new performance.
Not for my systems neither losing time in system clients… thank you for your contribution to this user situation, cheers.

EDIT: Im not here to suggest anything my friend…i just gave my opinion about a clean NVMe OS install vs an cloned old OS related the performance vs garbage.
If you are responsible for customer data drives you should do it as it fits you better.

Thats it my friend your on peak performance on old PCIe 2.0 x4, on this systems on PCIe 3.0, when possible, can give you a tiny boost, congrats.

So if cloning the drive isn’t an option how would suggest migrating data from one PC to another three times a week? Reinstall?

Not likely.