[OFFER] ASUS GRYPHON Z87 BIOS v2103 (updated+NVMe support)

Do any body help me to update Asus GRYPHON Z87 bios v2103 to all latest modules, latest cpu microcode and nvme module

Here is a link of last updated bios file link
Asus GRYPHON Z87 Last Updated Bios

EDIT by Fernando: Thread title shortened and customized

I manage to find something friend? I’m the same as you looking for the same version. Thank you

I have searched many place for updated bios for my mother board Asus Gryphon Z87 but I can’t find it. I also requested in this form to pro member to mod this bios for me but no one reply so finally I decided to do it myself. I have read many form article regarding bios mod then finally I have done this.

I have post my modded bios file to this form so that will helpful to others also.

Download the file and flash it through USB Pendrive

Module Update Details

ROM/EFI IRS RAID for SATA → v13.2.2.2224
ROM/EFI VBIOS v5.0.1036 → v5.5.1034
CPU microcode 0306C 19 → 27
NVMe support added by using module NvmExpressDxe_4.ffs


Enjoy with your new NVMe capable modded bios

Asus-Gryphon-Z87-Module-Before-After.jpg



Asus-Gryphon-Z87-CPU_Microcode-Before-After.jpg

Z87GP.rar (4.7 MB)

@LocalCrack :
Welcome to the Win-RAID Forum!

I am sorry, that you didn’t get any reply to your BIOS modding request, but you should consider, that we haven’t written all the guides about how to modify a BIOS with the intention to do it finally ourselves.
Fortunately you were able to do it yourself without any additional help - congratulations!
Since there is no need anymore for a request and since you have attached the working modded BIOS, I have moved this thread into the matching Sub-Forum. This enhances the chances, that interested users with a similar mainboard will find your modded BIOS.

Regards
Dieter (alias Fernando)

thx, it worked fine on my Gryphon, copied my sata OS disk to the nvme and it booted directly.
for some reason bios flashback worked with an usb3 ntfs usb drive and not on a fat32 usb2…
thx again !

Hi ,

I tried to use this mod-bios , but I receiving information "bios security verification failed" .
Could you help me with this?
Regards

@Bonxi - For mod BIOS Asus you need to use USB Flashback, or other method if board does not have flashback, but this one does so use USB Flashback

Smaller USB did the work with FLASHBACK, thank you.
Still I can’t see nvme disk . Any ideas ?

Thank you

@bonxi - Great you got it flashed!
See here, point #4 in the “This is what you should do” section, do all steps exactly - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS
Make sure NVME is RAW with no initialization or partitions etc first, or make sure it’s initialized as GPT (better to give it RAW though IMO)

You’re a genius! Thank you very much for the mod BIOS! Now, with the proximity of Win11, could you re-mod the mod to include TPM 2.0 support?

I own a Gryphon Z87 motherboard and I successfuly managed to buy and downgrade -to v1.2- a TPM module from Supermicro.
Had to do this because ASUS no longer commercialize the following:

[ URL to ASUS TPM-L-R2-0 module ]

Luckily, the AOM-9665V-C works like a charm, but the latest Gryphon’s BIOS update doesn’t support TPM 2.0 (required by Windows 11).

If you upload a new mod BIOS with this TPM 2.0 support I’ll just upgrade my TPM module to v2.0.

Can you please at least reply to me? Or tell me how can I modify your mod? Thanks in advance.

Mario.

Just signed up so that I could say thank you for posting the bios you made. Just used it on my ‘new to me’ Z87 board I bought yesterday.

Enjoy!

I finally got my Samsung 970 NVMe drive with a PCIe adapter. I updated the bios with the bios in this thread. I disabled the onboard SATA. I put the card in, booted my Win10 install USB drive, and tried to do a clean install to the NVMe drive.
Windows 10 saw the drive, it let me delete the partition on it, but told me it wouldn’t install to it because my bios may not boot from that drive. I have to assume that I messed something up, but I am at a total loss as to what. Can anyone give me a tip on getting my fast new drive to be bootable from win10 please?

Please check

[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

=> This is what you should do => 4. Installation of the OS onto the NVMe SSD

If you did everything as described and still get a message, dump your current bios/firmware and check if you properly flashed the bios.

No idea why, but when I moved the drive to the bottom pcie slot, it started working as expected. shrug