[OFFER] ASUS MAXIMUS V FORMULA BIOS 1903 modded for NVMe boot drive and EFI updates


See post #5 of this thread…you have to use the FLASHBACK PROCEDURE found in your manual.


No problem here, try updating your "winrar" software to the latest version…v5.91


Hi @hancor pls help,
I have succeeded flash bios my flash bios was successful, but I encountered a problem with installing windows
[[File:WhatsApp Image 2021-01-25 at 2.02.32 AM(1).jpeg|none|auto]]

settings in my bios

WhatsApp Image 2021-01-25 at 2.02.32 AM.jpeg

the NVME I use

WhatsApp Image 2021-01-25 at 2.03.14 AM.jpeg


WhatsApp Image 2021-01-25 at 2.02.32 AM(1).jpeg


In your BIOS/UEFI make sure to set CSM (Compatibility Support Module) = DISABLED.

You should be able to see the drive then.

Also unhook all other drives when doing the first install.

Okay rechecked the file and re-did the NVMe module using MMTool

Uploaded BIOS/UEFI to first post Latest edit to Jan 24, 2021. Download and give that a whirl…

Further to this, check for the correct NVMe driver suitable for your NVMe SSD brand. ie check manufacturers website…

ADATA drivers.png

I just did an upgrade to my "ancient" Z87-Deluxe mobo and used the Samsung 970 EVO Plus 2TB drive without a hitch. Read ~3300MB/s and write ~2800MB/s.



I have re-flashing the bios with the latest file that you shared.
and CSM (Compatibility Support Module) has been set as disabled.
[[File:WhatsApp Image 2021-01-25 at 10.01.16 AM(1).jpeg|none|auto]]

WhatsApp Image 2021-01-25 at 10.01.16 AM.jpeg

the result is still the same, with the previous problem
please help, for this


WhatsApp Image 2021-01-25 at 10.01.16 AM(1).jpeg

First of all…u picked a NOT too good adapter…by the way…is the XPG a PCIe NVMe or a SATA M.2 drive?
Is that a PCIe adapter with shared ACHI SATA slot and a PCIe one? Does it uses the PCIe bus or SATA bus from that port? Or only that port for the SATA slot?
Sorry for the questions…but it has to be made, this mod in this board is very easy and very reliable…my point is, is there another issue here…

EDIT: Ok seems that after all its a fair dual-solution adaptor and indeed a XPG NVMe disk. As Hancor told u before, disconnect all drives, plug the nvme, ignore disk in bios and install OS USB GPT RUFUS Win10 iso.
CSM to disable and secure boot to Other OS, ignore disk presence in bios, if it fails lets try PCIe x16 Slot 1 and/or PCIe x16 Slot 3, just to check behavior.


The pci card adapter that I use is the ORICO PDM2 brand.

WhatsApp Image 2021-01-25 at 10.49.50 AM.jpeg

NVME used is adata xpg 8200 pro 1tb


please find a solution


Your PCIe adapter uses the B type key for SATA, and M type key for the NVMe type drives.

Ensure your drive is in the correct M type key slot; otherwise no joy. Power up and see if the adapter LED lights up…if not change slots on the adapter to the bottom red PCIE slot as mentioned below.

Manufacturers spec sheet says your adapter is validated for Samsung drives, etc.
I don’t know if the XPG is on that list, but not mentioned on the page I visited.

From your mobo site:


Fast Boot = Disabled


Boot from PCIe/PCI Expansion Devices [Legacy OpROM first] (default) should be set = [UEFI driver first]

Lastly move your adapter to the third red PCIe slot from the CPU ie PCIE_X4/X1_3 slot as per your manual.

EDIT: as Meatwar mentioned you need the UEFI/GPT version of Windows 10 for this to work ie install OS USB GPT RUFUS Win10 iso

Good luck!

Thank you very much @hancor , everything worked out well

WhatsApp Image 2021-01-25 at 3.18.29 PM.jpeg



Delighted that worked out for you. Sometimes you just need to follow the DESTRUCTIONS carefully!

Just signed up to thank hancor and others for the effort to make this modded firmware available.
In my case, I put the nvme adapter (cheap 6 USD from Amazon) in PCI-E slot number 2 as it is faster than PCI-E slot 3. I did set slot 2 manually to gen-3.
I also did not need to disable CSM, once Windows was installed in UEFI mode, it was detected straight away in the uefi and could be used as an efi boot drive.

I’m actually pretty happy with the result, got 2186MB/s read and 858MB/s write on my Timetec 960GB nvme drive (74 USD Amazon).
For a nearly eight years old system it’s an awesome upgrade that doesn’t break the bank.

Cheers all, keep up the good work.

Hi there

Just a few questions:

When I plug my pci express adapter into 3rd red PCi express 2.0 4x/1x I just get around 420mb/s because always use 2.0 1x, however if I use the second 8x/8x I get around 2800mb/s read but my GPU runs at 8x and I lost some performance in game.
I saw there is another PCI express 2.0 4X (black) above the first PCI express x16 however my Noctua D14 cover that PCI, any idea about what speed can get in this PCI? any fix?

Regards & Thanks.


U have options in bios settings to change slots bandwidth (Black to x4) but with some drawbacks, its all in the motherboard manual, get to it.
I would never get that monstrosity of D14… sacrificing the PCIe 3.0 slot…

Thanks I will check this : )

Did you ever get help for this? I keep getting the same error message, "Security Verification Failed."

Please advise how to overcome the "Security Verification Failed" prompt that prevents me from updating with these new BIOS. Thanks!

Cant u read??? Posts and guidance…ring a bell?
Of course u get that error, its a mod bios file, its for using the ASUS Bios Flash back function, NOT on Windows/EZ or any other method.

Good I have an asus maximus v formula card and the 1903 BIOS and I need the modified BIOS to be able to install a ssd pcie nvme if someone can help me

@Kurgulese @herediaa79
This is the thread, where you can get the already modified BIOS, but if you don’t know how to get a modded BIOS properly flashed, you should better read the start post of >this< thread.

last official RTS for Z77 is 12.9 or the beta of 13.1 sure that with the 14.x everything works at all? With Z77 you can not install any 14.X drivers, there it brings you probably nothing if you use old drivers and a new ROM/EFi in the bios has