[OFFER] Asus P8B75-M BIOS v1701 NVMe, EFI_ROM microcode update

@Koekieezz I inserted the NVMe drivers into the BIOS with this guide: HowTo-Get-full-NVMe-support-for-all-Systems-with-an-AMI-UEFI-BIOS

and then tried to flash it with EZ Flash. The message "Security verification failed" came up.

Attached is a rar-archive with the original BIOS and the modded BIOS and a photo of the error message.

P8B75-M-LX-ASUS-1403.rar (5.99 MB)



This is the normal message all users get, when threy try to flash a modded capsuled ASUS mainboard BIOS by using the EZ tool.
The warning doesn’t mean, that you have done a mistake while doing the BIOS modification. So there is no reason to check the BIOS itself. You have to change the BIOS flashing tool/procedure!
>Here< is the guide how to flash a modded ASUS AMI UEFI BIOS.

Thank you very much! Flash of the modded BIOS with AFUWIN was successful.
Windows 10 was easy to install on the WD Blue SN570 SSD. (Fast Boot disabled, Secure Boot on other OS, CSM disabled)
But booting doesn’t work. Where is the mistake?

Attached is a rar-archive with the original BIOS and the modded BIOS and some photos.

modded BIOS - MM Tool.jpg

BIOS - MM Tool

BIOS Settings 1.jpg

BIOS Settings 1

BIOS Settings 2.jpg

BIOS Settings 2

BIOS Settings 3.jpg

BIOS Settings 3



no Boot Device.jpg

no Boot Device

P8B75-M-LX-ASUS-1403-org+mod.rar (5.98 MB)

You obviously didn’t remove/unplug all other HDDs/SSDs before starting the OS installation. Result: The boot sector is outside of the NVMe SSD.
Please compare your procedure with the text of >this< guide (point 4 of the “This is what you should do:” chapter).

No, only the SSD was connected during installation.


I did it as exactly as in >this< guide (point 4 of the "This is what you should do:" chapter)

Do I need to add additional drivers in the BIOS?


During the OS installation the computer reboots several times. How were you able to get Win10 installed, although it is not bootable according to your report?

Why do you ask me? I have neither offered within this thread a modded BIOS nor checked it.

He gets to this point.



Then it tries to restart and then the error message comes up.

The UEFI system environment REQUIRES UEFI compatible hardware, besides that the motherboard reports it as you can see in your capture screen.
So even with the bios settings configured, the boot process of the OS setup continues as intended, but in legacy mode.
Your external GPU card is not UEFI compatible.

can you make a video on this i have a p8b75m mother board

A video of what? You have the bios mod in the 1rst post.

did you get a soulution ?

i downloaded the p8b75.rar in that fisrt post but in bios tell me not good or dsomething ? thanks you any help.

Here’s a thought, how about using the tip in the first post which indicates the methodology at page 2-5 of your motherboard manual. RTFM… :blush: :slight_smile:

You will need to make a FREE DOS boot USB drive and then flash from within the DOS prompt!

Just google how to make a “FREE DOS boot drive” which is pretty much self explanatory…

Follow the instructions to the letter and you will stay out of trouble.


i will try thanks

am here too
i can install it but there is no boot device

did you get ever get motherboard to boot from nv nvme. thanks

did you get ever get motherboard to boot from nv nvme. thanks

I did try to do it like you said dos but the . At the FreeDOS prompt, type bupdater /pc /g and press . will not work . i did read the RTFM i like your french . lol but this video did update it i used the mod bios in the top … but still not showing up good day sir .

Flash any / most Asus motherboard Bios in DOS with USB tutorial - Intel & AMD roll back - YouTube

What was the point of the mod, if we cant boot from NVMe… off course it boots
Read point 4 of the guide: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS


Well delighted you are actually making progress…

So the BIOS actually flashes…well what a step forward!

Now you need to reboot, load setup defaults, and then CONFIGURE FOR NVMe DRIVES, then reboot again before you attempt to install the OS. See MEATWAR link…