[OFFER] Asus P8P67 Pro Rev 3.1 BIOS 3602 with fixed GOP support + many tweaks

After about 10 years, that motherboard still runs fairly well and has many things that can be improved.

Here is a custom BIOS with many fixes :

- Enabled all advanced settings (be careful with what you do, some might damage your hardware)
- Fixed GOP support (read below for details)
- Fixed HDA for macOS compatibility
- Unlocked MSR for macOS compatibility
- Made room for bigger logo and updated with a nice one (1080p)
- Lowered minimum fan speed limit
- Management Engine updated to
- OPROMs updated to :
Intel RST for SATA -
Intel Boot Agent GE - 1.5.62
Marvell 88SE9120 -
Marvell 88SE9172 -
Marvell 88SE917A -
Marvell 88SE91A0 -
JMicron JMB36x - 1.08.01

About GOP support :
As far as I could figure, GOP didn’t work because of a stupid bug : the CSM is loaded even when EFI rom is selected, thus loading two drivers that conflict.
Thank ASUS, this is probably the “persistent perfection” they talk about in their boot logo
After replacing CSMVideo with HermitCSM (thanks to Hermit Crab Labs for the driver), the CSM module still gets loaded but at least it doesn’t prevent GOP from working.
To enable GOP you just need to set “PCI ROM Priority” to “EFI compatible” in “Boot” pane.
It is highly recommended that you disable OPROMs as they seem to interfere with logo display either by making it not appear or appear corrupt.
This was tested with dual graphics with RX560 and RX580 (3 displays).
This fix can probably be applied to all other P67 family boards from ASUS that suffer the same bug and also many other boards with different chipsets but same generation (like Z68).

About “Above 4G decoding” :
You must pay special attention to the status of \ Advanced \ PCI Subsystem Settings \ Above 4G decoding, whether you use legacy or GOP display init.
- Above 4G decoding must be disabled when running display in legacy mode
- Above 4G decoding must be enabled when running display in GOP mode
Other combinations will result in getting video signal with black screen and no POST.
Those results were obtained using RX580 on PCIEX16_1 and RX560 PCIEX16_2, your mileage may vary depending on your configuration, in case of problem use the reset CMOS jumper to get back to bootable state.

Known issues :
- Logo/POST appear on secondary PEG with multiple graphic cards but setup interface and boot selection menu appear on the primary, there’s an option to choose the primary PEG port but it doesn’t seem to work, so I’ve let it hidden.
If you mind having displays switching, as workaround, you can make everything display on secondary by enabling any opROM in “On board devices” menu and setting “Option ROM Messages” to “force BIOS” in “Boot” menu. OS boot display will also be secondary.
- Mouse does not work in advanced BIOS display mode with multiple graphic cards, but is OK in easy mode, and subtools like EZ flash. If you launch one tool and go back to main menu, mouse then works in advanced mode. Mouse sometimes work if you set display configuration as described in issue above.
- No logo during windows boot. This is because BGRT ACPI table still has display bit status set to 0. I suspect this is because something does switch display mode during POST which in turns disables this bit. However the logo is present in memory and the BGRT table is valid, a workaround to force logo display like using Opencore or configuring Windows’ boot loader can get it displayed.

About the many new options :
You’ll see there are tons of options. So far, the options I tried run fairly well and do work, but I’m far from having tested them all, if you notice something that doesn’t work, or is irrelevant for this mobo, please report.
Some irrelevant settings were left disabled (not working or intended to absent devices like integrated GPU or battery…)

Other notes :
- Due to limited space, it was not possible to have HD logo and NVME at same time. Two versions are proposed :
P8P67Pro3602HQlogo without NVME and with high quality logo
P8P67Pro3602nvme with NVME and default logo

Some screenshots (there might be little differences here and there, not all are up to date)











Custom logo reduced.jpg

Changelog :
version 1.0 : 1st version
version 1.1 : disabled entries for absent hardware or not working
version 1.2 : disabled more useless entries, added NVME and made 2 versions to chose between HQ logo or NVME


P8P67Pro3602HQlogo.zip (3.34 MB)

P8P67Pro3602nvme.zip (3.27 MB)

Hello Krazubu,

Glad to still see some activity on those boards in 2021. It was a damn fine generation of motherboards. Still using a P8P67 Deluxe and i7-2700K.

Speaking of it, I was wondering if this BIOS would work with my mobo. I already have a 3602 modded BIOS for NVMe, which works, but it looks like I can’t boot with very recent GPU like nVidia RTX GPU. I am thinking it may be related to the GOP support?

Anyhow, let me know if you think it might work.


Yes beside its buggy BIOS this is nice hardware, I still use it daily and I’m not about to change.
I think deluxe and pro are identical beside some superficial differences that don’t relate to BIOS.
About recent cards, the possible lack of legacy ROM may explain why they don’t work, so this BIOS might be the solution.
By the way, the onboard error display should give you some code that would help to diagnose.
Keep in mind that this is experimental stuff. I’ve been using it for the past weeks and it’s really stable as long as I don’t mess with above 4G decoding option, otherwise it gets bricked and I have to reflash using hardware flasher.
I have since made several better tuned versions that I’ll post when I have some time, but it still has this problem, it might be because of my graphics cards but I can’t guarantee
Testing is welcome but I highly discourage it if you don’t have a cheap SPI programmer to 1st make a real (full) backup, then restore in case of bricking.
Add NVME module is totally doable, though my logo ate the few remaining space, so it would probably require reverting to some low quality one or replacing something else.

Thanks for the reply, feel free to share your updated version.

I’m a newbie, I usually flash modded bioses that people have already tested a bit, I’m not well equipped to do hardware repairs in case of bricking.

As for NVMe, I think it’s worth it compared to higher res logos, but it’s my personal opinion.

Anyways a big thank you for your continued efforts.

Sure, I just don’t have any NVME drive so didn’t feel the need.
I made big updates to the 1st post, better explaining, and added a NVME version.

@Krazubu Hi! Could it be possible to do a similar BIOS for the Asus P8P67 1.02? :slight_smile:

@d33ns I could buy a RTX 2060 at a very good price, but now, after reading your post, I’m a little hesitant. Did you manage to boot with your motherboard and a RTX?

Hi, I can have a look but you have to tell me the exact model, it seems a bare P8P67 in rev 1.02 doesn’t exist.
I’ll only bother with GOP enabling considering the risks of making a “full featured” BIOS without a possibility to test before.

You are right, it almost seems they wanted to erase this board from history!

I mean this one:

(I could use the M2 support too, you know… )

By the way, I’m using now the BIOS published in this page ([OFFER] 21 Modified BIOS for all Asus motherboards with Z68 and P67 (NVME, updated microcodes), number 7) and it’s working perfectly.

I’ll check it out

I wanted to ask you the question if my motherboard P8P67 DELUXE Rev 1.xx would be compatible with your version?
because I bought a samsung nvme m2 disk with a pcie extension card that I would like to boot my win 10
with my current bios version which dates from 2012 this and impossible and no more bios update: /
Thank you Best regards

Hi, as far as I’m aware, all P8P67 series share the same BIOS, only some options are hidden or not here and there depending on the built-in devices, also, the deluxe version is 100% identical to the Pro one except the built in debug display which is still supported by BIOS when it is absent. So this one should be compatible, however I still recommend you get a 5$ USB flasher so you can make a real complete backup of your BIOS before, and recovery after in case something goes wrong.

I have a P8P67 Rev 3.1 (without Pro) main board.
Can you explaine how you have inserted the GOP support in the BIOS please?
Especially I would like to know how you have replaceed the CSMVideo with HermitCSM.
I want to the same with my BIOS.
Many thanks in advance for your explainations.

Hi dear, can you make same with ASUS P8P67 Deluxe rev 1.xx BIOS Rom file please??? Rev1.xx and 3 have different PCB realization and not compatible best regards…
p.s i am attach the BIOS rom 3602 with HDA patch for OSX bellow… please help, best regards

MacHDAfix-P8P67-DELUXE-ASUS-3602.zip (3.06 MB)

There’s a tutorial here :
[Guide] How to extract/insert/replace EFI BIOS modules by using the UEFITool

Hi dear, can you make same with ASUS P8P67 Deluxe rev 1.xx BIOS Rom file please??? Rev1.xx and 3 have different PCB realization and not compatible best regards…
p.s i am attach the BIOS rom 3602 with HDA patch for OSX bellow… please help, best regards

Afaik, only USB 3 chip is different and P67 chip revision does not imply BIOS difference so rev 3.0 BIOS should still be compatible with rev 1.0
Anyway, here is a minimal patch that should fix GOP support (UNTESTED).
Be careful with "above 4G memory" setting as explained in 1st post.

MacSND-P8P67-DELUXE-ASUS-3602-GOPfix.ROM.zip (3.06 MB)

I am flash this rom, and it’s not working) and can’t to reflash bios because Asus CrashFree same not booted. After pci-e init, postcodes are constantly repeated F3,F9, it seems that the BIOS can’t initialize something… i am restore backup bios via usb spi programmer…

Sorry to read that, could be the memory issue I’m referring to in 1st post. Have you tried to do a clear cmos with the jumper ?

sure, but it not helped…

Well, it’s no big deal to flash original back if you have a spi programmer.
Could you try the rev 3 BIOS just to see how it behaves ?
I can try patching again after, I may have screwed something up, it’s been a while that I didn’t mess with this since my post.

ok, i am try rev3 later, and let you know about results