Here is the modded bios v4802 for the Asus P9X79 WS motherboards. I also have the WS/IPMI in another post. These have both been verified and boot from Kingston KC1000 480GB NVMe and a WD Black 512GB NVME. I used the method of flashing from the AI Suite within Windows, way easier for me since there was no information regarding naming my CAP file for flashback on these boards. See Fernando’s post about flashing modded bios and look for Asus “Without USB flashback” and you will see what i am talking about. My thanks to Fernando for his assistance with earlier modding.

P9X79-WS-ASUS-4802.rar (4.37 MB)

You have entered the wrong data with a picture in Chinese, maybe it’s a virus, if you do not know better, the bios is defective in editing, maybe intentionally

@robinunicul - please give more info on what you are describing, show some image of the issue etc, thanks. If this is a badly modified BIOS, or some random issue with the mod BIOS we need to either describe/show the exact issue here so others are aware, contact the poster and have him fix, or possibly remove the BIOS.

i am still using the pc with this fix applied with no issues so i am not sure what you are referring to?

Thanks @RichC - I too could not understand what he meant, hopefully @robinunicul will reply with more info about what he’s trying to describe.

9A4713…File…DXE driv…NvmExpressDxe_3…china image

The good DXE driv…NvmExpressDxe_4…and no image

File GUID: 5BE3BDF4-53CF-46A3-A6A9-73C34A6E5EE3
Type: 07h
Attributes: 40h
Full size: 5160h (20832)
Header size: 18h (24)
Body size: 5148h (20808)
State: F8h
Header checksum: 90h
Data checksum: F2h From China you

File GUID: 9A4713C2-EF56-4FC4-AB91-270825BFD142
Type: 07h
Attributes: 40h
Full size: 696Eh (26990)
Header size: 18h (24)
Body size: 6956h (26966)
State: F8h
Header checksum: 72h
Data checksum: 94h real me,…china spy computers?you spy from china?


I get what you mean about version 3 vs version 4 @robinunicul and I too would suggest updating to version 4 ( @RichC ), but I still do not understand “China” image?
There’s also an older version 1 and 2 of the NVME module, all these 1-4 have been edited by someone to be compatible for our usage (all around compatibility)

Is version 4901 available? There is a security verification error when flashing to BIOS OP shared.

@maelstrom_x - rom All mod BIOS must be flashed via USB Flashback, this applies to all Asus boards and mod BIOS, otherwise you get security error.

If you want 4901 I’m sure I’ve modified it already for someone, I’ll hunt it down for you or post new link if you really want it?
I and many others hate those new 128GB memory BIOS from Asus for x79, but if you’re sure you want that one I can do for you or link to where I posted already.
Yes, here is 4901 I did, with some additional settings unlocked for someone (If you want stock + NVME only, let me know I will redo for you)

Thank you. Been trying to get P3608 DC to boot on this board.

@maelstrom_x - You’re welcome! That has many settings unlocked that stock BIOS doesn’t @ Advanced >> System Agent Config >> IOH Config

Are you implying that the board is able to support above 128GB memory?

Anyway, stock 4901 was able to discover Intel P3608 DC by default, booting was possible as well.

Somehow the booting difficulty recently mentioned with P3608 DC was due to failing E5 2690.

I updated to the version you provided and wasn’t able to discover 970 PRO as bootable option, so is there a setting to toggle?

Also note that the modified 4901 is not able to enter BIOS after toggling IRST (for 850 PRO RAID 0) & RSTe (for P3608 DC) - tried both to isolate another hardware related issue.

Hi there! I tried to flash my P9X79 WS mother with this one but i showed "security error" no matter what I did. USB Flashback etc. So can you fix stock with only NVME only? It would be really helpful.

Quick format the media and copy the modified BIOS into root directory. In order to determine if flashback if working, the LED needs to be blinking after you have pressed it for 3 seconds.

Non blinking LED indicates no activity, corrupted file or thumbdrive.

Sorry @maelstrom_x - if stock BIOS is NVME compatible use that instead, I was not aware it was so didn’t check for stock NVME compatible modules in there since I knew older/other BIOS for this board was not NVME Compatible. I’ve never seen anyone mention that it was other than you.
To use NVME with BIOS I modified you use this method, for boards that are not originally NVME compatible (Which I still assume applies to this board, and maybe your drive is regular SSD since you could see/boot with stock BIOS) I checked, no stock NVME compatibility for this board/BIOS 4901
All steps must be followed exactly in step #4 - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

@wentakura - sounds like your USB Stick is not compatible, or you did not set it up correctly, or you renamed the BIOS file (Must be left named exactly as I had it)

To you both, here is stock BIOS with NVME mod only, you must follow all steps exactly as written in the guide linked above at post #4 to install and boot from NVME
The mod BIOS above has been tested and used by several people too, so it’s OK, other than that RST issue mentioned which no one else has said before so unsure about that, possibly related to disk being used or some other setting maybe?

I just tried to flash this (unlocked) bios: It did not work for me

Board: P9X79 WS
CPU: E5 1680 v2
Previous bios: 4901 stock

First Try: The flashback light stays turned all the time. When I remember it right this means bios not detected.
Then I entered bios and loaded the default values. After that, the bios flashback finishes successfully but the board does not post: It stays at code “00”.

The version posted in:
P9X79 WS 4901
works out of the box for me.

Just for interest:
Does this unlocked bios support more memory? 128GB was mentioned above.

Are there modded bioses for the P9X79 which have updated memory mappings, and probably also support cheap registered DIMMs?