[OFFER] ASUS Z87-A Bios/UEFI_v2103_complete_mods

Hello! Thank you so much for the work done! I want to update the BIOS on my Asus Z87-A rev1.02, but I ran into a problem. When updating using “Asus EZ Flash 2” it gives me the error “Security verification failed.” Could you help me with this problem by explaining what I’m doing wrong. I have a CH341A-based programmer to flash SPI EEPROM, maybe you have an image.bin of a modified bios? I will be very grateful! I apologize for my English =)

I solved my problem by converting the image.cap to the image.bin using "ASUS_BIOS_CAP_to_BIN". Maybe my experience will help someone =)

CAP_to_BIN.rar (3.51 MB)

Z87A.bin.rar (4.76 MB)

Hi! A have the same problem as @Avadon58 - Asus EZ Flash utility says "Security verification failed" when i tried to update BIOS with new image from the first post.
Can anyone help me?



All you have to do is carefully take some time and read post #6 in this thread and follow the links for the procedure to the letter.


I tried my self-edited BIOS and yours but i see no change. Do I need something else aswell when in-windows(it doesnt show up in there either) or am I missing something? Its an adata xpg sx8200 pro with an axagon nvme adapter.


In the bios try disabling CSM (Compatibility Support Mode) = DISABLED

Unhook all your existing drives and you should see "Windows Boot Manager" in the boot tab of your bios.
This is where you install your new UEFI enabled system via your USB stick.

Also when running in UEFI mode you have to convert all your existing drive from MBR (Master Boot Record) drives to GPT (Gui Partition Table) drives as MBR and GPT drives cannot coexist on the same platform.

You should then experience something like found in post #14.


I tried the drive with a native slot support motherboard(Asus tuf b360 gaming plus) and it didnt show up there either so im gonna RMA the ssd and see what happens. Thanks for the response @hancor

@konrad1374 yes annoying when that happens…

Alrite i got a new drive today(HP EX950) and it works finally. The bios works aswell. Now i just need to install windows 10 on it.

Final report. It works like a dream. Although i cant update the storage controller driver with the samsung one but that doesnt matter now. Thanks @hancor for the bios


Naturally, as you are using the adata xpg sx8200 pro which isn’t specifically a samsung product.

Delighted you found your way “out of the woods”.

Hello from France !

This is what I done and it work fine !

Download latest official BIOS (Z87A.CAP)

Comment #1 : Download attachments

Comment #6 : Follow the link

Download package from [Prerequisites] and follow [Flashing the Modified UEFI] with :


Glad that worked for you!

Hi !

Just flashed my files and unfortunatly, without success.

- Got an Asus Z87-A
- Downloaded both files at the top of this topic.
- Flashed Z87A.CAP with Afuwin64, wich told me it was the wrong version of AFU, need to use Aptio 4 AFU.
- Downloaded AMI AFU For Aptio 4
- Flashed Z87A.CAP and got a secure flash rom verifiy check (with the cap of this thread)
- Download genuine 2103 cap on asus support website.
- Flashed new Z87A.CAP => OK
- Flashed Rom file (of this thread) and get an error : unknow command or option : /GAN

Is my afu version ok ? What am i supposed to do or try ?

Thank for advices

EDIT : Fixed. Old AFU tool needed with version 3.05.04

Links to the BIOS files no longer work, can we please get an update?


Links in the first post work just fine for me.

I’ll see about an update


Odd. They both bring me to a white page with a link that says “Zurück zur Forum Übersicht” I click that and it just brings me to win-raid.com.
:edit: OK, it appears that Firefox just doesn’t detect that there is something to download on that page.


Works in Chrome, Opera, etc. your browser have the latest update?


POST #1 of this thread updated with updated BIOS/UEFI

Microcode updated to v 28, network EFI/ROMs updated March 05, 2021

Interesting website and blog.