[OFFER] ASUS Z87-DELUXE-QUAD updated BIOS v2103 NVMe mod

Using the UBU 1.79.8 with UEFITool v28 I also upgraded the following:
EFI IRST RAID for SATA 12.7.0.1936 ----> 15.1.0.2545
EFI GOP Driver Haswell 5.0.1036 ----> 5.5.1034
EFI Intel Gigabit UNDI 5.4.19 ----> 0.0.29
EFI Realtek UNDI 2.020 ----> 2.054

Detect:

Z87_Deluxe_Quad_detect.png



EFI_ROM updates:

Z87_Deluxe_Quad_EFI_ROM.png




CPU microcode 19 ----> 28 (latest Spectre/Meltdown?MDS mitigation microcode) Thx Sonix! [Latest edit: Date: Sept 23, 2020]

Z87_Deluxe_Quad_microcode_update.png





NVMe functionality via ------> NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe_4.ffs dated 04/18/2018 inserted after CSMCORE for this Aptio IV UEFI/BIOS via

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Result: Very stable and reliable NVMe boot drive and system this "ancient" Asus Z87-Deluxe-Quad mobo with i7-4770K cpu sporting an Aptio 4 BIOS/UEFI; which should now run like a top on the latest Windows 10 Preview Build 18992

Use BIOS FLASHBACK method, check your manual at page 2-12.

CPU microcode 0306C 19 -------> 28 (Thx WinRaiders!)

JackRackham.png


The "Cutting Edge" of bios modding…WOOT! :slight_smile:

Made with UEFI Tool v0.28 & UBU v1.77

NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe_4.ffs dated 04/18/2018
All the rest is pretty standard ROM/EFI updates.

Enjoy your new NVMe capable modded bios with MDS/Meltdown/Spectre microcode updates.

BTW microcode v 28 fixes Microarchitectural Data Sampling (or MDS) side-channel vulnerabilities in Intel CPUs in addition to Spectre/Meltdown vulnerabilties.

As usual make a back up of your current bios and drives!


Cheers

Z87DQ.rar (4.8 MB)

@ittrainbow

UPDATE to first POST Date: Feb 17, 2020

Latest microcode 28 for Spectre/Meltdown/MDS vulnerability mitigation, also overclocks nicely to a breezy 4.7Ghz on all cores.
Also stable with one core @ 4.8Ghz with the other three cores @ 4.7Ghz.

Enjoy

@ittrainbow @Lost_N_BIOS

minor update to networking EFI Last edit May 7, 2020

Hello hancor,

This is a godsend, especially since I bought a Samsung NVME Evo 970 plus 1tb drive with a RIITOP NVMe M.2 PCIe SSD to PCI-e x4 Adapter. I assumed it worked, but now realize that the Z87-Deluxe/Quad Bios is too old to support it. I don’t plan to upgrade my CPU and MB until later this year, so your Bios is Awesome!

With that being said, I have tried to follow your suggested method to update the bios, via the Use BIOS FLASHBACK method, found in my manual at page 2-12. Unfortunately when I have the USB, with your unzipped CAP file, it all it does is blink blue and then goes solid blue. Per the manual, this means the bios upgrade failed. I do have my USB flash drive in the correct green lined port, and I hit the button when the computer is in standby.

I am not sure if I am doing something wrong, but if you or someone on this forum can help, it would be great!

My set up:
- CPU: i7 4770k
- MB: Asus z87-Deluxe/Quad
- Current Bios: 2103

Thank you!

@Maximusio - It should blink for a minute or so, getting faster as it nears the end, then go solid or off. How long is it blinking?

Small, cheap USB 2.0 is best, like 128MB-2GB. You can try to format larger ones down to 2GB or less, sometimes that helps, but some sticks are just not compatible so you may need to try a few or find some older ones in a back of a drawer somewhere
Should be formatted to FAT32 (use windows right click format, or from windows disk management), and most Asus boards it also need to go into a specific rear USB Port. Put file on root of USB, not in folder

Turn system OFF, standby may be OK but that is not the norm.

@Lost_N_BIOS @Maximusio

You may also want to try using a USB 3.0 FAT32 formatted drive which is what I use for my own Asus Z87 Deluxe.
I’ve tried with USB 2.0 and it doesn’t like it…go figure.
For my other motherboard the Asus ROG Zenith Extreme ONLY USB 2.0 works.
But here the recommended drive is USB 3.0.
As Lost_N_BIOS mentioned you may have to shop around in your drawers to find the right USB that works for you.
I’ve used a Sandisk Ultra USB 3.0 16MB sized drive in FAT32 format on my own Asus Z87 Deluxe.

The light should flash slowly at first, then the flashing light speeds up near the end and turns completely off.
Wait until the flashing STOPS COMPLETELY before rebooting and reloading defaults.

Hope that helps! Cheers

Thank you both @Lost_N_BIOS and @hancor for your prompt responses. I have tried it with both a cheap 2GB USB formatted in Fat32 and a 128gGB Samsung USB 3.0 formatted FAT32 down to 32GB, but none of them work. ;(

The experience I get, after I fully turn off the computer, is that the flash button blinks a slow blue, then I see the lights of the USB getting accessed, and then it turns solid blue. I don’t notice the transition of slow blinking to fast blinking. This happens in a few seconds, and then stays blue for the remainder of the time. I have let is sit there for 5 minutes to no avail. As a confirmation, there is nothing else in the drive but the CAP file, which I have extracted using 7-zip, from your rar file.

As mentioned prior, my outcome is to be able to boot off of the NVME drive. I currently see and can use it in File Explorer as a storage device, but the Bios has no record of it. Only my previously installed devices/drives/USB flash are recognized.

It is frustrating since you have helped so many people with this bios tweak. I will say this, prior to reading your whole post, I first tried upgrading with your bios in the EZ Flash tool, in the Advanced Bios Screen. It obviously didn’t work, and said Security Error. I then tried the Asus 2103 bios, and it said the same thing. I redownloaded the 2103 bios and tried again, and this time it accepted it. After this I tried your bios in the BIOS FLASHBACK method. After multiple attempts, USB flash drives, etc… I have had no success.

Any further suggestions would be great. Maybe I should buy a Sandisk USB 3.0 with a lower capacity, since mine is a Samsung 128GB 3.0 USB Flash drive, formated down to 32GB. I say USB 3.0, since I would buy it and use it for other purposes, opposed to my older USB 2.0 drives lying around.

Thanks again for your help and patience.

@Maximusio

I would try something in the 16-32MB region formatted FAT32 USB 3.0 drive…2GB is way too small, 128GB is way too big, you need the “Goldilocks” USB which is sized just right. ie NOT REPARTITIONED.

Should you still have no success the new fall back method should help here in the Annex section:

[Guide] How to flash a modded AMI UEFI BIOS

@Maximusio - In my experience 128MB - 2GB USB 2.0 works best, but as Hancor noted he had success with certain USB3 on this model too. You probably just need to find compatible USB Is all, sounds like both you have are not compatible
Dig around, sometimes you have to try 10 before you find one that works Older = better

You can do above linked method if you can’t find a compatible USB Stick. Or, I can help you with easier FPT method if you want? That is what we do for all Asus Intel models without USB Flashback.
If you want to do FPT way, please do below and tell me what error # you get at step #2 (I do not need your biosreg.bin dump yet from #1, we’ll toss that and make a new one once you tell me error from #2 and then we unlock it)
For this, please flash the STOCK BIOS 2103 first using EZ Flash, then proceed as noted below

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Hello,

I am getting this:
Error 280: Failed to disable write protection for the BIOS space!

After tried the step # 2

*Note: I did re-flash my bios with AFUWIN64_v3.05.04 by original file of bios then did step # 1 successfully.

Please help,
Thank you.

My Board:
ASUS Z87-DELUXE-QUAD BIOS v2103

@QLF

You should try the flashback procedure first, which is the recommended method!

Minor update to the network EFI/ROM in the first post Sept 23, 2020

Cheers

Hello @hancor

I have tried to flash my bios with your Z87DQ.CAP but I got the follwing error when the Asus EZ Flash 2 Utility tries to read it:

"Security Verification Failed"

Could you help me?

image0.jpeg

@ketchup

Yes I can help…you need to read your manual and the first post of this thread!

Use BIOS FLASHBACK method, check your manual at page 2-12

If you take your time to do this, you will solve your problem…


Cheers and Happy New Year!

Hello hancor. Just upgraded my Z87-DELUXE/QUAD to boot up a Samsung 970 EVO. Thanks for the great job, and happy new year !