[OFFER] ASUS Z87-DELUXE updated BIOS v2103 NVMe mod

Speaking of my question above, newest win10 (1809) .503 update didn’t change this firmware, was still 0x25, now with your bios it’s 0x27 like you mentioned.


Yes it is Windows 10 Insider Preview Build 18895 (20H1) [ version 1903 etc]that the microcode came from, so you are now “ahead of the curve”.

Did you ever figure out if Optane Memory for system acceleration works with a 4770k on the Z87-Deluxe/Dual ? I’ve already flashed my bios using your guide, has there been any updates or improvements to your own system since you posted this?

I’m speaking only for performance I don’t have nvme ssd yet, will probably test soon in lowest 3rd pcie16x slot (real 2.0 4x).

So the first thing I noticed when I flashed new how quicker it now boots to Uefi and later by windows restart. I also I got my cpu oc stability back I’m ocing that 4770k to 4.7ghz and cache 4.2ghz. But guess my oc slowly went bad because I tweaked too much in these 3-4yrs

Newest microcode 0x27 is good, even better then older 0x25 with retopoline enabled.

I’m basically having the same perf. like by old windows8.1 or even 7 fo that matter. Tested various cpu bound game benchmarks and system tests and it’s good.

Anyway, thanks hancor for this little aio bios mod! :slight_smile:

Results below keep in mind that I’m running unfinished preview software ie build18898

Passmark Score 96%

You can check the NVMe performance by eyeing the Disk Mark part of the chart above.
I’m running a Thunderbolt card in PCIe_X16_3, so my NVMe SSD (Samsung 950 PRO 512GB) is in slot denoted PCIe_X16_2.

With a max X 47 multiplier on the CPU I get no BOOT up, on 32GB of G.Skill 2400Mhz RAM modules.

I went with a x 46 multiplier on the CPU; but then that is on ALL cores; your mileage may vary.
Go big, or go home…

Edit: OK, played around a little more with individual cores multipliers and the following worked for me: ie will boot up and game

CPU Core0: x47 no voltage adjustment x47 +205mV in OFFSET mode, on CPU core voltage 1.360V total
CPU Core1: x47 --------------------------- x47 +205mV in OFFSET mode, on CPU cache voltage 1.321V total
CPU Core2: x45 --------------------------- x46
CPU Core3: x45 --------------------------- x46

CPU cache x 42 multiplier in both no voltage and overclocking voltage scenarios as above.


As you can see from pic below the Optane enabled driver loads; but of course there is no Optane enabled drive on the motherboard at present.
The question I posed was somewhat speculative, but it would be interesting if someone loaded an Optane drive onto a PCIe adapter card to find out and see if that works…with or without another Bios/UEFI mod.


Good Morning! Does this modified BIOS fit the ASUS Z87-K Motherboard ??

@rockwxnl : Check the link below for:

[OFFER] ASUS Z87-K_BIOS_UEFI_v1402_complete mod


Don’t want to be another request, but I have a Asus Z97-WS that I really don’t want to upgrade. Can you mod the most recent BIOS (ver 2004) as well for my board? If yes, very much appreciated and thanks.

The latest version for the motherboard is v 2704

See the thread below:

[OFFER] ASUS Z97-WS_BIOS_UEFI_v2704_complete mods



Sorry I have written a typo, my MB is Z87-WS. The Z97 chipset has PCIe booting. Please excuse my idiotic mistake. So if u look up current BIOS version for Asus Z87-WS. It should be ver2004.

Shall we try this once again…try the NEW link…

[OFFER] ASUS Z87-WS_BIOS_UEFI_v2004_complete mods


I hate to be another request, but I have a Asus Z87-PRO, here’s the link to the BIOS download https://www.asus.com/us/Motherboards/Z87PRO/HelpDesk_BIOS/.

I recently bought an M.2 and a generic adaptor and my motherboard does not want to recognize it, if you could work your magic I’d greatly appreciate it. Thank you in advance!

Already done, you just need to use your search function, see link below:

[OFFER] ASUS Z87 PRO v2103 complete mod


dude, sorry for texting here

i own z87 deluxe quad, so i cant upgrade my mb with your mod

i extracted nvme.ffs from your rom and inserted it into my .cap taken from offsite, and still not able to upgrade bios

"security verification failed" popup for ez flash, no any results for flashing via flashback (at least still no additional ssd in bios)

any advices?

Try this link for your pleasure:

RE: [OFFER] ASUS Z87-DELUXE-QUAD updated BIOS v2103 NVMe mod

[[File:Intel SATA AHCI & RAID Driver v15.9.1.1018 photo2.jpg|none|auto]]

btw where can I find this driver? I tried a few from stationdrivers but it didn’t work.

Intel Rapid Storage Technology (RST) v15.9.1.1018 WHQL

https://kbench.com/software/?q=node/69114 (Korean benchmark site)

Fernando also mentioned in this thread:

Intel RST/RSTe Drivers (latest: v17.2.12.1035 WHQL/v6.1.2.1008 WHQL) (115) post #1713

Hm When I tried to install normally it said driver installation ended prematurely, when I tried in devicemanager also nothing happened. Max I can install is 14.9.xxxx

On a clean Windows 10 installation…Pro or Home version?


Windows 10 pro 1903 latest official.

I had basic ahci, read once newer meltdown and what not runs worse with official irst, but then I tried to install a few and can’t…

Or do I need to do that f6 install before windows install?