[OFFER] ASUS Z87-DELUXE updated BIOS v2103 NVMe mod


Hancor helped me with a modded BIOS for my Asus Z87-WS, it worked perfectly for my Windows 10 install, all updated to Ver. 1809. Then when Ver. 1903 came around, I thought I would try it out, then there after a few 'Blue Screen of Death" with Win10 frowny face. Then eventually BIOS boot to black screen, GPU was not outputting a signal. I had to do a USB BIOS flashback from back port of MB. Not sure what update Ver.1903 contains, but its poison and volatile to the NVME mod. All in all, it seems we are stuck at Ver.1809, or until an update post Ver.1903 that might be compatible. So if you revert back to Ver.1809, your MB might work with the modded BIOS.

I’m currently running Windows 10 Preview Build 18932, and yes Windows Updates are having problems. I’ve had a black screen issue with my old daily driver an Asus P6T which hangs with the install of a cumulative update. I just pause updates and roll back to a set restore point.

The bios is fine, its the fine folks at Microsoft issuing crap updates which breaks more stuff than it ‘fixes’. see news story below:


Installation rates for Windows 10 May 2019 Update (version 1903) remain low, and this is at least in part because Microsoft has blocked updates for many people because of a series of problems with hardware and software compatibility.

Now installation numbers may start to increase as Microsoft has removed some of these blocks – although the company warns that it could take a little while for the update to appear to those who were previously unable to install it.

Over on the release information page for Windows 10 version 1903, Microsoft reveals that three problems that prevented installation have been addressed. The trio of issues that have been fixed are:

Loss of functionality in Dynabook Smartphone Link app
Audio not working with Dolby Atmos headphones and home theatre
Error attempting to update with external USB device or memory card attached

If you have been prevented from installing the update because of any of these issues, you will soon now be able to do so.

Microsoft warns:

[These] issue[s] [are] now resolved and the safeguard hold has been removed. Please note, it can take up to 48 hours before you can update to Window 10, version 1903.

With the problems having been fixed as of July 11, you may have to wait until the weekend for the update to show up for you.

How many people in computerdom own an external USB device or memory card…!?!

This issue is just plain laziness and really sloppy coding on behalf of Micro-Death; I mean people just buy thousands of dollars worth of equipment so they can stare at a blank screen. Evidently no regression testing had been done before releasing the prior ostensible “FIXES”.

Hi @hancor

I have a Z87-DELUXE/DUAL and as I understand it won’t work with your mod.
Therefor I’d like to request a mod for it, if you have time.

Link to BIOS download: https://www.asus.com/us/Motherboards/Z87…L/HelpDesk_BIOS

Many thanks in advance!


I made time for your mod request, see link below:

RE: [OFFER] ASUS Z87-DELUXE-DUAL updated BIOS v2103 NVMe mod

Thank you very much!

HI, I read now. I wish to put in my mainboard a 970evo nvme disk.
I have a Z87 DELUXE/DUAL motherboard.
There is difference between Z87 DeLuxe an Z87 DeLuxe/Dual bios ?
Can I use your modified bios or I need a modified one for my motherboard model ?

Edit: Excuse me ! I see only now that there is a specific thread for my motherboard ! :slight_smile:

Hey all,

I’ve been reading with interest.

I have the ASUS z87 Deluxe w Wifi (mobo).

I’ve loaded the BIOS mod (Z87D.CAP) however for the live of me I cant get window to boot from it.

I’ve loaded my Window 10 (acronis image) onto the m.2 drive, which acronis can see.

I’m running a Samsung 970 evo Plus (nvme) M.2 on a PCI-e adpater card which supports nvme.

I’ve tried several settings and just doesnt want to boot up. In boot setup under bootable drives it shows this as a boot option: PATA SS: nothing else.

Can someone shed some light on what I am missing here? I’ve uploaded the specific BIOS for my motherboard if that help.


Z87-DELUXE-ASUS-2103.zip (5.25 MB)

You must have CSM (Compatibility Support Module) set to DISABLED to support the UEFI functions.
ie NVME drive will only boot in a UEFI environment. Further, unhook all your other drives when installing Windoze 10.
Lastly, make sure your drives are ALL configured as GPT (Gui Partition Table)

If that doesn’t work, reflash the bios in the first post.



Thanks for the reply hancor, I will try that. I hadn’t disabled CSM. I’ll post back results.


Well so far no good. When I disable CSM the BIOS wont post. I seem to have an error onboard? 0099. And a red LED lights up next to the first PCI-E slot where the GPU sits. I did swap the M.2 adapter card with the GPU however still got the same issue.

If I enable CSM no issues, however it doesn’t boot off the M.2.

I noticed while swapping PCI-E cards around, it says on one of the heatsinks near the CPU, Dual Intelligent Processor. Does this have anything to do with the BIOS differences between Asus Z87 Deluxe and Asus Z87 Deluxe Dual? Maybe I am flashing the wrong BOIS?

Edit: No its not the Deluxe/Dual Mobo.

At page 1-7 of your manual you will discover that the first PCIEX16_1 slot has a VGA LED next to it.
If your primary graphics card is not installed here it gets cranky, hence the lit “RED” LED.


(ie you have separate/discrete graphics card as opposed to the onboard graphics in the CPU.) You will have to tell your bios whether you are using onboard graphics or have a separate adapter.

Your M.2 Adapter card with the NVME drive should be inserted in either PCIEX16_2 or PCIEX16_3. I used PCIEX16_2 slot as I have a Thunderbolt2 controller in the latter slot.

You either have a bad graphics card or you need to reflash the bios from the beginning post using the BIOS FLASHBACK METHOD as outlined on page 2-12 of your manual. by using the BIOS FLASHBACK button on your rear panel. DO NOT INTERRUPT THE PROCESS UNTIL THE BIOS FLASHBACK BUTTON STOPS FLASHING!

Your computer should be plugged into the surge protected power source, but powered down. Hold the BIOS FLASHBACK button down for a few seconds and it will begin to start flashing. The flashing light blinks faster near the end of the process, let it complete without interruption IE DO NOT REMOVE YOUR USB STICK OR PULL THE POWER PLUG!

Reboot, load setup defaults, reboot, adjust CSM to DISABLED. Under the boot TAB, upon reboot, you should find WINDOWS BOOT MANAGER this is the drive you install WINDOZE 10 to…

Lastly, your WINDOZE 10 USB stick also needs to be the GPT version of the installer as the MBR version won’t find the drive…



Sorry for the hassle, just a bit confused on this one. I can deal with most things on my system… :slight_smile:

Yep GUP card is fine, at least is seems to be. It is in PCI-E slot 1. Nvme card in PCI-E2, nothing in PCI-E 3.

All BIOS flashing is done using the Flashback method. easy enough.

I dont appear to be getting the option to boot to windows boot manager? I used to see many of these previously, not sure why not now. I need to workout how to convert my WIN10 acronis image to a GPT version. This might be where I am coming unstuck. SO I need to have the WINDOWS 10 UEFI installed on the M.2 before I turn off CSM?

I’ll take a break from it for the moment and think about it. I can see the M.2 drive in Disk Management under current windows so it should be ok.

Probably PCIE Card does not have UEFI BIOS, thus you cannot boot to UEFI mode with CSM disabled.

@hexem What kind of PCIE M.2 adapter do you have? There are adapters that only support SATA SSDs.

You need to have an adapter that supports the NVME protocol.

When I was doing this I used the Addonics M.2 PCIe SSD Adapter X110.

See my original exploits with Fernando et al below:

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (22)

See post #356 below on why you CANNOT MIX MBR and GPT partitions: all the hair pulling has been done for you!

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (24)


The Addonics M.2 PCIe SSD Adapter X110 (part number AD2M2X-PX4 $38.55 USD) I used, has BOTH NVME and SATA SSD support! Make sure the M.2 is in the right slot, ONLY one will work with the NVME drive. IE it won’t boot off the SATA SSD slot if CSM is disabled.

We know this works, and have proven it.

BTW what adapter and NVME ssd are you using specifically?

$38 card just for NVME? That cost almost as much as my NVME drive
If you just have one NVME drive, you only need $5 card for a single NVME, this is cheapest one I found and use - https://www.amazon.com/gp/product/B07GPBBCGS
Works fine for NVME, my benchmark here in Win7 even - Installing Clean Win7x64 on M2.2280 PCIe Gen3x4 SSD A-DATA SX8200 Pro

Hacor you are right about some of those Dual M.2 cards, only support one NVME + one SATA via SATA cable, those are #12 or so on amazon/ebay

Hey mate,

The PCIE adapter does both NVME and SATA. The M.2 is a Samsung 970EVO NVME 500GB.

The PCIE adapter is a Simplecom EC412.

I did some tweaking and can get the 970 m.2 to show at post as a Windows Boot Manger. However when it tried to load windows I got the "Your PC ran into problems" blue screen. I think I know what caused that.

I have not yet disabled CSM as yet. I will once I get the OS loaded onto the M.2 properly.

Thanks for your assistance. Greatly appreciated.

Now, you are there, clean install from GPT partitioned USB to GPT or RAW drive, also see my above post if you are considering other adapters

Yes well when I was doing this 4 (FOUR) YEARS AGO NVME SSDs were relatively new technology…!
So if I only had time travelled forward FOUR years to get a better DEAL!!!

So I get into the penalty box for being an early adopter or is that early adapter?

Yes, now it’s all cheap, even the NVME’s - I was very surprised, especially at SSD’s I paid 100+ for last year, now $30 already

Yes, it’s early adapter I know the pain, I’ve paid $150+ for sets of 2x2GB DDR3 you’d be lucky to see sell for $30 today

Ok up and running.

Edit: CSM now disabled in BIOS and boots to windows.