[OFFER] ASUS Z87-DELUXE updated BIOS v2103 NVMe mod

Using the UBU with UEFITool v25 I also upgraded the following:
EFI GOP Driver Haswell 5.0.1036 ----> 5.5.1034
EFI Intel Gigabit UNDI 5.4.19 ----> 0.1.00
EFI Realtek UNDI 2.020 ----> 2.054
CPU microcode 19 ----> 28 (latest Spectre/Meltdown & now MDS mitigating microcode) Thx Sonix! [Latest edit: Date: Jan 04, 2021

Network update mod Jan 04, 2021

UBU detect:

Asus Z87_Deluxe_detect_04_12_2021.png

EFI ROM updates:

Microcode updates:

NVMe functionality via ------> NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe_5.ffs inserted after CSMCORE for this Aptio IV UEFI/BIOS via
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Parenthetically, the above UBU works with MMTool v4.50.0.23 or v5.0.0.7.

Manual NVMe insert via MMTool v4.50.0.23

Result: Very stable and reliable NVMe boot drive and system for my "ancient" Asus Z87-Deluxe mobo with i7-4770K cpu sporting an Aptio 4 BIOS/UEFI;
which now runs like a top on the latest Windows 10 Preview Build 19041.81

Use BIOS FLASHBACK method, check your manual at page 2-12.



Interestingly, I was able to successively load the following drivers after upgrading the EFI IRST RAID for SATA ---->

Intel RSTe AHCI & RAID v15.2.16.1060
Intel RSTe AHCI & RAID_v15.5.5.1059
Intel RSTe AHCI & RAID v15.7.6.1027
Intel RSTe AHCI & RAID_v15.9.1.1018

The above drivers are also supposed to work with Intel Optane technology which leads to the following speculative question:

So I’m wondering if there is an Intel_Optane_DXE3.Ffs
which could also be loaded into the old Z87 class bioses which would allow Optane 900P/800P or the the server-oriented P4800X 750GB card
to be used in older systems as we’ve done with NVMe drives?

[[File:Intel SATA AHCI & RAID Driver v15.9.1.1018 photo2.jpg|none|auto]]
[[File:Intel SATA AHCI & RAID Driver v15.9.1.1018.jpg|none|auto]]

Edit: NVMe mod using module NvmExpressDxe_5.ffs
CPU microcode update to version 28
Network ROM/EFIs to:
EFI Intel Gigabit UNDI 5.4.19 ----> 0.1.00
EFI Realtek UNDI 2.020 ----> 2.056

Date: Nov 13, 2023 NVMe_Dxe5_Ffs insert & minor network updates as per pic above

Z87D.rar (4.8 MB)

could you do a version for https://www.asus.com/us/Motherboards/MAX…pDesk_Download/
but without the specure/meltdown fixes *they cost to much performance for my workload
much appreciative if you could give this old board some love

check new thread above

MAXIMUS VI GENE BIOS 1603 modded for NVMe boot drive and EFI updates



Hi, and thanks for developing these NVMe bioses for us! I really appreciate that people like you are out there and willing to help those of us less experienced in the bios world.

Does your Asus Z87 Deluxe Bios work with the Asus Z87 Plus mother board? If not, would you please modify the 5.2 MB Plus 2103 bios located here: https://www.asus.com/us/Motherboards/Z87PLUS/HelpDesk_BIOS/

I also attached the bios, but if you don’t trust attachments, (I understand that), please use the link I supplied.

It is the second bios in the list and I prefer it because it doesn’t have the Asus firmware installer included with it. Are there any special instructions for loading this bios? And this mod will allow me to boot from any NVMe drive attached to the PCIe3 system on my Z87 Plus?

Thank you so much for your help. I am indebted to people like you who help all of us get the most performance from our older motherboards that Asus won’t update their bioses for! :wink:

My Z87 Plus also runs the i7 4770k overclocked to 4.2GHz with 16GB RAM, a Sandisk 500GB SSD, a Samsung 250GB 840 EVO SSD and 2xSeagate 2GB Barracudas, as well as an nVidia GTX 770.

By the way, this is for a Windows 10 64bit PC.

Z87-PLUS-ASUS-2103.zip (5.2 MB)

Enjoy updates for Z87-Plus here:

Asus Z87 Plus - Nvme Bios mod & Meltdown/Spectre microcode updates - Version 2103

Sorry for my n00bish question but I’m new to bios modding and have an ASUS Z87I DELUXE mainboard. I’d like to at least enable NVMe support and get some info about what else I can modify/update in it. It looks like u did a lot of updates for the one posted in this thread.
Also have a couple other questions:
I read that u can’t have the intel raid enabled to have the NVMe work, is that only for during flashing or do I kiss it goodbye for good?
Also it is possible to make the NVMe drive bootable for win 10, correct?
Lastly, do u know if it’s possible to use an inexpensive PCIe adapter card w RAID onboard w multiple NVMe drives in raid and have it as a windows boot drive, without using the $400 highpoint card?

@Zer0bit - If @hancor does not get back to you on this, I can do the NVME mod for you. I can’t answer your questions about adapters or RAID though sorry.
But yes, you will be able to boot Win10, but you will need to do a clean install onto the NVME - here is guide to do the mod and clean install, it’s very easy to do, after the mod make sure you follow all steps exactly in post #4 to install win10
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Sorry just busy with my day job, which has some deadlines re:March 1st; after that I’ll have some time.


Ty for the offer @lost_N_BIOS and @hancor
I’d like to try it myself first, just to get the experience, but I’ve been having an issue getting any of my usb sticks to work via ASUS Bios flashback. All of the ones I’ve tried are Sandisk formatted to fat 16 or fat 32, 2gb, 8gb and 16gb. The bios file is correctly named and stock bios file works thru the ezflash inside the bios.

Any tips u can give me to try to get these sticks working w flashback? I’ve also tried formatting via hp format tool and a couple others but no luck.

Basically when I try flashback I hold the button for 3 seconds till it starts blinking and release, it blinks 4x then stays solid indefinitely. 2 of the sticks have a led that lights up showing access, it stops flashing after the 2nd or third blink of the button.

@Zer0bit - you can format the sticks again yourself, and I suggest trying that before you give up on them. HP Format tool is for making bootable devices, don’t use that. Format with windows simple right click, format to FAT32, put recovery named BIOS file on the root of the USB not in any folders.
Also, upload your mod BIOS for me to check. You didn’t rename some rom/bin BIOS to CAP did you? If yes, you can’t do that, you need to put the rom/bin BIOS back inside of a capsule before flashback will use it.

Some USB are just never going to work, the only ting you can do if everything else is correct is to get other USB to try, dig around in back of your drawers, hopefully you find some good old USB sticks you forgot about.


That is a great achievement with your Z87 Deluxe Bios. Thanks for sharing your journey.

Having tried over the past two weeks to modify a Asus Maximum Impact VI Z87 Bios I am not having much success. I have managed to insert NvmExpressDxe_4.ffs for NVMe support via UBT.

My CPU is a older (Haswell)Intel Core i5 4570s. I do not know whether the CPU Microcode updates would degrade performance of this chip further. The tool ‘inspectre’ already shows performance as ‘slower’ with Meltdown Patch applied. Does the microcode update have a significant impact on your system?

I have also been unable to modify the Raid OROM to some newer version. My current orom version is also
I run the system currently in AHCI Mode with a Samsung EVO SSD, but I have purchased a Samsung M2 NVMe 970 EVO that I wish to eventually install with Windows 64 Bit(7 or 10).

Could you possibly modify the Version 1603 Bios (dated 2014/09/12) with relevant updates that might help. The bios is found at https://www.asus.com/us/Motherboards/MAX…/HelpDesk_BIOS/

Thanks for any help.

see this thread
MAXIMUS VI IMPACT v1603 mod NVMe functionality; Spectre/Meltdown microcode update —> 25

Thank you so much hancor, I look forward to flashing it later today

Hi hancor, just saw you thread. Amazing work.

Could you do one for the Asus Z87-A? Attached is the bios

Thank you so much in advance.

Z87-A-ASUS-2103.zip (5.18 MB)

@ DACHIGGA: see below link

[OFFER] ASUS Z87-A Bios/UEFI_v2103_complete_mods


I have the same motherboard and cpu as you

When I tried to load your bios in EZ flash trough uefi it said something about security protection fail and it won’t let me read the rom… What could be wrong? do I need to flash with USB, like when I flashed newer imei firmware once.?

The correct procedure with all modded bios on the Asus motherboards, where applicable, is to use the “FLASHBACK” method with the specific flashback USB port on your motherboard. READ your manual to find the correct port [USB port is outlined in green on your mobo I/O plate] , have power on in standby mode, not BOOTED up. Press flashback button and wait until it stops flashing completely!

Evidently, you didn’t read the first post where I indicated where to find it in your manual:

Use BIOS FLASHBACK method, check your manual at page 2-12.

BTW updated BIOS/UEFI uploaded with microcode v27 which fixes Microarchitectural Data Sampling (or MDS) side-channel vulnerabilities in Intel CPUs.

Ah and i just updated original bios :smiley:

Hmm, so is this the same as latest windows update microcode?

well I re-flashed anyway since I’m already in the mood. Got it up and running now :slight_smile:

Speaking of my question above, newest win10 (1809) .503 update didn’t change this firmware, was still 0x25, now with your bios it’s 0x27 like you mentioned.