[OFFER] Gigabyte B75M-D3H 1.0 BIOS Mod (NVME Support)

I recently bought a Gigabyte M.2 NVME Drive and i cant boot from it without using my windows install on another drive.

I already have tried the NVME BIOS MOD and still not sucess, i have got a valid windows 10 install on the Drive so it should work fine.
The BIOS Mods ive tried all boot fine but still does not find Windows Boot Mangager!

Ive attacted the bios’s ive tried (Based on F15) so please tell me what im doing wrong or what is wrong thx!
Dropbox Link to my Non-working NVME Bios

@Duncan494 - Did you test a clean install? I’m not sure you can move an already installed windows like that.
Normally you have to follow all steps, exactly, from step 4 in this guide
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

I checked your BIOS file, mod is fine. Moving this thread, since this is not an already modified BIOS for others to use.

It was a clean install using a gpt Uefi formatted USB hdd so it can’t be the install I don’t think. Thank you for moving the thread.

USB HDD? That’s the issue, you need to do a clean install on the M.2 NVME, with nothing else attached.

That is exactly what I am talking about it was a fresh install with the installation media on a separate USB hdd and I can boot to it and verify it is working because I’m using it right now and a nvme controller is loaded

That’s exactly what I’m talking about too, you can’t do that, you need to do a clean install on this system exactly as you are trying to use it now (without the USB).

*Edit - ohh, you mean the install media is on USB, not the NVME, sorry about that. I thought you meant you initially installed onto the NVME via some USB/HDD/SSD adapter.

If you followed all steps in guide above at step #4 it should be working, if you did not use that method I have no clue how to correct things and make it work, other than suggesting doing it again using that exact method.

i know what ive done, im such an idiot! the bootable partition is on the ssd not the hdd so i will move it or install grub, Thank you for checking my bios and telling me the problem! Amazing Work! You saved me from buying a new motherboard!

Great you figured it out. I didn’t do anything, it was all you! Well, I let you know mod BIOS was OK, but that’s not a big deal, you found the cause of the issue, good work!

Thank you for it though I wouldn’t of thought about it until you come in to help! I ended up using easyuefi to rebuild the efi partition for windows boot manager then it instantly popped up Gigabyte ssd in my bios AMAZING!

@Duncan494 - You’re welcome. You’ll have to share that fix/method into the main NVME thread, it might help some others in the future

I’m also with that B75M-D3H and a Plextor M8SeY 1TB , I have this beta gigabyte bios that also supports it, have you tried with that bios F16_GC?

B75MD3HGC.zip (4.36 MB)

I have version 1.0 with my Motherboard and it only has f15 and i works okay but i dont know if the two boards are different



The boards are the same , in the F15 mod does the suspension mode work?

This bios F16GC are made in the gigabyte support for NVMe

Maybe you have better luck with the mod BIOS from this thread instead?



:slight_smile:

Hello, Is there a "full updated" Bios mod for this motherboard? thank you

@laranje - contact them directly via support ticket and let them know, maybe they have the device and will test and make you new BIOS. Sometimes you get lucky



I’ve done that and that’s the bios that I’ve been sent, it works well with other NVMe models :frowning:



Yes, the one that I have uploaded 16d GC

cpuidmio.jpg

Did you write back to them, and ask again, please test with xxx device = test BIOS sent does not work with xxx device? Maybe they will look again, if they have a sample of your exact device.