[OFFER] Gigabyte GA-970A-DS3P rev2.x BIOS Mod NVME Added

And I made a mistake…
This is the latest BIOS of my motherboard http://download.gigabyte.eu/FileList/BIO…0a-ud3p_f2g.zip
f2g not f2j…

This is my motherboard: https://www.gigabyte.com/Motherboard/GA-…support-dl-bios

I am sorry @Lost_N_BIOS for the confusion… :frowning:

EDIT: I probably have to make another Thread with a correct title and links to be able to be found by others who search the same, right?

EDIT 2: I made this thread here, so if there is a solution, people will find it easier [Request] Gigabyte GA-970A-UD3P rev. 1.0 MODDED BIOS for M.2/NVME Support on Boot

You’re welcome, and I’ll catch you on the other thread then!

Hello guys how to enable nvme boot in BIOS, I flashed modified BIOS but motherboard doesnt see inserted pcie nvme adapter, and there is no option to boot from nvme pcie card?
When I launch install win10, they can see my pcie nvme adapter but cant install win on it.

MC Extractor shows this:

That looks like you picked the correct modified BIOS, you’re using newer version of MC Extractor is why it shows those two out of date vs the posted image on page one. Since the first post BIOS mod, there is now newer microcode updates than what’s in there, that’s why it says “NO” on latest, since there is newer update available now.
As for your NVME issue, have you read this thread, specifically spoiler #6 since the modification is already done to the BIOS - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Yes I read that, and tried couple times and for the third time I finally succeeded. Thanks

Great you got it figured out @Tomelis !

Thanks for your effort!
Has anyone tested it with x4 or x16 pcie?

@cr3a7er - maybe @vagdesign can answer this, but he has rev 1.0 board, should be same result though, you can also ask the other guys on his thread here
[OFFER] Gigabyte GA-970A-UD3P Rev. 1.0 BIOS F2g completely updated (incl. NVMe support)

thanks, but folks are talking about different mobo GA-970A-UD3P
Mine is
GA-970A-DS3P rev1. 0

latest bios seems to be beta, i havent updated it yet,

@cr3a7er - yes, but it’s same chipset, so would have same results with hardware testing like you asked about, that’s why I linked it. I assumed you were asking about NVME speed testing/benchmark results
I would use the latest BIOS, beta or not, since this is such an older chipset you can consider the last beta probably last final and likely wont get anymore updates unless you ask directly and they send you something for special request.

Hi! First post and first time looking for a modded BIOS. This will work with Rev 2.1 and a 1 TB Samsung 970 EVO?

Thanks so much!

@Bennemat - yes, BIOS in first post by @Ferrous will work for your board for NVME SSD

@Lost_N_BIOS thank you so much for the fast response. I will go ahead and flash tonight.

I’ve tried doing this but unsuccessfully. Flashed the bios and I can get it to see the NVME drive and choose it as a boot drive, but it won’t boot from it. I cloned my current drive (Samsung EVO 850), shut down the system and unplugged it. Reloaded into bios and verified that the boot drive is set to the new PCIE NVME, but after I exit the bios it doesn’t load windows. Do I need to do a fresh install onto the NVME in order to utilize it or am I just missing something?

This is a Rev 2 board, not Rev 1 like one person was asking about.

@xD0ZERx - to boot from NVME mod BIOS, you must do the operating system install a certain way, with certain BIOS settings. Yes, completely new windows install is required
Here is the guide on that, follow every step in “Step#4” exactly - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Hi @Lost_N_BIOS ,
i’ve just got one test m2 nvme MP500 480GB .
I’ve tried to flash the bios you’ve posted

but it says “Invalid BIOS image.” is there something that can be done to make it flash? Or it is bad mod?
This is my original/currently flashed/ Bios - http://download.gigabyte.eu/FileList/BIO…0a-ds3p_f2j.zip

Sadly the PCIE slot isn’t fast enough to deliver more than 600 MB/s

I’ve managed to add the NVME module on my Gigabyte AM3+ by following this guide,
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

It did worked for me, here are some benchmarks
NVMe - MP500 480GB - https://ibb.co/zSLBLdp
SATA - Evo 860 250GB - https://ibb.co/L1fWZch
I hope this helps to anyone that wants to speed up his PC using M2 NVMe

Guys, thanks so much, I just make my Gigabyte 970 motherboard working with Samsung 970 evo following your instruction
I specially registered on your forum to say thanks and bring my 5 cents of practical experience as it may be useful to someone.
So first, I flashed mod bios and nothing changed. I spent about a day trying various tricks but nothing worked.
Than I started thinking of what could be different between my setup and the others setup where modded bios successfully works.
I had 5 HDD connected to MB, sounds pretty awesome but I kept all of my HDD connected: Toshiba, WD 75OGB, WD 1TB, WD 2TB, Seagate 4TB
Just to reduce “complexity” of setup I started unplugging HDDs and BINGO when 2 and 4TB HDDs left, SSH drive appeared in BIOS boot menu.
I do’t know if those HDDs caused compatibility issues with SSD or BIOS can’t handle so many bootable HDDs at a time, but I would strictly advise to leave only 1 HDD and unplug (temporary) the others if you have more than 2.

@cr3a7er - yes, maybe it is bad mod! Sorry, it must be due to this BIOS needs modified via MMTool instead of UEFITool, you used MMTool correct?
I will update link with MMTool modified BIOS once you confirm that’s what you used, or you can link your mod BIOS if you want and I’ll update my post with link to your BIOS.

@red_perez - For the many drives issue, you need to go into HDD BBS options and move your main NVME drive to top, or disable all in there until you can then select the NVME at top, then back out and again make sure NVME is first, then you can have all drives connected.