[OFFER] Gigabyte GA-97X-Gaming 7 beta bios (F9b) mod

Hi all,

Here is an updated/modded BIOS based on the Gigabyte GA-Z97X-Gaming 7 Beta BIOS version F9b.


This modded BIOS contains the following updates:

Disk Controller:

EFI GOP Driver HSW-BDW: 5.5.1032 → 5.5.1034
ORM VBIOS HSW-BDW: 1038 → 1044

EFI Lx Killer Network UNDI: →
OROM QCM-Atheros PXE: →

Other SATA Controller:
EFI Marvell SATA ACHI: →
ORM Marvell 88SE9192: →

Intel Management Engine: → (Due to the updated IME, once the BIOS is flashed, run the following Flash Programming Tool command in a administrator level CMD window: fpt -greset
The computer will reset after this command

Re-enabled the 1024MB option for Integrated Video Memory Allocation

New boot splash screen:


Updated CPU Microcode:




A special thanks to @Lost_N_BIOS , @SoniX , @Fernando , and @chinobino for their guidance and help in this project!

Below, the BIOS is also attached in a two part .zip file. Unzip each file and then combine the two expanded files together to make one .zip file:

z97XGAMING7F9b_mod001.zip (5 MB)

z97XGAMING7F9b_mod002.zip (4.44 MB)

Thank you for the updated BIOS!

I have done the update on my rev 1.0 motherboard and it works fine :slight_smile:

Had some problems finding the right Flash Programming Tool but i eventually succeseded with this version.

Can you say anything about what the benefits are of the update?

Hi again, which FPT tool to use?
Can you attach link?


Used this BIOS
I see some improvement on efficiency but did not test stability yet

Intel orom for raid did not load.

BIOS i rom.jpg

So how it was set?
Is these BIOS valid for full?

@PitKoz :
These are the modules, which are within the linked modded BIOS of this thread:

Z97XGaming7_F7b-mod BIOS.png

If you have flashed this modded BIOS, but don’t see the Intel RAID Utility v15.1.0.2545 after having set the Intel SATA Controller to “RAID” within the BIOS, there are only 2 possible reasons:
a) The BIOS flashing procedure didn’t succeed.
b) The system BIOS of your mainboard doesn’t allow an update of the Intel RAID ROM module to any v15 platform version.

the latest o ROM for platforms are these:

P67 / Z68 / Z77 - OROM

Z87 / Z97 - OROM

@boombastik :
Thanks for this statement, which may be important for all users with an Intel RAID system. This would explain, why I haven’t been able to use any v15 or v16 platform Intel RAID ROM with my Z97 chipset ASRock MB RAID system.
Where did you get this information?

Here is my explanation regarding the reason why newer Intel RAID Option ROMs cannot be used by older Intel chipset RAID systems, whereas the related Intel RST RAID drivers are installable without any problems:
The usability of the Intel RAID driver depends on the external DeviceID DEV_2822, which is identical for the Intel RAID Controllers of all Intel chipsets from ICH8R up, whereas the usability of the Intel RAID ROM depends on the internal DeviceID, which is quite different for the various Intel chipset RAID Controllers.
If boombastik’s statement should be correct, it wouldn’t make any sense to update the Intel RAID BIOS modules of older Intel chipset systems to the latest available ones.

1) Wikipedia that keeps updated above 4 years -https://en.wikipedia.org/wiki/Intel_Rapid_Storage_Technology
2) Modder garikfox -https://www.overclock.net/forum/16994769-post1.html
3) Personal experience.

@ Fernando:

While generally true, there are exceptions such as the Asus Z87 Deluxe (Mono), (Dual) & (Quad) boards do allow the RAID ROM to go up to and function without issue.
I know I have tried with these boards! Higher iterations of this of the 15 series RAID ROM cause a failure to boot…

See here:

[OFFER] ASUS Z87-DELUXE updated BIOS v2103 NVMe mod
RE: [OFFER] ASUS Z87-DELUXE-DUAL updated BIOS v2103 NVMe mod
RE: [OFFER] ASUS Z87-DELUXE-QUAD updated BIOS v2103 NVMe mod

Of course these were higher end boards and had a little more manufacturer effort behind them…

So while it is useful to look for general patterns, there is some variability in the manufacturer space with respect to RAID ROMs.


@hancor They are the only boards that you mod with 15.1 because in all others z97 you use the 14.8. I am correct?
But even with them above 15.1 dont post as you said.


Z87 / Z97 - OROM is the general "rule"

But with the Asus Z87 Deluxe boards, I went through the whole 15.x RAID ROM sequence to find those that booted and those that didn’t. (ie Flash and reboot with each RAID ROM)
You can actually test the Z97 boards yourself to see if they exhibit the same behaviour, you may find other boards will allow the level 15.x RAID ROMS to run.
Yes, yes, I know this takes time to do good science.

If you are just trying to ‘get on with your life’, the quick and dirty rule on the level RAID ROM will suffice.


My own experiences with Intel RAID arrays on different Intel chipset systems have verified, that it was never a good idea to put the latest available Intel RAID modules into the BIOS of old Intel chipset mainboards.
So the Intel RAID user doesn’t have any real disadvantage by the restrictions, which have been documented by boombastik.

Thank you guys for taking look at this thread.

@boombastik @Fernando
So this makes sense, but this offer BIOS F9b is not true, as there was one and only one revision for this motherboard, and @digitalMedic did something what is not real, or he forced somehow bios to update. Wonder how and why. I was updating with onboard BIOS update tool, and got no change to ROM.
I am digging this subject as this is my working rendering RIG and do not want to have some unexpected freezes or blue screens. Some renderings take more than 24 h…

My final BIOS is still not set to final. So still experimenting.

Yes but I guess that z87 is a bit different and with many revisions comparing to one and only z97x gaming 7 from gigabyte.


The Z87 and Z97 chipsets came out in roughly the same time frame so I’m not surprised that the 15.x RAID ROM may well work on the Z97 chipset.

There is nothing inherently wrong with ''pushing the envelope" of performance…other than knowing you are taking a reasonable risk.

If you are being conservative and after stability for your “day job”, then Fernando’s advice is quite astute and reasonable.

It just depends on what you are trying to achieve…presumably you are not overclocking with liquid nitrogen; when you stated you “do not want to have some unexpected freezes or blue screens”.


Can you upload a vbioshsw.dat (ORM VBIOS hsw-bdw: 1044) file for gigabyte Z97X-UD3H, which can be directly put into the ubu folder, because I can’t find the place to download it, thank you.

I would like to get final working Bios for this mobo with maximizing of Intel SATA in raid mode and freaking Marvell SATA,
as well with full compatibility with all my hardware. That’s it. It takes time. I was as well hoping for all this community help with assembling all codes.

please update with new microcode

Updated and tested the ROM
A special thanks to @Lost_N_BIOS , @SoniX , @Fernando , and @chinobino for their guidance and help in this project!

z97XGAMING7F9b001.zip.zip (5 MB)

z97XGAMING7F9b002.zip.zip (4.45 MB)




Can you please enable SPD Write on the SM Bus?

@Overshot1989 - What BIOS do you want that done on? If some BIOS in this thread, tell me the post #, if some official BIOS, or beta, give me the link to the download page (not the BIOS)