[OFFER] Gigabyte GA-Z77-DS3H NVMe Mod

Based on latest beta BIOS ver F11a

Unlocked some additional options in BIOS menu
Added PCIe SSD (Both AHCI/NVMe) boot support
Added UEFI boot from NTFS partiton support

EFI GOP Driver IvyBridge → 3.0.1030
EFI GOP Driver SandyBridge → 2.0.1024
OROM Realtek Boot Agent GE → 2.65 // It seems unnecessary since this mobo uses Qualcomm LAN instead of Realtek one.
EFI Realtek UNDI → 2.040
OROM QCM-Atheros PXE →
Ivy Bridge Microcode CPUID 0306A9 → 1C
SandyBridge Microcode CPUID 0206A7 → 29
ME FW → with Intel Anti-Theft Technology Disabled

Flash via Intel Flash Programming Tool or Gigabyte QFlash

EDIT by Fernando: Title slightly customized (now matching the other offers)

mod_z77-ds3h.rar (3.52 MB)

Tried on my z77-Ds3h and so far working OK, with corresponding IRST 13.1.0 driver (latest supported). I am not big fan of these mods but this one seems to me reasonably "conservative" and at the level of manufacturers updates available (e.g. IRST - 14.x or 15.x is not supported by intel on z77). Not sure if I keep it or return to standard F11a, however.

@jumpingjackflash5 :
Welcome at Win-RAID Forum!
Dieter (alias Fernando)

UPDATE: Disabled Intel Anti-Theft Technology by following this guide
The attached BIOS is updated.
You should use command fpt -greset after flash to apply changes immediately.

UPDATE: Reset NVRAM volume

Just for information after some time, I have kept the modified version on my system. I have kept the original mod as posted earlier, not the subsequent updates version.

The previous version was an SPI dump from my PC, it has leftovers inside the ME Region and NVRAM volume.
I managed to clean the ME Region and manually replace the NVRAM volume with stock one.
For some reason the BIOS with stock Flash Descriptor cannot be rebuilt by FITC, I have fixed the problem following this reply from plutomaniac. Afterwards Gigabyte atBIOS utility has trouble flashing my rebuilt BIOS (stucks at Erasing/Writing 0%), while Intel FPT works fine.

Still the original version is stable on my system.

Hi Ferrous,
I flashed your modded BIOS on my Z77-DS3H rev 1.0 but I can’t find my Samsung 960 Evo among the drives that could boot. The ssd is mounted using an Asus HYPER M.2 X4 MINI Card M.2 adapter. Can you help me?

Have you set OS Type to Windows 8 WHQL?

I have flashed the latest bios posted. Working great. Thanks again for this mod it has prolonged the lifetime of my z77-ds3h board


Hi Great work,Whats the link for the latest update ?
p.s the rar archive seems damaged

Ops Sorry the archive is fine !

working fine, thanks ferrous, jumpingjackflash5 for infos

can I use this on mY Ga-H77-DS3H, or would you have another one suit may mobo ?

Best Regard

Hello again!

I would like to thank to ferrous again for this bios, since the NVMe boot from PCIe SSD really works. I tried it yesterday and Kingston KC1000 works well. I placed it in PCIe x16 slot (instead of graphics card which i moved to PCIe x4 since I do not play very demanding games) and the speed is great. But it worked (a little slower but still much faster that SATA SSD) even in PCIe x4.

Of course, it would be nice to have new e.g. Ryzen motherboard, but this helps me save my investment to I5-3570+16 GB DDR3 RAM I made before.

this is a great bios ! but i believe we will never have anything new, i pm ferrous but he doesnt answer.

I managed to change my i5 3550 with an i7 3770, after the change the pc resetted 3 times without bios coming up , and then it started ok, but said that the bios settings had been resetted,asked to load default values, so i just confirmed and all went well, really strange…but works ok…

and btw jumpingjackflash5 seems that with the nvme adapter you loose a lot of speed, can you confirm it ?