[OFFER] MAXIMUS VI IMPACT v1603 compl. mod

BIOS mods as requested by "rukhie"

EFI GOP Driver Haswell 5.0.1036 ----> 5.5.1034
EFI Intel Gigabit UNDI 5.4.19 ----> 0.0.29
EFI Realtek UNDI 2.020 ----> 2.054
CPU 306C3 microcode 19 ----> 28 (latest Spectre/Meltdown/MDS microcode) Thx Sonix! Latest edit: Oct 10, 2020

OROMS updated as well.

EFI_ROM updates


microcode updates


NVMe functionality via ------> NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe_4.ffs dated 04/18/2018 inserted after CSMCORE for this Aptio IV UEFI/BIOS

Enjoy your NVMe capable drive!

EDIT by Fernando: Thread title shortened and specified as OFFER

M6I.rar (4.75 MB)

Thanks hancor for modifying and providing the bios.

I was having a slight issue flashing over usb flashback, so I flashed it via the Asus AI Suite method outlined under Fernando’ s guide and the forum members ‘Wishbringer’.

It appears to have been successful and everything is working, checked the OROM version by temporarily changing SATA AHCI to Raid, sure enough it has been updated from to Brilliant! Everthing is working and can boot up. The system feels faster.

Everything is working as before, however there is one issue.

My overclocking options are all greyed out.

I can change the values within the boxes but they do not appear to save when pressing f10 and rebooting. The only overclock i run on this machine is the Ram which i normally run at 2048MHZ @9 9 9 28 1t timings. Entered Ram timings are not being saved at all,; bios shows standard timings.

It is strange because Windows is reporting the ram running at 1336 mhz. Bios is reporting ram @2048mhz, however albeit under ’ grey boxes’; my preference to apply a voltage increase of 1.510 volts is not showing in bios as the usual 1.510volts… bios reports 1.35 volts.

On the previous standard bios, the boxes were white in colour and any entered and saved options were visible. I have cleared the cmos and set up bios again but still the same issue.

Having said that, I have probably forgot to press a combination of keys which might activate the options… i just can not remember the combination or if there was even a combination.
Should i try and flash again via usb flashback?

Any help appreciated.

Try enabling the XMP memory timings, I had to do the same with the GSKill 2400MHz memory sticks; worked no problem.

See your manual: MEMOk! button on page 1-19 for successful memory stick tuning.

Seel also manual: FAST BOOT jumper page 1 - 21

Correct USB 2.0 port for flashback procedure is found on page 2-19 of your manual.
Use a USB 2.0 stick only, with FAT32 file system and ONLY the M6I.CAP file on it.
(You may have to hunt around for a proper USB 2.0 stick, or find one at Walmart like I did.)

From the manual:

Computer should be powered down and in standby mode.

5. Press the “ROG Connect” button and release when flashing light appears, which indicates BIOS flashback function is working.

6. Wait until the light goes out, indicating the BIOS updating procedure is complete.

The light tends to speed up blinking near the end of the bios flashback procedure. Make sure it doesn’t blink at all before you reboot!

Cheers and much success

I have already selected the XMP memory timings profile; still no change. It just wont save the settings after a reboot. All the options should be white in colour but are grey in colour. This colour change does not affect me trying to change their values but it wont save. I will try and reflash the bios using flashback method as you suggested and report back. Thanks.

Just one question hancor. I uninstalled Asus AI Utilities. Do i need the AI Utilities software installed in windows for USB flashback to work, or is it something hardwired into the motherboard?

I NEVER perform BIOS updates in windows, so the AI Utilities software is not needed in this case.
Too many ‘clusterfracks’ from much hard learned experience!

USB flashback procedure is as you guessed hardwired into the motherboard.
Follow the exact procedure as on page 2-19. Use the USB 2.0 stack, with the BIOS flashback port being the one closest to the motherboard. Print out the instructions if you need to…

Your computer should be powered down and in standby mode. ie the power switch on your power supply is ON, but computer is NOT booted up.

Also don’t disconnect your power while flashing as this will lead to a ‘clusterfrack’.
Follow the instructions precisely and take your time.

Ok , that makes absolute sense; i just got lazy i guess… Going to try that to the letter . Thanks

hancor, thanks for providing those instructions.

Okay, i tried the usb flashback method,formatted a cheap usb 1GB stick/fat32 and like you said,the flashing light appeared and started to speed up towards the end, it does work!

However, the same problem is there. I can not enter the required ram voltage/timings and make them stick. Everything does work though, no boot problems whatsoever.

Had an idea! I just flashed the original bios back via usb flashback method to check. With that bios, i CAN enter the required settings and they do stick.

Hmm, could it be one of the modules that were updated into the bios causing such a conflict. Or some sort of protection mechanism by Asus?

I am still grateful for what you have provided here

I’m guessing perhaps I should try the smaller version of NvmExpressDxe_4.ffs which is 6Kb instead of 21Kb.
I don’t have time today, as I’m running through pics of my mother-in-law for a funeral photo montage; but give me a day or two and I’ll try the ‘lighter’ version of the NvmExpressDxe…

Cheers for now

Thank you so much. Please accept my condolences. I hope you manage to get the montage done to perfection, please take your time. I can wait.

You may be correct in your reasoning with regards to the smaller version of NVMExpressDxe_4.

A few days before you kindly provided the updated bios, i took the risk and did successfully flash the maximus VI Gene bios you provided for the winraid forum member ‘Zitat von onemoar’. Curiosity and impatience got the better of me…

Prior to flashing, I examined that bios under ubu tool, it appeared to have much the same code and has the same Asus version number 1603/ same size-- so i thought why not. That bios you compiled can be found here
[OFFER] MAXIMUS VI GENE BIOS 1603 modded for NVMe boot drive and EFI updates

That bios does indeed have two differences, specifically the NVMExpressDxe_3 instead of 4 and the other difference is the Cpu Microcode was updated to version 22 instead of 25. That bios worked on my motherboard, i could enter the settings and they were saved; the only issue was the bios support for the wifi module and bluetooth was missing so i flashed the original bios back.

There are some forum posts I have read elsewhere that Haswell chips are crippled by CPU Microcode updates-- I do not think that should affect the motherboards functionality tho.

It may just be the NVMeExpressDXe module…

Ok, blasted through the photos, which my wife had shortlisted last night (otherwise it would have been wading through about 10000 family photos) and got them off to my brother in law via Google drive.
The shortlisting saved a huge amount of time…

I’ve now used the NvmExpressDxe_Small.ffs dated 04/01/2018 as per the link:

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

All the other modules stay the same. If you want an NMVe SSD drive, make sure to find the setting CSM (Compatibility Support Mode) and set to DISABLE. NVMe drives only work with GPT (GUID Partition Table) and not the old MBR (Master Boot Record) Also if you want to do this, you’ll have to convert all your other drives from MBR to GPT drives otherwise the OS won’t see them.

See M6I_NVMe_small zip file in the start post

Wishing you much success…


I do not envy that task hancor! Glad you managed to get it done.
Thank you for giving up your time to provide another solution. Flashing now.

hancor, just flashed it. Thanks, a successful flash.

Unfortunately, the same issue persists.

Thanks so much for trying to help me out. I do not know what is causing this issue, it is strange.

It may just be time to retire this board as although i need to enable NVME , i can not take the hit of returning to 1333 ram on this cpu.

Really love this forum, have learned quite a bit over the years.

will try to mess around with NVMe version 3 and see if that works for you…stay tuned

appreciate your committment to the cause, never say die!

Could the problem be the Microcode update to v25?

unlikely, as the tip off may be the crossflash to the Maximus Gene platform you cited above…anyway going out for a walk for the moment; so I’ll play around with my older version of UBU 1.69.11-fixed…we’ll see how that goes.

sounds feasible and promising!

Just out of interest, what type of CPU are you running?
Mine is an i7-4770K which is unlocked and able to overclock without issue.
It is possible that the overclock features are lost with microcode updates if your CPU is an i7-47XX (non-K) variant.
Intel has been known to scupper overclocking features.

I’ve redone the bios versions attached below: one with CPU microcode v19 (best for overclocking) and one with CPU microcode v23, as per the Maxiumus Gene you crossflashed before, the last one before Spectre/Meltdown updates. Flash and compare if you get the same behaviour as before. Please post back and report.

All the other EFI/ROM modules remain as updated in the first post.

M6I_microcode_v19.zip (5.27 MB)

M6I_microcode_v23.zip (5.18 MB)

The light turns on!

My CPU is indeed a haswell socket 1150 non-k version i5 4570s. Your logic is sound hancor!. Thanks again for exploring this issue further with me!

I’m going to flash both bios’ you have provided and will report back in a jiff.

hancor the legend!

Tried both bioses.

Cpu Microcode v19 did the same thing, does not save settings in bios for ram overclocks.

CPU Microcode v23 as per the Maximus Gene did it! Checked the OROM by temporarily switching to RAID mode, and sure enough, the platform has been updated from to v

I can now save my previous ram settings of 2048 @ 9 9 9 28 1t. Voltages are also being saved!

Would be good do know why this version 23 worked with this particular cpu and the v19 did not. Having said that, like you said, the v19 is better for overclocking and my cpu is not a K version. Maybe that has something to do with it.

I suspect that all the bios versions that you provided do indeed work if the cpu is an unlocked K version. I now have a library of bioses for this board for individual situations.

I can not thank you enough sir. Would like to donate for your kindness?

PS… Time to look for a K Chip me finks…… will also remember your advice when I get around to setting up NVME and GPT requirements…