[OFFER] MSi Z68A-GD65 (G3) Bios Mod (fully updated)

Update: Found Beta Bios 25.93B, for those who want to try, i provide the very same mods as the 25.8 ones on this beta bios:
BetaBiosMod.rar (5.1 MB)

Flash with intel fpt to update all region, this is a clean bios not initialized/dumped ones.

This should be the latest update i ever done. Both for 25.8 and 25.9B3 included in the file.

  • OROM VBios SNB-IVB: v2171
  • TRIM mod Intel RaidDriver v12.9.0.2006 + >“Universally TRIM modified” Intel RST(e) RAID ROM v12.9.0.2006 with TRIM in RAID0 support

Z68AGD65G3 LatestMOD P80+P93.rar (7.0 MB)


I also have the same mb as yours, and it still works more than well.
Today I was trying to install a nmve using the free pcie slot on the mobo, but the result was not good at all.


Searching I came here to your post. Could you give me some assistance?
After the modding is it possible to boot from a nvme mounted in the pcie?


Welcome to the Win-Raid Forum!
If you want help from a specific supporter, you should use the @username feature.
Good luck!

1 Like


Thank you for the information, im new and a bit confused from all these new info that i read about firmware. :slight_smile:

After having flashed the modded BIOS you should be able to boot off an NVMe SSD.
Within the start post of >this< thread you can find a guide about how to do it (look into “Step 4”).

1 Like


thank you for this information, im looking at it.

Is it sure to mod a bios? or you can have some issues later?

Also im discovering a new world here. :slight_smile:

Maybe is it possible resolve some issues? I have the white sata ports 1-2 that dont find nothing if I put a ssd drive there. They are white colorful, so i meant thats the raid one.

I appreciate your help

thank you

So you’re not here cause of NVMe mod itself, all you have is disk detection issues with your 2.5" SSD on the SATA Ports, correct?

The “white” SATA ports supports standard 6Gbps AHCI or RAID mode by the Z68 chipset, for single disk boot set it to AHCI in bios.
Check SATA cables or the ports for pin isolation, these are old boards and moisture/dust can be an issue, if the disk itself is OK and tested in another system.
The Marvel ports only supports disk drives, not ODD and can also provide ACHI or RAID.

1 Like


hello , thank you for your reply,

to tell the truth i’m here mainly because of the NVMe issue, the pc although old now, is still my main pc, since i have so many disks and strangely the two ports 1-2 don’t work for me, i’ve been looking for a pcie adapter to put a m2 disk in it. Obviously nothing works

I will try with an air compressor to blow the dust off the sata ports, to see if by some miracle they work again.

Now I would also like to do the bios change, to use the new m2 drive, but at first glance it seems like a non-trivial operation, which needs a bit of study.

All help is welcome. :slight_smile:

thank you

To flash the bios only just flash it as usual using M-Flash, just don’t use Bios+ME option.

It is recommended to downgrade to bios P1 (the very first release that supports ivy bridge), update it to 25.6 (use bios option only), and update again using the same 25.6 bios you just use for updating, but this time using Bios+ME option, to make sure that backup bios is updated, so that in case anything bios related fails, the backup bios is ivy bridge ready.

1 Like


My bios is currently this

if I understood the procedure correctly using the bios tool



It is recommended to downgrade to bios P1 (the very first release that supports ivy bridge), update it to 25.6 (use bios option only), and update again using the same 25.6 bios you just use for updating, but this time using Bios+ME option,

I do not understand which one to use precisely

    • 25.6 2012-08-16
    • P.1 2012-04-16

is the difference from my current one so great that I have to downgrade? or just a risk of failure of the upgrade?

(use bios option only) … but this time using Bios+ME option,

is this for writing to both bios? having an emergency one

once I am sure I have two working bios, which one should I try to load out of all the ones you posted?

  1. E7681IMSMOD.rar (5.3 MB)

  2. BetaBiosMod.rar (5.1 MB)

  3. Z68AGD65G3 LatestMOD P80+P93.rar (7.0 MB)

thank you for help

the downgrade to P.1 is necessary to make the dual bios actual getting updated, it needs a trigger and based on my past test, it is indeed the trigger, but if you find any alternative to trigger both dual bios update, please let us know.

As per why? Because even if you know your main bios is the latest, you never know if your 2nd bios is actually still shipped with old non ivybridge bios, or it is already hve, because i bought the board and it does have the latest bios, BUT the 2nd bios is the old ones, so i need to buy a cheap pentium sandy bridge to boot onto it using the backup bios.

If you do actually understand the logic of my steps, it’ll be great, the point is, the way i did it like that is to make sure that 2nd bios is actually flashed with the modded bios without the need of external programmer. If both bios chips are flashed using the update method that triggers it, you could purposely fail the flash of main bios, and then when the board start, the LED near the bios chip should be blinking, which indicates that 2nd bios is on use.

When 2nd bios is on use, immidiately go into bios, disable Multi Bios Auto Update option so that whenever your 1st bios fails the 2nd bios will be in use instead of reflashing the 1st bios using the 2nd bios data.

Want both of your bios using the mod? repeat the same steps, but this time stop at step 5. while 2nd bios is in use (make sure LED near bios chip is blinking) and you could enter the bios, still disable multi bios auto update, then you update the bios with the mod, and after it finishes, boot to windows if you need to update the ME Firmware, if you dont, you just need to either adjust your personal non OC settings or adjust everything including oc, save and exit and go to bios again, enable Multi Bios Auto Update, and your 2nd bios will copy all of its content to 1st bios, there you go both of your bios udpated and modded and else.

The third is the latest one.

1 Like


If you do actually understand the logic of my steps, it’ll be great,

I understood what you did, it is a very smart solution to overcome the limitations of the system itself.
but isn’t there another way to actually select which bios to use?
I would prefer to have a modded bios, and a vanilla one so that I can always revert to the original if needed.

Here on the site I found a lot of things to read, even technical things, to understand. Reading your post you said you also updated other parts of the bios.

I understood that the nmve driver is added , but besides that what do you update? if indeed you need to update anything.

s NVMExpressDxe5 and Samsung_M2_DXE for samsung ahci, Updated Uefi GOP for Ivy Bridge and Sandy Bridge iGPU, Updated Realtek OROM and UNDI DXE, and mCode for Ivy Bridge to mCode 19 (best for OC)

all these elements, which I honestly don’t know what exactly it is about.

thank you.

Well it’s (cmiiw)
UEFI GOP = the Graphics Output Protocol driver for the igpu
Realtek OROM and DXE = the ROM driver and DXE driver or realtek to be able to operate on uefi or legacy/csm
mCode = microcode, i put the best microcode for overclocking.

if you need the latest microcode i might be able to replace it, also the realtek orom and dxe is abit outdated, but it was on purpose because when i try to save any settings it just wont save, return to an old one and it worked like a charm, but if you want to experiment, i could replace the modules to the latest version 2.70 OROM and 2.066 UEFI, as per now i didn’t have the board as it is broken internally, due to age i guess, but yeah that were my discoveries back then.

1 Like


hello, thank you for your answers.

So my mb has always had a curious problem, it does not accept in any way to boot from hdd/ssd if it is set in ahci mode. It only works in ide. I had read at the time that it was a bug. Never fixed perhaps. Or is it my sample that doesn’t work.
Day before yesterday, I got the nvme adapter and plugged it into the pcie, and windows10 was unable to see the drive, I had a driver that I tried hard to update to see if it worked, but to no avail. I removed the adapter.
I was reading here on the forum that at the very least, it should see it as a non boot disk.

I saw that on the msi site, you requested the latest firmware available for the platform. I was thinking if I used that firmware version, modded with the nvme drivers, will I be able to boot the drive? starting with the drivers of the version I currently have installed, without downgrading.
I would like the safest possible procedure because I don’t want to break the motherboard.

I’m seeing a lot of videos talking about it, I’ve also seen videos where they use an alternative bootloader , clover.

What are your thoughts on that?


I vaguely remember that it was an issue to me too, but i used the latest bios (which i mod after) and latest beta bios, i could let it work on ahci mode… Seagate barracuda 1TB (old model from 2013 i use till today, formatted into GPT and did a clean install with my 850 Pro (both drives are gpt) ), and team mp34 i tested just before the board broke down.

You could maybe try to use either of both bios mod to see if it’s working or not.

But i want to ask you this, is your gpu UEFI compatible? I remember having a hard time to figure out which is which, but i am able to use full uefi and ahci mode on the board as far as i remember, or maybe auto? I kind of forget about it… Sorry :pray:

1 Like


my gpu is a 1060 extreme , i was wondering but after how long did your mb break down? wasn’t the beta bios to fault?

I would still like to use this PC as a mule :slight_smile: when I decide to buy another one. I am attached to it. At the moment it is also giving me problems with a new ssd from crucial, since I installed it it gives me continuous bsods.

As soon as I try to enable ahci, it won’t boot.

(both drives are gpt)

part of the problem is that if I format in that way, the system does not see the drives. Not even USB sticks.

My plan would be to use the latest beta bios, or perhaps the 25.8 I currently have, with nvme drivers and see if it finally recognises my m.2 drive

It was on 2022, probably 3-4 month after i post this, and no the beta bios is perfectly fine, in fact i ran the beta bios XD.

I suddenly remember that it happened due to the Marvell sata ports is in fact the problem (wont do AHCI). You could disable the Marvell sata port (i forgot which option is that, maybe Settings → Advanced → Integrated Peripherals → External SATA). the thing is, that marvell sata port causes it. When i disable those, i am able to launch AHCI and Full UEFI.

1 Like


your memory works fine, in fact the marvell ports give problems so much so that I have not connected any drives to it. Going through the logs with bluescreenview I found that it always points to the marvell drivers, I tried to find drivers every which way, but nothing, the problem remains.

If it is possible to disable it I will do so, to see if that solves part of the problem.

Maybe before modding the bios, I could try following a tutorial to try to boot the drive using clover.

Did the m.2 drive work for you before modifying the bios? Could you see it in Windows Explorer? Could you use it as a storage drive?

Yes it could, as both a boot drive and a storage drive, but it was pre formatted as gpt since i gpt everything for big storage. Tested the drive on my personal pc (it was B560M Pro) and it is normal, tested it on the Z68 and it could be seen, no special drivers installed, just PnP, but i forgot if it was put on the x16 slot or the slot underneath it. The thing is, i disable marvell, i enable ahci and i vaguely remember there is no csm/uefi option in the bios, so i install secure boot keys and enable secure boot to make sure it is pure uefi.

tl;dr: Yes it work, bios set to AHCI, Marvell disabled, Secure boot installed and enabled, drive at GPT.

1 Like