[OFFER] Var. ASUS Sabertooth X79 BIOSes (NVMe/Bifurc./uCode/OpROM)

After all this time going strong, I decided to re-write original post to provide easier download links for everyone that searches for moded BIOS for X79 Sabertooth.

There are multiple versions, so here’s list of them along with changes they have :slight_smile:
I attached them in .zip to this post, so there is no need for going to other sites to download them.

Official 4701 and 4801 versions with only NVMe support added [module “NvmExpressDxe_4.ffs” (22kB)] :
Files :
SABERX79 (4701 NVMe support only)
SABERX79 (4801 NVMe support only)

Module versions (the same as official release but with NVMe added) :

Module Versions.png

uCode versions (the same as official release) :

uCode Versions.png

^As you can see only NVMe was added, anyone can verify this by downloading UBU Tool (modules) with MCE added (uCode version).

last Pic.png


Bifuraction support : Shows hidden settings, and enables different PCI-e port lanes distribution (needed for multi M.2 NVMe drive add-in cards, like ASUS HYPER M.2 X16 card).

4701 (based on official latest released) :

All updates without bifurcation support :
File to download : "SABERX79 (4701 no bifurcation)"

All updates with bifurcation support
File to download : "SABERX79 (4701 bifurcation)"

All updates list :

All Updates List Pic1.png


4801 (based on official latest beta) :

All updates without bifuraction support :
File to download "SABERX79 (4801 no bifurcation)"

All updates with bifurcation support (this one has latest LAN OpROM as well) :
File to download "SABERX79 (4801 bifurcation)"

All updates list

All Updates List Pic2.png

Bifurcation example :

Bifurcation Example.jpg

Keep in mind, for easiest update you have to use BIOS Flashback option and have pendrive that is compatible with this function (formatted in FAT32). Not all pendrives work, so if update doesn’t even start (update starts when blue LED will start blinking once per second, gradually speeds up and at one point simply stops). Blinking for only 10 seconds doesn’t count as succesfull update, so if you encounter it try switching pendrives.

Those BIOS’es were made by both Me and @Lost_N_BIOS on this forum.
They were tested by Me and few other users, but they are NOT fool-proof.
We (moders), are NOT taking ANY responsibility, if You brick your board during update process.
We will try to help You if there are problems but, You are ultimately responsible for Your hardware. If You think this isn’t something you need, or you have doubts about process itself DO NOT attempt to do this.
Better ask a friend that’s better at this stuff, if you are afraid you can damage something.

Thank you and I hope we are can appreciate this motherboard for few more years to come.

Edit by Fernando: Inserted pictures resized and directly attached, thread title shortened

SABERX79 (4701 bifurcation).zip (4.92 MB)

SABERX79 (4801 no bifurcation).zip (4.92 MB)

SABERX79 (4801 bifurcation).zip (4.94 MB)

SABERX79 (4701 NVMe support only).zip (4.79 MB)

SABERX79 (4801 NVMe support only).zip (4.79 MB)

SABERX79 (4701 no bifurcation).zip (4.92 MB)

@agentx007 :
Thanks for your report and congratulations for your success!
Why don’t you offer your modded BIOS within >this< Sub-Forum?
If you want, I can move your thread there.

No problem :slight_smile:
Please move it there.


Results :
Core i7 3820 :

Core i7 4960X :

New UEFI contains :
1) Updated microcodes for LGA 2011 Xeons (E16xx v1/v2 + E26xx v1/v2) and Core i7 3xx0/4xx0 series (based on August 2018 Intel pdf : LINK).
2) NVMe boot module (the same as my original moded BIOS),
3) Updated firmware for Marvell SATAIII controller (from original v1.0.0.1031, to v1.1.0.1002).

I have problems booting the drive. It is recognized as pata ss, also in Win10 x64 install is fail because of warning that the drive cannot be made bootable, since is not enabled in bios.

0) Are you sure you updated the BIOS (only BIOS Flashback works, but remember - it will start with slow blinking, and will keep getting faster until it’s done). If it starts, but never does faster part - you failed at updating. Also, did you used FAT32 USB storage for updated file ?
1) Is NVMe it formatted as GPT ?
2) Are you installing Windows in UEFI mode (CSM must be set to UEFI first on USB/Boot devices)
3) Did you cloned AHCI/SATA drive ?

Flashing part wasn’t the issue, it was that the drive hasn’t been formated as gpt.
I’ll give one more go.
Thanks for the advice, I was quite helpless, because found no “how-to” guide until now.

It works cloning from mbr ahci/sata drive? It would save me a system reinstall.
I did as you said in 1) and 2) and the result is:

Screenshot 2018-10-05 at 21.17.48.png

@gdfath3r Cloning won’t work… I think you either have :
1) Legacy booting Windows installer (or it’s made for Legacy, instead of EFI/GPT - try writing ISO for Win10 on USB stick with program called “Rufus”),
2) BIOS simply wasn’t updated like it should.
Try disabling CSM (may require quite a reflex to go back to BIOS after this), it does require GPU with UEFI booting support.
Also, what NVMe drive is this ?

It is a Sam 970 evo 500gb on Aqua Computer kryoM.2 evo PCIe 3.0 x 4 adapter.
I will try with other win10 x64 install image, maybe thats the problem.

Yes, it was the Install Disk fault. I downloaded a new x64 image , extracted to usb with Rufus, and can confirm that works.
Thank you, agentX007

Glad it worked out.
No problem :slight_smile:

Huge thanks for the upload, speeds are absurd and it’s clearly working as intended.

I am having an issue I haven’t seen before and I’m hoping maybe you have, or have an idea which direction to look.

Fresh install, same hardware I was using before minus the drive, everything works perfectly for 2-24 hours and then it starts to freeze for a second every 5-10 seconds - doesn’t matter whether I’m playing a game or browsing the web, it eventually becomes unusable. The keyboard, mouse, and video lock up, audio continues. This persists until I restart the system, then it works perfectly for another couple of hours. Nothing inside the case is warm and there aren’t any unusual logs. I’m using the Samsung 970 EVO drive and the below PCIE to M.2 adapter, any ideas? Again, I really appreciate you posting the BIOS.


@iJoshh - What operating system are you using, and what drivers? That kind of info may help someone like @Fernando offer some advice on this issue.
You also may be better off with the now more commonly used NvmExpressDxe_4.ffs file instead of v3

Also, just my personal opinion, I hate BIOS 4801 variant on any Asus X79 board, it always caused instabilities for me (Unrelated to your mentioned issues, but that could be causing some of what you’re experiencing too)
If you want, I can update 4701 for you with latest microcodes and NvmExpressDxe_4.ffs for you to try out? And you also may need to use a better driver for best performance, but I can’t comment on that as to which is better.

After unsuccessful trials of booting with clover with usb and booting with my new nvme disk, I found this thread and it worked out smoothly.
Anyone having Asus sabertooth X79 mainboard can use it without doubt.
Thanks a lot.

I picked up a Samsung 970 Pro with a m.2 to pci-e 4x card. Flashed the modded bios, used the Samsung Transfer tool to transfer my data and was able to boot off the nvme SSD with no problem.

I’m able to get full read and write speeds as if it was connected directly to a m.2 port on the motherboard.

Thanks for letting me breath some new life into this PC!

I have issues with 4801 as well… As already stated on another forum, the power consumption of my X79 is lower after a cold boot and I’m having all sorts of micro-stutters (GPU + LAN). It all went away after I reverted back to 4701 ;). So if you could update 4701 with the latest microcodes and MVMe, I’d give it a try… THX

cheers, chi

Agreed @chi - all X79 boards with 4801 BIOS (or whatever # adds the new 128MB memory thing), it’s a bad BIOS update series I’ve found, I tested several different X79 models with 4801, all I didn’t like how the board ran and went back to next BIOS down.
Which exact board model do you want update microcodes and NVME into 4701 on? Please link, thanks! I would assume Sabertooth, but you know how assumptions go…