[OFFER] Var. ASUS Sabertooth X79 BIOSes (NVMe/Bifurc./uCode/OpROM)

Yes, I have an ASUS Sabertooth X79. Thanks in advance

@chi - Original BIOS has 4 microcode volumes with 2x in first two and 5x in second two (14 total), update I made all same (5x in each = 20)
Flash via USB Flashback and do not rename the file, in case you didn’t already know this for mod BIOS.

MicrocodeUpdate.png


http://s000.tinyupload.com/index.php?fil…404995955823983

@Lost_N_BIOS I just flashed my board with your updated BIOS, but unfortunately it didn’t work… After a flash (when I press the power button) it usually starts and immediately (2-3 sec) shuts down again, followed by a restart where I can go into the BIOS menu. But with your BIOS mod it just hangs after the power button was pressed… Any ideas why?

@chi - sorry about that, there could be a few reasons causing that, lets try this method instead. If this fails in a similar way, then I know we need to leave those old 2x entries alone with their two old microcodes.
I thought it was odd to have 4 microcode modules in there with two only containing two old codes and then other two updated, but first lets see if this works, then if not I will leave those in there.
http://s000.tinyupload.com/index.php?fil…370668273710231

@Lost_N_BIOS Apparently this update works as expected… This time it didn’t hang after the flash and I was able to go into the BIOS menu after the self-initiated restart.

Thank you very much for your efforts! Much appreciated



Does this contain the NvmExpressDxe_4.ffs driver?

Thanks

@chi - great that one worked, happy to not stress you out again

@mafiaboy01 - yes, that contains updated all CPU microcodes to latest version and NVME 4 mod



Awesome! Running great here with my 970 Pro getting full speeds.

@iJoshh This might be unstable configuration… is SMART reading of ALL disks connected to your PC "OK" ?

Works here, ok.

Dont work for me, on my Sabertooth X79 AFUDOS und AFUWIN Displays Error "secure flash function is not supported on this file"

Flashback Method also don´t work.

At the moment i have installed the original 4801 Beta Bios, do i have to downgrade it before update to modded 4801 ?

Flashback only. Flashback works, only you might not done correctly.

IMG_20181230_152949.jpg

I recommend reading first page of this thread, just to be up to date " how-to"

Hi,

now it worked with Asus USB Flashback Method.

I tried another older USB 2.0 Pendrive then it worked. On my Sandisk Pendrive with only 4GB and FAT32 it doesn´t work.

Update : I updated/uploaded BIOS from my orignal post to include NvmExpressDxe_4.ffs instead of NvmExpressDxe_3.ffs.
It does also have ucode updates, and Marvell OpROM update.



Hi, my PCIe Nvme adapter is PCEM2-DC PCIE NVME+NGFF M.2 ADAPTER and Samsung 970 EVO Plus 500GB. I’m use your latest BIOS and still in AZ mode is “PATA SS:” and Windows can’t install on this drive, because isn’t bootable drive. What am I doing wrong. Any idea? :slight_smile:

edit:
SOLVED

I’m install windows on the SATA HDD and then clone disk via Acronis True image to SSD. All work :slight_smile:

Worked like a charm!! Thank you for sharing. Amazed the the M2 NVME performance. :slight_smile:

Hi, I added the modified BIOS to install the OS on a Samsung 970 but I only get 1200MB / s in the PCIe 3.0 x16_2 slot.
I have to modify some BIOS option?
System: i7 3979k with 32Gb of RAM.
Thank you!

No, BIOS only enables booting, it can’t cause problems with performance.

1200MB/s is what : Read, Write, Both ?
What adapter do you use ?
Do you have PCI-e 3.0 switched on (in BIOS) ?
Which driver version is installed ?
SSD alignment ?

Hi,

I just picked up a samsung 980 pro 512gb nmve ssd with a m.2 to pcie adapter, i applied this modded bios (which was successful) but the UEFI drive doesnt appear in the boot option.
Does this bios need to be modded with something else in order for it to work with the 980 pro?

thanks.