[OFFER] Var. ASUS Sabertooth X79 BIOSes (NVMe/Bifurc./uCode/OpROM)

Never CSM enable, always OFF as PURE UEFI as NVMe OS install requires it, the PATA device in bios is irrelevant, with an USB UEFI OS installation, perform the setup and the destination NVMe drive will be available
Thats it, further guidance in Fernando guide, point 4: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

Hi MeatWar

thanks for your input - maybe I wasn’t clear enough, I definitely had CSM disabled, enabling it was just a last-ditch effort in my long process of troubleshooting.
I have since resolved the issue with the “empty” drive (see below) but am now facing a different one, hope someone is able to help.

After hours and hours of troubleshooting and trial and error, I managed to make the disk “visible” to the Windows installer.
If someone else is facing the same issue, this is how I did it (it’s a pretty straightforward one, I don’t know why I didn’t do that in the first place):
1. Found @Fernando 's thread regarding recommended NVMe AHCI/RAID drivers
2. Downloaded relevant (pure) drivers for my Samsung 970 Evo Plus, namely: >“pure” 64bit Samsung NVMe Driver v3.3.0.2003 WHQL for Win10 x64<
3. Copy the drivers to the Windows bootable USB
4. Load the drivers when disk selection windows pops up
5. Disk no longer shows 0 MB of 0 MB available, but the actual capacity
6. Open beer

From that point, I thought I was at the finish line, BUT: (there’s always a BUT)
- Now the Windows installation gets stuck at “Getting devices ready 98%” (after restart) and the wheel of dots stops spinning
- I tried unplugging all peripherals (except monitors, mouse and keyboard of course), taking out all memory modules (4×4GB Corsair Vengeance) and re-seating them in the same Asus-recommended DIMM slots (randomly, so the module that was at slot A1 is now probably at C1 or D1), but now the installation gets stuck at “Getting devices ready 97%” and the wheel of dots keeps spinning, so that’s done nothing

Does anyone have any ideas how to move forward? Is there perhaps another device that might be causing the installation to freeze?

My build:
- Asus Sabertooth X79 with Fernando’s modded 4801 BIOS (no bifurcation)
- Intel Core i7-3820 @stock frequency, cooled with Corsair H100 Hydro
- 16 GB RAM (4× 4GB) Corsair Vengeance 1600MHz (tried running it @1333 as well since I thought it was a memory issue now)
- ASUS Radeon RX580 OC Edition (8GB) with two Dell 24" monitors connected via DisplayPort
- Samsung NVMe 970 EvoPlus 1TB on an Orico riser card, installed in the first PCI-e slot (under the GPU ofcourse) - this is the drive I want to install Win10 on
- Samsung SSD 830 Pro 256 GB on SATA (disconnected during win10 installation) - this is the drive I have my Win7 installed on (running smoothly since 2012)
- WD Black 1 TB (disconnected during win10 installation) - just for storage purposes
- PSU Corsair AX650 Fully Modular (80Plus Gold rated)

This build has basically served me great since 2012, the only thing I changed this year was the GPU (bought it from a friend, used to have a 560Ti).

Also, since this is no longer in any shape or form a BIOS-related issue, I agree to have the post moved to a more relevant thread, at the moderator’s own discretion.

Well m8… u dont know how to resume ur problems or im too stupid for it…
I do hundreds of 10 OS install on NVMe disks with adaptors. Simple NVMe mod inserted, CSM OFF/UEFI/Secure boot off, USB UEFI multi OS plugged, setup, install, done.
There is NO NEED of NVMe disk drivers for installations (Only specif is the adapter has a built in controller, that windows setup doesn’t recognize), only in Windows IF the user wants it.
I NEVER make any cloning or upgrades, always a clean brand new OS installation, period, i cant afford encountering and loosing time.
My last Asus P9X79 was done in 10 minutes, WITH AN EMPTY NVMe, not a disk already partitioned MBR/GPT with old data or old OS (If so, del all partitions, initialize is optional)
This process is so simple and all i see is users creating NEW problems… i really cant believe this because in this mod presented by Fernando… the only hard, risky part is the flash.

Hi MeatWar

I realize where you’re coming from and I’ve done dozens of Windows installs myself - never needed any help.
That’s why I was so taken aback by the fact that this is causing me issues.

I’ve done everything by the book - I can even do a video of me trying to do it the right way. The BIOS flash didn’t cause any issues for me.
The fact of the matter is that I’m following all the guides, it should be working, but it just isn’t. Maybe I just attract bad things :smiley:
Maybe there’s a problem in the adapter, I don’t know, that’s why I’m seeking help.

Simply put (If I reply to what you wrote in red):
1. If I don’t load Samsung NVMe drivers during Windows setup, the disk shows empty (0 MB in size) and I can’t install
2. There was no cloning or upgrades, I wanted to do a clean install
3. The NVMe is completely empty every time I try anew (I even went into cmd to use diskpart to clean the drive before the installation)

Like I said, I’m not the one creating new problems - I have absolutely NO IDEA why this is happening.

Thanks again for taking your time to try to help.

Well im out… i can elaborate 50 more issues or retained misinformation by users on ur problem, but im getting too old for this and i cant burn more brain tissue with it, sry ull have to dig it urself.
All the best.

Morning! I have a x79 sabertooth I would like to use a NVMe for my OS. Do I just need to update my bios to your custom bios for it to work?

I have a M.2 NVME to PCIe 3.0 x4 Adapter w/ WD Black SN770

Also The official bios on asus site for my board is “4801 beta” is this the same bios on this site?

You need to mod the current bios, here’s all the guides you need:




hello all, not sure if many still visit this thread, just wanted to say thank you
for the information! and great work it seems. I have ‘new’ SABERTOOTH X79
which ASUS replaced under warranty a few years back. It sat in its case with
all the goodies for a while, essentially been using it for a couple of years now
to stream Formula one on weekends.

short story: i was lucky enough to get my hands on a few brand new goodies
to compliment the board and give my rig a fresh start. It runs very smooth w/ pcie3.0

INTEL i7 Ivy Bridge 4930k HEX core @ 4.2Ghz O.C. (brand new, box cpu :smiley: )
nVME SAMSUNG 970 EVO PLUS 2TB (3.5GB/s read, 3.3GB/s write)
{pcie 3.0 m.2 adapter (magician reports no incompatibility errors)
loads up in Win 10PRO 64Bit legit copy, i cloned a fresh WIN install
into it to give it a good test right off the bat, but of course i cant boot :smiley:
RAM= 1600Mhz 48GB (4 x 8GB + 4 x 4GB all matching (2 set), QUAD)
(pc is for audio / video production)
ASUS RTX KO 3060 Ti 8GBvRam O.C. (LE) brand new (pcie4)
120GB MUSHKIN Chronos ssd 2.5 SATA 6GB/s

i have windows in 4K 60Hz, but plan to game @ 1440p 120Hz

now, about the flash… i can confirm the process does work IF you have the right
USB stick. I used an older ADATA 32GB (yes!) FAT32 usb 2.0 flash drive.

I was able to reFLASH to the 4801 (no bifurcation to keep it simple)

the process i observed: blinks at a stead pace for some time, starts blinking a
little faster, then even faster after a while. the flash logo stops blinking
and the process appears to have been successful.

the PC POSTed w/out issue and it took me directly to WINDOWS.
BUT ON MY SSD 120GB sata, not the NVME. (both copies of win
are exact same)

i had to restart and load up the BIOS… No Change in its ability to
see the NVME. i have CSM enabled (boot into ssd) as before and
set to use the UEFI driver on storage devices, etc (settings)
1st as I have seen others on here, but then of course as I have
seen a couple experience… that is the last time i saw the bios.

computer tried to restart, froze and failed. start button disabled,
cannot boot ~!!~!:frowning: but of course, i tried not to freak out,
grabbed my fresh copy of 4801 official beta from ASUS
website and VOILA: reflash process works as it did before,
no issues at all. good.

rebooted PC and i’m back on my trusty 4801 beta. My drive is there, it is 100% OK
according to MAGICIAN. So, the FLASH process works, but on my BOARD at
least the MODed flash does not.

not sure if i should try the 4701 Version posted on here, i have a copy of it.

Will give it a couple of days to see if anybody is still around… I have not seen
comments from others running the Ivy bridge 4930K I7 so i figured i’d post.

i used to have a 3820 and will likely sell locally. So, while the board was free
none of the rest of the gear is, i’d rather not brick it, if you know what i mean. :smiley:

This is the culprits of cloning, a UEFI boot system needs a GPT disk and no CSM or Auto enable.
Off course, a x64 OS and compatible hardware…motherboard and gpu, and you have it.
A legacy boot system (MBR) cant boot in UEFI mode, a UEFI (GPT) system can boot both modes.
I do suggest a clean UEFI OS installation on the NVMe as primary boot drive, do this with no other drives attached during OS setup and reconnect all later.
This is no bios version related or UEFI driver priority, as no specific hw roms seems to be present in your system.
But this requires an NVMe bios mod to the 4801, very easy to do and 100% successful reports, with Asus Bios Flash Back.
If not your choice to mod, then the SSD SATA can be used as UEFI boot but all NVMe drives will be seen and used as storage devices, because no NVMe DXE driver was loaded from the motherboard.

[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

i tried the bios flashback, i cannot see the drive in bios.I did originally do a win
install off bootable usb with latest win10Pro. upon reboot even though process
had begun, BIOS wont see nor allow me to select as bootable device!! that
is how we all got here isnt it? I am not about to continue to repeat failed process’.
there were no other drives attached. bios continually tells me CSM settings wont
allow boot from device… but we all know the nvme module is not available to load.

the bios flashback did not enable boot access either. I should at least see the drive
available as a boot device… its not listed. regardless of CSM enabled or not.

i have read all other reports regarding the flash process. as posted I tried the 4801
modded bios available on this very thread… the PC booted once, and would not
even start afterward… That would be an obvious sign said bios is no good on my board.

pretty self explanatory. are there any reports of anybody with a i7 4930k hex cpu
running this bios mod? I thought i was very clear in my post above… I do see the
new cpu’s should be supported. It is on Intel’s list from 2018.

i have installed windows, several different versions for many years
(25 n’ change since the original win floppy) i’m an electronics technician.

Thank you. the initial process of being able to get win install to see the drive
was never the issue, it is of course not available as a boot device. My service
dept manager went through this process a little while back and in his particular
case installing on an SSD then cloning over did the trick, but of course different
mobo’s likely etc. I need to be clear, I am not a programmer but dont mind
trying a modded bios, but the PC at the very least needs to start, and I should
be able to see the drive listed as a UEFI boot device yes? at least that is what
was posted on this very thread. But i also need to try not to brick my brand new PC.

if there are no other hdds (of which i have 2xSSD & 2xHDDs, unplugged) and i
boot into bios there is NO DRIVE listed to boot from… regardless of WINDOWs
install method… there was a 100MB partition there at 1st, with the GPT loaded
on the 2nd, largest portion (1.8TB?)… The bios ignores it… will not boot from it, Obviously
we need to mod the bios. again, i was clear about understanding this.

does this make sense? i try not to leave out details on posts, but can miss little things.

Too much text… to me. Take it easy if you please, people tend to panic and not to use their brain.
CPU is no issue here, it is supported on the motherboard model since bios 4210.

The NVMe mod is NOT an official solution integrated in the motherboard by AMI itself, so some motherboards wont show any NVMe disk on the bios or some can show it if CSM is enable and a PATA_SS device will appear. But this is irrelevant for us as the NVMe drive will show as destination source during OS setup is the mod was successful flashed.

If the ASUS Bios Flash Back procedure is made correctly the bios MUST be configured to PURE UEFI mode, NO CSM, NO AUTO to perform a clean install of an UEFI OS, thats it.

You can always recover the motherboard bios with the same method and an original 4801 bios file.

Read the guide again because your issue is human error…the small details.
Over_n_Out, good luck.

can only post what info i have. its a little tough if you are just deciding
to not read what i have already tried. you do make it sound very simple
but obviously the results are wide and varied. Please dont automatically
assume somebody is freaking out and as you say ‘not using their brain’.

that, my friend. is unsulting… if you cannot remain level headed yourself
i’m not sure how helpful you will be… as posted, weather or not drive shows
up the pc should boot when pressing power button. The bios mod does
not work as expected, though on some it does, that seems to be very obvious.

the flash process doesnt seem to be an issue, but yes as posted on the
initial posts, I was expecting to at least see the drive available as a boot device
It would have seemed a normal operation would find switching between CSM
enable or not should not have a negative effect. weather there is a drive
to boot from or not, so of course it was concerning to see the PC would not
even start when pressing the ON button… There was no human error in this
process. Alas, i dont think your comments are very helpful.

Good to know, good luck.

EDIT: By the way…the mod is so easy that thousand of non-techs users have done it and installed their UEFI OS x64 in their SSD NVMe M.2 with cheap adaptors and even with no backup as Asus USB BFB as option to recover. Credits to the excellent guide by our dear Fernando.

thank you… i think it is just a result of the written word. Its easy to assume
somebody is ‘just scared’. This is the only reason i posted I am a technician.
Remaining level headed is a direct result of the job. I gathered a lot of info
on this when the boss went through the process but it does not seem to be
the same across all mobo’s etc. As mentioned, i do see the CPU is listed
among list of supported intel i7, I just needed to confirm as most are running
an older cpu. Same one i had before in fact. :smiley:

thank you for taking the time to respond. It seems most of the doubt was based
on not knowing which method would work, having read so many reports, and
encountered some familiar issues. Hard to say what is procedural, what is
actual failure of process.

the issues i encountered with other bios files were actually not related
to USB flash disk in use. Though the ADATA unit is better suited. I
am not able to flash v. 4701. I had already flashed up to Asus’ 4801
beta previously, dunno if it makes a difference.

BIOS 4801 (bifurcation disabled) modded from this thread WORKS!
drive set to UEFI (GPT), disabled CSM, set OS to WIN UEFI
PATA SS shows as list of bootable drives.

Followed WIN 10 (previously formatted GPT usb flash via rufus 3.19!) install as usual,
reload bios & confirmed partition, WIN 10 Pro available as UEFI primary OS. BOOT!

ran another benchmark, random read unchanged, random write increased somewhat.

Thank you again for the great work! much better than running the SSD as a system device.

привет друг,скинь мне пожалуйста мод биоса для ксеона и nvme диска в обновлении 4701hello friend, please upload the modified bios for x79 sabertooch for xeon and nvme on version 4701, thanks in advance

@N1ghtwatch It’s already uploaded ?
uCode + NVMe moded BIOS = “SABERX79 (4701 no bifurcation)”.
Sadly, it doesn’t have absolutly latest uCode for for all IvyN-E CPUs (only 4820k) at this point :confused:

Hey there,

I flashed the 4801 (NVMe only) bios about two months ago, while waiting for my PCIe adapter to arrive.
The computer worked as usual during that time.
Today I got the adapter and hooked it up with an ssd into the system (which was working up until then).
Ever since, I get no POST, fans are spinning and the CPU_LED in on (red).

These were my diagnostic steps so far, none have changed the behavior of the issue at all:

  1. removed the adapter
  2. cleared CMOS
  3. flashed the 4801 file with bifurication (successfully)
  4. re-seated RAM
  5. re-seated 24 and 8 pin connectors
  6. Power supply swap
  7. CPU swap

All help would be appreciated :slight_smile:

We dont know your adapter, we dont know your NVMe disk, we dont know where plugged in what PCIe slot. Could your motherboard not like them at all…?
And why to flash the BIF mod instead of the already present NVMe mod?
Is it a new multi disk adapter or single disk?
Does the motherboard has the same issues if the adapter is removed again from the motherboard?

EDIT: So if the issue remains with the adapter off, what does this have to do with mod files or NVMe?

To check the adpater itself and the Sabrent disk, put it on another machine
Flashback USB the original Asus 4801 on the motherboard, test stability and even without NVMe or BIF, the Sabrent in the adapter plugged in, also should work as non bootable, standard storage disk. Thats it, you have hw issues on the motherboard or not, regardless any mods.
Now, some hw tests, ram slots with 1 DIMM only, one by one, with GPU off using iGPU and re-check seated CPU and socket pins, finally buy a cheap CH341A, remove the SPI SOIC8, direct plug on the programmer and read it, save backup (No FFs), program back the Asus 4801 bios file without CAPSULE (UEFI extracted INTEL image).

Hey, thanks for your reply.

I’m using a generic PCIe 3.0x4 to M.2 adapter from ebay, it is single disk, and was connected to the bottom PCIe x16 slot on the MB.
My disk is a Sabrent Rocket 4 1TB.

I tried flashing the BIF mod in hope to check if the issue could have been related to running an x4 card in an x16 slot. I flashed back to the 4801 NVMe only since, to no avail.

The motherboard has the same issues ever since the first installment of the card, including when the card is removed.