[OFFER] Various mod GA-Z87X-UD3H BIOSes incl. NVMe+Microcode

Gigabyte GA-Z87X-UD3H updated BIOS version F10b:

EFI GOP Driver Haswell 5.0.1036 ----> 5.5.1034
EFI Intel Gigabit UNDI - 0.0.27
OROM Intel Boot Agent CL - 0.1.16
EFI Realtek UNDI 2.020 ----> 2.052


CPU microcode 19 ----> 28 (latest Spectre/Meltdown microcode updates)


NVMe functionality via ------> NvmExpressDxe_4.ffs inserted after CSMCORE for this Aptio IV UEFI/BIOS via
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Results in very stable and reliable NVMe boot drive and system for “ancient” Gigabyte GA-Z87X-UD3H mobo; BIOS version F10b mobo sporting an Aptio 4 BIOS/UEFI; which should now run like a top on the latest Windows 10.
Use BIOS Q-Flash method, see page 89-91 of your manual.
Remember to create, via Rufus, a DOS FAT32 bootable USB and flash the unzipped file (see Fernando’s instructions).

Cheers and enjoy

Edit Feb 17, 2020 updated network ROM/EFI and CPU microcode to version 28

EDIT by Fernando: Thread title shortened without deleting important information

Z87XUD3H.zip (5.98 MB)

Hi thanks for modding the BIOS.

Did you update the other OROMs or were they already updated?

That would be compared to the other modded BIOS I have is shown below -

Intel Legacy RAID ROM to
Intel UEFI SataDriver to
OROM VBIOS Haswell 1028
EFI Intel GOPdriver Broadwell 5.5.1023
Intel Boot Agent GE 1.5.04 to 1.5.56
Intel GigabitLan X64 5.1.00 to 6.3.27
Marvell 88SE91xx Adapter
EFI Marvell RAID for SATA
CPU Microcode 06C319 to 06C31C
ME firmware
Modified splash logo 2

Yes OROMS were updated to the latest available via the UBU tool as a matter of course, but the UEFI is the future so most folks will convert to GPT partitions to take advantage of the UEFI features.


I tried this (and even tried to downgrade bios, but to no avail) and lost all my sata disk booting using UEFI. I had clover on GPT partitions, and now I can’t boot even an UEFI usb media. I can only boot using clover’s extra bootloader on mbr.

Any ideas?

Using the clover boot loader doesn’t seem to make much sense, as this motherboard supports UEFI boot drives.
I know I upgraded my son’s computer using a NVMe Samsung 950 PRO 512GB drive and installed all drives as GPT about a two and half years ago; which require UEFI support.
Needed an extra adapter card to hold the M.2 drive. Double check your boot drive settings in the BIOS/UEFI as this is an APTIO IV which is a
mixture. CSM (Compatibility Support Mode) should be disabled if your going full GPT/UEFI on the boot drive!
Result: The mobo runs GPT/UEFI partitions without breaking a sweat.

Also always back up your boot drive BEFORE messing with it so you can always retrieve your personal data, should you experience a SNAFU.

Clover is for hackintoshes, to boot mac os on generic intel hardware. I used https://www.easyuefi.com/ to reconfigure uefi to include clover.efi and it works.

@hancor Do you have an updated bios or is this the latest for ud3h? Thanks a lot mate

As you can check F10b is the latest bios for this board:

The modded F10b offered at the beginning of this post is the latest available and works rock steady on my son’s computer which he uses for work purposes. I’ve had no complaints or issues from him at all since I modded his board BIOS/UEFI.



Hey @hancor excuse my ignorance. I’m so happy that I found your post as otherwise I had to buy new mobo + CPU+RAM and yeah. Ok so I successfully updated to your version of the MOBO 10b and I have roline adapter + Sam 970 EVO

It’s not working for me I mean I see the drive in the boot options with weird name but I see it. BTW win 10 ORIGINAL i detecting the ssd as not compatible by the MB and saying you can’t install windows here however you can select it and press NEXT After initial Install of Win10 If I want to go to the ssd to boot it’s giving me some windows error winload.exe is not available blah blah. I have 3 drives on the PC -> 1 server grade HDD, 1 hybrid SSD+HDD, 1 NVme SSD. On the second one there were windows now I can’t boot normally. (It’s not from BIOS for sure).

Therefore I will appreciate if you post or even export your mobo settings so we do it 1:1 with your setup.

Any Other suggestions from your side are highly appreciated.

Big thanks !!!

When setting up, remove ALL the drives EXCEPT NVme SSD, and install Win10 on the NVME drive only. Works like a charm.
Once you’ve got the OS installed & patched, hook up the remaining drives to suit.


Yes @hancor you were right, I had to remove all other drives, while installing windows. Then I got error message about GPT MBR which I fixed easily. And now the samsung magician is rocking with 3.3 GB/1.4 GB R/W which is amazing

thanks a lot, got bless you !!!

Delighted that worked out for you! Oh HAPPY DAY

Hi hancor this is a new BIOS with microcode 25 from GB Support. Could you check if there is any modification or update about NVMe, EFI, ME, …

Z87XUD3H-F11c.zip (5.96 MB)

updated microcode to version 25 and NvmExpressDxe_4.ffs dated 04/18/2018 enjoy

Older SATA ROM/EFI, updated CPU microcode to 25, updated network ROM/EFI, updated Marvel SATA ROM/EFI, and added NvmExpressDxe_4.ffs inserted after CSMCORE for this Aptio IV UEFI/BIOS


Z87XUD3H.F11c.zip (5.9 MB)

Hi man! My GA-Z87X-D3H rejected this bios. Is this mod bios compatible with my D3H? How can I adapt it to recognize this bios and boot nvme? Thank you for your support!

My son has had this in his computer for over a year without issue.

Use BIOS Q-Flash method, see page 89-91 of your manual.

Make sure you are using the the bios from Post #1 at the top of this thread.
BIOS is already NVMe capable, as my son is using it with the Samsung 950 PRO SSD.

Ok, i am using Q-flash. The Q-Flash show me the error message: BIOS ID CHECK ERROR. My MB model is D3H, it’s the same bios as UD3H?

no you need the full GA-Z87X-UD3H

For your GA-Z87X-D3H see here:

RE: [OFFER] Gigabyte GA-Z87X-D3H updated BIOS vF9 : NVMe mod, EFI, & microcode update > 25