Old Board P6T6 Ws Revolution

Hello Fernando,
Coud you tell me please, if it’s possible to this board P6t6 WS to use 2 Hd 3 To in raid ?
I try to replace intel raid rom v10.8.0.1303 at ID 20 loc 8086:2822 with mmtool322 with no sucsess .
Thanks a lot

@Alex13 :
Welcome at Win-RAID Forum!

It is possible, if you are able to update the Intel RAID ROM of the BIOS to v10.5 or higher.

If you tell me the mainboard manufacturer and give me the link to the latest BIOS, I may be able to test it (if I have the required time).

Dieter (alias Fernando)

Thank you :slight_smile:
My mainboard : asus P6T6 WS Revolution
Last Bios 0905

I had no problem to replace the original Intel MSM RAID ROM v8.0.0.1038 by the much newer Intel RST RAID ROM v11.2.0.1527 by using the AMI MMTool v3.26.
What I do not know is, whether this >100 KB sized module can be loaded while booting.

The only way is trying to Flash it :slight_smile: the original intel from 0905 is 40,5 Kb i tryed many roms version but they 're always bigger than 40.5Kb !
I thing it’s problem .

The size of the Intel RAID ROM doesn’t matter while flashing the BIOS.
The only problem is, whether the inserted >100 KB sized Intel RAID ROM will properly work. You can verify it by hitting CTRL+I while booting after having flashed the modded BIOS. If you have access to the Intel RST RAID Utility, everything is fine.

Aloha Fernando’s Forum,
I have been through many of the pages here before making this post. I have finally come to the conclusion that I need a little help. Forgive me if this is the wrong place for this. I am in a similar boat here where I just acquired 2 new 3TB drives. (Exciting) After much heartache I cannot seem to find a bios tool that will allow me to update my Intel MSM RAID ROM to a better version. I have tried using the AMI MMTool v3.26. However perhaps I am missing something. Different things that I have followed on this form are these different posts.
BIOS Modding: Introduction and Preparations,
[Guide] How to flash a modded ASUS/ASRock/Gigabyte AMI UEFI BIOS <- I do know that I do not have a UEFI bios. Simply trying everything.

If someone could point me in the right direction to get this asus of mine to a more compatible state, with Win 10 & 3TB drives. That would be awesome!

@609shadow :
Welcome at Win-RAID Forum!
It would have been a good idea to think about the options of your of X58 chipset mainboard before buying 2 new 3 TB sized HDDs. I cannot give you any guarantee, that you will get them properly working with your X58 chipset RAID0 system.
Only Intel RST RAID ROM modules from v10.5.x.xxxxx up re able to detect and manage > 2TB RAID Volumes. The problem of many X58 chipset mainboard BIOSes is, that it is impossible to get any Intel RAID ROM modules loaded, which are bigger sized than 100 KB.

Obviously yes. The AMI MMTool v3.26 is working flawlessly with the latest ASUS BIOS v0905, which has been designed for your special mainboard. I just was able without any problem to replace the stock Intel MSM RAID ROM v8.0.0.1038 by the TRIM in RAID0 modded Intel RST RAID ROM v11.2.0.1527.
What I do not know is, whether the 119 KB (uncompressed) sized Intel RST RAID module will be successfully loaded while booting into your RAID0 array.
If no, only ASUS is able to help you by offering you a new BIOS for your mainboard with a proper RAID ROM loader.

Good luck!
Dieter (alias Fernando)

Albeit not exactly your use case, I did get 2 x 2 TB Seagate SSHDs with an X58 motherboard to work in RAID-0 mode with Intel RST(e) RAID ROM v15.0.3.2675. The caveat is that I needed to crossflash it with another BIOS as my ASUS P6T Deluxe V2 did not originally accept such a large Option ROM. But thankfully the one of the P6X85D-E is compatible with it and provides more room for the Option ROM. Windows 10 didn 't accept a single 4 TB volume though, but I could work around it by creating two 2 TB volumes.

I have read that you usually recommend the 11.2 OROM with corresponding drivers for the ICH10R. I just wanted to let you know from my own extensive testing that I do get pretty good numbers with the combination of this v15.0.3.2675 OROM with the RSTe drivers in Windows 10 x64. The stripe size of 64k was the key that gave me the best experience. I had tried it with 4k first, but the read speeds were underwhelming.

@ms178 :
Since the Intel RST v15 platform has been designed by Intel for the latest Intel chipsets from 100-Series up, I really doubt, that it is a good idea to combine the Intel RST(e) RAID ROM v15.0.3.2675 with the Intel RST(e) RAID driver v13.6.3.1001, which both belong to totally different RST platforms.
I would like to see a benchmark comparison with the Intel RST RAID ROM/driver combo v11.2. The reason why I recommend this combo for older Intell Chipsets are the outstanding RAID0 WRITE scores after having enabled the Write-Back option.

Sure, here the results with this mixed combination with the 64k stripe size:

Chrystal Disk Mark 5.1.2 x64:

Sequential Read (Q= 32,T= 1) : 177.239 MB/s
Sequential Write (Q= 32,T= 1) : 359.958 MB/s
Random Read 4KiB (Q= 32,T= 1) : 3.505 MB/s [ 855.7 IOPS]
Random Write 4KiB (Q= 32,T= 1) : 9.826 MB/s [ 2398.9 IOPS]
Sequential Read (T= 1) : 159.577 MB/s
Sequential Write (T= 1) : 372.668 MB/s
Random Read 4KiB (Q= 1,T= 1) : 1.545 MB/s [ 377.2 IOPS]
Random Write 4KiB (Q= 1,T= 1) : 10.194 MB/s [ 2488.8 IOPS]

I have attached the ATTO results. The results do fluctuate though. Especially in Chrystal Disk Mark. I haven’t kept the results of the 11.2 combination but from my memories the read speeds were vastly inferior. Especially in ATTO with transfer sizes above 512 kb the read speeds went into the 40 - 60 MB region. Write speeds were never a problem for me with all combinations, nearly maxing out the theoretical maximum of SATA 3G. This could be specific behavior of my SSHD drives though. You have benched with SSDs.

1363_64k_Stripe.pdf (64.9 KB)